Advanced view

From BOINC
Jump to: navigation, search

Contents


The Advanced View window of the BOINC Manager provides a comprehensive user interface for monitoring and managing task and projects. It provides the user with the capability of monitoring the details of the tasks running on the client computer and the projects the client is participating in. The Advanced view can show notices from projects, disk usage, and graphs and statistics for the client computer, the user's account, and the projects the user is participating in. The Advanced View is comprehensive, but also complex, so beginners may wish to use the Simple View instead.

The BOINC Manager window can be opened from the BOINC icon in the notification area (Windows) or Dock (Mac OS X).

This page describes the newer BOINC 7.0 client software. If you are using an older version, please upgrade now.

The controls in the Advanced View are divided into six main sections, which can be selected using the tabs across the top of the window. Additionally, a set of pull-down menus provides additional management and monitoring functions.

The Notices tab

The Notices tab shows project News items and information from the project (such as when private messages arrive).

The Notices tab.

The Projects tab

The Projects tab shows information about the projects in which this computer is participating.

The projects tab.

Status messages

  • Suspended by user: The project is currently suspended.
  • Communication deferred ...: The client will wait the specified amount of time before attempting to contact the project server again. If no communication is required at that point, none will be attempted.
  • Won't get new tasks: When user clicks the "No new tasks" button in Commands panel, the BOINC client will not fill the cache for this project when it runs out of tasks. To resume project tasks, click "Allow new tasks" button.

Commands

Note: When you click on a project name this will enable the following additional buttons to the left of the list of projects:

  • Allow new tasks: Allow the project to download additional work, if needed.
  • Remove: Your computer will stop working for the project. Any tasks still in progress, uploading or to be reported will be discarded!
  • No new tasks: Do not download any additional work for this project.
  • Reset project: Stop the project's current work, if any, and start from scratch. Use this if BOINC has become stuck for some reason. Any unreported results and tasks in progress will be discarded.
  • Resume: Resumes processing of a previously suspended project.
  • Suspend: Suspends any further processing of this project.
  • Update: Connect to the project; report all completed results, get more work if necessary, and get your latest preferences.

Project Web Pages

Underneath the "Commands" buttons for the project you may find additional buttons which are specific to the selected project. These are created by the project administrators. Each button will take you do a different web page using the default browser. While the specific buttons available vary from project to project, most often there will be one button to take you to the main project web page, another to take you to your account on that project, and another to take you to the project forums. The button column is resizable, when the vertical scroll bar is not in view.

The Tasks tab

Shows the tasks currently on your computer.

The Tasks tab.

Each task is either:

  • Aborted by user: Result has been aborted.
  • Downloading: Input files are being downloaded.
  • Suspended: Result has been suspended by the client-side scheduler and will be resumed the next time the project comes up in the processing rotation.
  • Ready to report: Waiting to notify the scheduling server. In order not to stress the server too much, and the deadline is not too near, it may wait with the report until the next task of the project is done. This is intentional.
  • Ready to start: Task has not started yet, it's waiting its turn. An estimated time to the end of task is showing.
  • Waiting to run: Task has run for a bit, but has stopped while another task is now running. Elapsed CPU time and estimated percent done is shown.
  • Running: Elapsed CPU time and estimated percent done is shown.
  • Task suspended by user: Task has been suspended by the user. Use the 'Resume' button on this tab to resume the task.
  • Uploading: Output files are being uploaded.
  • Suspended - User request: BOINC is suspended, either by the Activity->Suspend menu item or pressing the Snooze button.
  • Suspended - CPU benchmarks in progress: BOINC is running CPU benchmarks. All activities are suspended.
  • Project suspended by user: Project has been suspended by user. Use the 'Resume' button on the Projects tab to resume the project.
  • Suspended - time of day: BOINC is suspended due to time-of-day preferences.

Deadline:

  • This column specifies when each task is due to be completed. BOINC will automatically increase the priority of tasks that are in danger of missing their deadline. If a deadline is missed, you will continue work on the task, but the task will also be assigned to another user. If the other user completes the task before you do, they get credit and you do not.

Note: Click on a result name to enable the following additional buttons:

  • Abort: Abort processing for a result. NOTE: This will prevent you from receiving credit for any work already completed.
  • Resume: Resumes processing of a previously suspended task. Note, this applies to tasks with status 'Suspended by user'.
  • Show active tasks/Show all tasks: Pressing this button will switch between showing all tasks in cache and only those running or waiting to run. Refreshing the window with lots of tasks showing may slow down, or even crash the manager.
  • Show graphics: Open a window showing application graphics. (Only available if that application has graphics, and when the Status of the selected task is 'running'.)
  • Suspend: Suspends any further processing of this task.
  • Properties: Opens pop-up window with additional task information.

Project Web Pages

Project administrators can add buttons to the manager to quickly navigate the project website.
The button column is resizable, when the vertical scroll bar is not in view.

The Transfers tab

Shows file transfers (uploads and downloads). These may be ready to start, in progress, and completed.

The Transfers tab.

  • Aborted by user: Result has been aborted and will be reported to the project server as a computational error.
  • Downloading: Your computer is receiving data from the project server.
  • Retry in ...: The client will wait the specified amount of time before attempting to contact the project server again.
  • Uploading: Your computer is sending data to the project server.

Note: Click on a file name to enable the following additional buttons:

  • Retry Now: Retry the file transfer now.
  • Abort Transfer: Abort the file transfer. NOTE: This will prevent you from receiving credit for any work already completed.

The Statistics tab

Shows some simple charts and graphs about the user and host progress.

The Statistics tab.

This feature requires at least three connections to each project scheduler on three different days before it starts working properly.

Command buttons

Click on any of the buttons to change to a different chart:

  • Show user total: Shows your credit totals for each project.
  • Show user average: Shows your credit averages for each project.
  • Show host total: Shows this computer's credit totals for each project.
  • Show host average: Shows this computer's credit averages for each project.

Mode view buttons

Click on any of the buttons to change the view:

  • All projects: Show all projects on individual charts.
  • One project: Shows one project at a time. The chart and a list of projects will be shown, switch between them using previous project and next project buttons.
  • All projects (sum): Shows all projects in one chart.

Project buttons

  • < Previous project / Next project > select the previous or next project from the projects list in the legend sidebar (single-project mode only.)
  • Hide project list / Show project list to hide/show the legend sidebar (BOINC 6.11.8 or later.)
  • Double left-click the graph, or the project names legend (sidebar on the right), to hide/show the legend sidebar.

Mouse commands

For the all-projects modes:

  • Left-click on a project in the project list to show/hide that project's data in the graphs

For the single-graph views, i.e. "One project" and "All projects (sum)":

  • Left-click on a project in the project list to select that project for graphing
  • Left-click on the graph to display the X and Y values for any position on the graph
  • Left-click-drag to highlight an area on the graph you wish to zoom in to
  • Right-click to reset the graph
  • Right-click-drag to pan the graph

On Macintosh, use control-click instead of right-click.

The Disk tab

This shows how much disk space is currently being used by BOINC and each project.

The Disk tab.

BOINC Manager Menus

The BOINC manager has the following menus:

  • File
    The BOINC Manager File menu.
    • Close Window: Minimize the BOINC Manager to the notification area or Dock. Note that closing the manager using the [X] button on the title bar will close the window, not exit BOINC.
    • Exit: Exit the BOINC manager and all running BOINC applications. No further work will take place until you run the BOINC manager again. On Mac OS X, this is under the BOINC menu as Quit BOINC.


  • View
    The BOINC Manager View menu.
    • Shows shortcut keys to Notices, Projects, Tasks, Transfers, Statistics, Disk Usage and Simple View.
Notices:      SHIFT + CTRL + N
Projects:     SHIFT + CTRL + P
Tasks:        SHIFT + CTRL + T
Transfers:    SHIFT + CTRL + X
Statistics:   SHIFT + CTRL + S
Disk usage:   SHIFT + CTRL + D
Simple View:  SHIFT + CTRL + V


  • Tools
    The BOINC Manager Tools menu.
    • Add project or account manager: Enroll this computer in a project or account manager. For projects, you will be asked to enter the project's URL and your account details, which is the email address and password you desire to use for an existing or new project registration. For World Community Grid enter the member name and password previously established when registering there (required!). Also see topic Choosing and joining projects for more registration information. For account manager, you can attach to one or more new projects using an account manager web site. See Account managers.
    • Options: Opens a dialog allowing you to set up BOINC Manager.
      • General
        The BOINC Manager Options tool
        • Language: Allows you to change the language of the Manager and Event Log. The default language will be detected from the language and country settings of your operating system.
        • Notices reminder interval: Sets how often you will be reminded that new Notices are in. Values range from Never to 1 week.
        • Run Manager at login?: When checked, BOINC Manager will start each time you log in to Windows.
        • Enable Manager exit dialog?: When checked, when you exit BOINC Manager through File->Exit, you will be asked if you want to stop running the tasks as well.
      • Connections: Allows you to set up a connection through a modem or VPN connection.
      • HTTP Proxy: Allows you to set BOINC up to use a HTTP Proxy server.
      • SOCKS Proxy: Allows you to set BOINC up to use a SOCKS Proxy server.
    • Computing preferences: Opens a dialog allowing you to override your preferences locally.


  • Activity
    The BOINC Manager Activity menu.
    • Run always: Do work, regardless of preferences.
    • Run based on preferences: Do work when your preferences allow it.
    • Suspend: Stop work (both computation and network).
    • Use GPU always: Override preferences and always allow BOINC to use the GPU. May slow your system down immensely.
    • Use GPU based on preferences: Run GPU tasks only based on preferences.
    • Suspend GPU: Stop doing work on the GPU.
    • Network activity always available: Always allow BOINC to contact the project servers when it needs to.
    • Network activity based on preferences: Allow BOINC to contact the project servers only when your preferences allow it.
    • Network activity suspended: Setting this keeps BOINC from attempting to contact any of the project servers. It is useful for those on dial-up connections who do not want to be bothered with BOINC prompting to connect or disconnect for a time.
  • Notes:
    • The GPU activity menu is only visible if BOINC actually detected a GPU and it is allowed to use it (not ignored or excluded). These activities apply to the GPU only, not to the CPU preferences.
    • Selecting an option that requires contacting a project will temporarily enable network activity regardless of the network setting. This includes updating a project, retrying file transfers, retrying communications and attaching to projects. Network activity will remain enabled for five minutes.
    • Selecting Snooze from the icon menu overrides the 'run....' setting and suspends activity for one hour. Deselecting Snooze, or selecting the Activity menu items Run always or Run based on preferences cancels Snooze.


  • Advanced
    The BOINC Manager Advanced menu.
    • Select Computer: Allows you to control BOINC on a different computer. You can optional specify a port number (host:port), allowing you to control a client via SSH tunneling. Run the client with the --gui_rpc_port option.
    • Shut down connected client: Shut down the currently connected core client.
    • Run CPU benchmarks: Run benchmark functions, which measure the speed of your processor. BOINC does this automatically, but you can repeat it whenever you want. The results are shown in the Event Log window.
    • Do network Communications: Force a retry of any project deferred communications.
    • Read config file: Reread configuration info from the cc_config.xml file.
    • Read local prefs file: Reread preferences from the global_prefs_override.xml file.
    • Launch another BOINC Manager: Opens another BOINC Manager to monitor another BOINC with, such as over the network.
    • Event Log: Shows status and error messages in a separate window.


  • Help
    The BOINC Manager Help menu.
    • BOINC Help: Opens the Wiki page with useful starter links.
    • BOINC Manager: Open this web page with instructions for using the BOINC manager. The F1 function key also does this.
    • BOINC website: Open the main BOINC web page.
    • About BOINC Manager: Show BOINC manager version number and whether the client is 32bit or 64bit. Note: on the Macintosh, this command is under the BOINC menu.


The Event Log window

Shows status and error messages. You can control what messages are shown. Messages are also written to the file 'stdoutdae.txt'.

The BOINC Manager Event Log window.

Click on one or more messages to enable the following additional buttons:

  • Show only this project: When selected, shows only the messages from the project selected. Can only show one project at a time. Will continue showing this project until deselected.
  • Copy All: Copies all the messages to the clipboard.
  • Copy Selected: Copies the highlighted messages to the clipboard. To highlight multiple messages, hold down the SHIFT key (Windows) or Command key (Mac) and then click on the messages you want to store in the clipboard. You can then click on the 'Copy selected messages' button to copy them to the clipboard.
  • Close: Closes the Event Log window. Else it'll stay open indefinitely, or until BOINC Manager is closed.
  • ?: Shows additional help for what buttons do, when used and clicked over them.

Menu names and other text in the BOINC manager can be displayed in languages other than English.

Personal tools