Simple view

From BOINC
Jump to: navigation, search

Contents


The Simple View window is the default interface of The BOINC Manager. It provides a simple set of controls and is designed for non-technical users. More control is provided by the Advanced view.

The Simple View window can be opened from the BOINC icon in the notification area (Windows) or Dock (Mac OS X).

This page describes the current BOINC 7.x client software. If you are using an older version, please upgrade now.

The Main View

The Simple View window looks like this on Windows or Mac:

The BOINC Manager Simple View window on Windows, showing the SETI@home project.
  
The BOINC Manager Simple View window on the Macintosh, showing the Einstein@Home project.

The Simple View is compliant with the majority of screen readers for the visual impaired.
The whole of the Simple View can be skinned, including the command buttons. If you are interested in making skins, please check New Simple View Design.

Top Bar Menu

The Simple View has the following menus:

  • File
    File menu
    • Close Window: Minimizes the BOINC Manager to the notification area or Dock. Note that closing the manager using the [X] button on the title bar will close the window, not exit BOINC. Shortcut key combo: CTRL + W.


  • View
    View menu
    • Advanced View...: Will switch BOINC Manager to show the Advanced view. Shortcut key combo: SHIFT + CTRL + A.
    • Skin: Allows you to switch between different skins, when you have installed different ones.


  • Tools
    Tools menu
    • Computing preferences...: Opens a dialog allowing you to override your preferences locally.
    • Options...: Opens a dialog allowing you to select your preferred language, how often you wish to be reminded of new notices, etc. If you connect to the web through an HTTP or SOCKS proxy, use this dialog to enter its address and port. You may also enter a comma-separated list of URLs for which a proxy should not be used. Windows only: use this dialog to tell BOINC your method of connecting to the Internet when it isn't detected by default.


  • Help
    Help menu
    • BOINC Help: Opens the Wiki page with useful starter links.
    • BOINC Manager: Open this web page with instructions for using the BOINC manager. The F1 function key also does this.
    • BOINC website: Open the main BOINC web page.
    • About BOINC Manager: Show BOINC manager version number and whether the client is 32bit or 64bit. Note: on the Macintosh, this command is under the BOINC menu.


Tasks Window

In the Tasks window, when you click on the Tasks drop-down button, you can see which project's tasks are running. You can select the individual ones that are showing. A red sign in front of the task means it's stopped/suspended, a green sign means that it is busy and in progress. Underneath this is the slide show of images about the selected task and project. When there is no slide show available, BOINC will show the project description in this place.

Slide show with images Slide show with text

The Elapsed time shows how long the active task has been worked on, the Remaining (estimated) value shows how long BOINC estimates that it's going to take to finish this task. Underneath that is a progress bar, which shows the progress of the task in percentages.

This is followed by a Task commands button, through which you can command what BOINC should do with the task:

    • Graphics: If the science application supports graphics, this option will be enabled. Graphics will open in a separate window. Not all projects have graphics.
    • Suspend: Suspends the selected task.
    • Abort: Aborts the selected task. Aborting will delete the file from the computer, you will not be able to get it back.
    • Properties: Shows the properties of the selected task.


Projects Window

In the Projects window, when you click on the Add Project button, the Add project or Account Manager wizard pops up, allowing you to add a new project or attach BOINC to an account manager. When you click on the Tasks drop-down button, you can select whichever project you like, and then use the Project Web Pages button to navigate to the project, while the Project Commands button allows you to give specific commands to BOINC.

The "Work done for this project" line shows the total credit you have received for this project.

  • Project Web Pages
    • These buttons are generated by the project and will change from project to project. In general though, there will be a direct link to the project web pages, the forums, and to your account on that project.


  • Project Commands
    • Update: Connect to the project; report all completed results, get more work if necessary, and get your latest preferences.
    • Suspend/Resume: Suspends or resumes any further processing of this project.
    • No new tasks: Do not download any additional work for this project.
    • Allow new tasks: Allow the project to download additional work. Only when status is No new tasks.
    • Reset project: Stop the project's current work, if any, and start from scratch. Use this if BOINC has become stuck for some reason. Any unreported results and tasks in progress will be discarded.
    • Remove: Your computer will stop working for the project. Any tasks still in progress, uploading or to be reported will be discarded!
    • Properties: Shows the properties of the selected project.


The Event Log window

The event log shows detailed messages about what BOINC is doing. Press CTRL+SHIFT+E to open the Event Log window. In Simple View it can only be reached by the keyboard combination.

Advanced level: you can control what messages are shown. Messages are written to the file 'stdoutdae.txt'.

The BOINC Manager Event Log window.

Click on one or more messages to enable the following additional buttons:

  • Show only this project: When selected, shows only the messages from the project selected. Can only show one project at a time. Will continue showing this project until deselected.
  • Copy All: Copies all the messages to the clipboard.
  • Copy Selected: Copies the highlighted messages to the clipboard. To highlight multiple messages, hold down the CTRL key (Windows) or Command key (Mac) and then click on the messages you want to store in the clipboard. You can then click on the 'Copy selected messages' button to copy them to the clipboard.
  • Close: Closes the Event Log window. Else it'll stay open indefinitely, or until BOINC Manager is closed.
  • ?: Shows additional help for what buttons do, when used and clicked over them.


Personal tools