Linux: 6.6.36 and 6.6.37 need run_client started in shell: Why?

Message boards : BOINC Manager : Linux: 6.6.36 and 6.6.37 need run_client started in shell: Why?
Message board moderation

To post messages, you must log in.

AuthorMessage
Mdoerner

Send message
Joined: 20 Jul 09
Posts: 3
United States
Message 26139 - Posted: 20 Jul 2009, 14:23:35 UTC

Hi Guys,

Since version 6.6.33 I have needed to start the run_client separately in a shell because 6.6.36 and 6.6.37 do not start the run_client when run_manager has been started. When will this be fixed? Thanks.

Mike Doerner
ID: 26139 · Report as offensive
Profile KSMarksPsych
Avatar

Send message
Joined: 30 Oct 05
Posts: 1239
United States
Message 26178 - Posted: 21 Jul 2009, 8:59:29 UTC

*sigh*

I reported this right after 6.6.37 came out and was ignored.
Kathryn :o)
ID: 26178 · Report as offensive
Mdoerner

Send message
Joined: 20 Jul 09
Posts: 3
United States
Message 26237 - Posted: 23 Jul 2009, 16:02:35 UTC

So who is the individual on the BOINC team that released 6.6.36 and 6.6.37 on Linux? Who do we contact to fix this, or they just going to keep shovelling untested apps out the door?

Doerner
ID: 26237 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14729
Netherlands
Message 26238 - Posted: 23 Jul 2009, 20:25:17 UTC - in response to Message 26237.  

When you go to the BOINC download page, you will see that 6.6.36 is labeled Development version (MAY BE UNSTABLE - USE ONLY FOR TESTING)

So 6.6.36 and .37 are effectively ALPHA versions. In which case you should report these problems to the BOINC Alpha email list. This list needs registration.
ID: 26238 · Report as offensive
Mdoerner

Send message
Joined: 20 Jul 09
Posts: 3
United States
Message 26242 - Posted: 24 Jul 2009, 16:01:37 UTC - in response to Message 26238.  

I'm not gonna join an email list to post a problem.....that's what the blogs are for, right?

Mike D

PS Yes, I know they're development versions, but doesn't someone actually RUN the installation before releasing it? Nothing personal, just an observation.
ID: 26242 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14729
Netherlands
Message 26245 - Posted: 24 Jul 2009, 17:41:38 UTC - in response to Message 26242.  
Last modified: 24 Jul 2009, 17:43:26 UTC

I'm not gonna join an email list to post a problem.....that's what the blogs are for, right?

These aren't blogs, but forums. The developers hardly read these, they've got better things to do with their time than constantly monitor forums. Hence the email lists, where they react to much faster.

If you want to run development versions of the software and find errors, the alpha email list is the place to report them, your direct line to the developers and the place where all the alpha testers will read about it, so they can test to see if they have the same behaviour or not and relate their experience on the matter.

The developers don't so much test the versions they release, that's what the alpha testers are for, with that group of people reporting to the alpha email list when they have problems.

What are these forums for then? Mostly for asking questions or help on the publicly released BOINC versions, getting answers from the people in the know in the BOINC community and for asking for help on the server side of the software. We're not the BOINC Alpha forums, while the actual existing BOINC Alpha forums aren't the place either to report your problems to.
ID: 26245 · Report as offensive
dentaku

Send message
Joined: 14 Dec 06
Posts: 74
Germany
Message 26707 - Posted: 20 Aug 2009, 18:38:21 UTC

My workaround for this: I changed run_manager to

#!/bin/bash
sleep 5s
cd "/home/BOINC"
./boinc $@ &
exec ./boincmgr $@ 

BOINC 7.2.42 (x86_64) on Linux Ubuntu 16.04 (64 Bit), AMD APU 7850K 3.7 GHz, 32 GB RAM.
ID: 26707 · Report as offensive
dentaku

Send message
Joined: 14 Dec 06
Posts: 74
Germany
Message 26708 - Posted: 20 Aug 2009, 18:40:34 UTC - in response to Message 26238.  

When you go to the BOINC download page, you will see that 6.6.36 is labeled Development version (MAY BE UNSTABLE - USE ONLY FOR TESTING)

So 6.6.36 and .37 are effectively ALPHA versions. In which case you should report these problems to the BOINC Alpha email list. This list needs registration.


Well, iof you go to the official download website (http://boinc.berkeley.edu/download.php) version 6.6.36 is displayed to download - no mentioning of "alpha".... I just downloaded this yesterday and also noticed that the clienbt doesn't start anymore.
BOINC 7.2.42 (x86_64) on Linux Ubuntu 16.04 (64 Bit), AMD APU 7850K 3.7 GHz, 32 GB RAM.
ID: 26708 · Report as offensive
Profile KSMarksPsych
Avatar

Send message
Joined: 30 Oct 05
Posts: 1239
United States
Message 26723 - Posted: 21 Aug 2009, 9:42:48 UTC - in response to Message 26708.  

When you go to the BOINC download page, you will see that 6.6.36 is labeled Development version (MAY BE UNSTABLE - USE ONLY FOR TESTING)

So 6.6.36 and .37 are effectively ALPHA versions. In which case you should report these problems to the BOINC Alpha email list. This list needs registration.


Well, iof you go to the official download website (http://boinc.berkeley.edu/download.php) version 6.6.36 is displayed to download - no mentioning of "alpha".... I just downloaded this yesterday and also noticed that the clienbt doesn't start anymore.


It was promoted to a stable release because the devs are working on 6.10 now.
Kathryn :o)
ID: 26723 · Report as offensive

Message boards : BOINC Manager : Linux: 6.6.36 and 6.6.37 need run_client started in shell: Why?

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.