Template master page : language_select.php link missing

Message boards : Web interfaces : Template master page : language_select.php link missing
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Ananas

Send message
Joined: 27 Jun 06
Posts: 305
Germany
Message 19689 - Posted: 22 Aug 2008, 20:14:53 UTC

Why has language_select.php even been created if the project home doesn't contain a link to it?

It's very useful to get rid of those incomplete translation and messy language cocktails.
ID: 19689 · Report as offensive
Pepo
Avatar

Send message
Joined: 3 Apr 06
Posts: 547
Slovakia
Message 20732 - Posted: 10 Oct 2008, 9:54:25 UTC - in response to Message 19689.  

I believe I've seen it referenced (and tried it few times back then) off of the SETI homepage, but it was many many years ago.

Peter
ID: 20732 · Report as offensive
Profile Gundolf Jahn

Send message
Joined: 20 Dec 07
Posts: 1069
Germany
Message 20733 - Posted: 10 Oct 2008, 10:44:07 UTC - in response to Message 20732.  
Last modified: 10 Oct 2008, 10:46:20 UTC

It' still there, directly below "Site search". And on the Einstein homepage under "Returning participants".
ID: 20733 · Report as offensive
Pepo
Avatar

Send message
Joined: 3 Apr 06
Posts: 547
Slovakia
Message 20734 - Posted: 10 Oct 2008, 11:20:19 UTC - in response to Message 20733.  
Last modified: 10 Oct 2008, 11:21:44 UTC

And on the Einstein homepage under "Returning participants".

Yes, I remember it looking out and behaving like Einstein's Language selection.

It' still there, directly below "Site search".

The SETI version is missing all language selection links. Just automatic selection according to the browser's settings is there.

Many other projects contain the page complete. Possibly the home link got lost or "optimized away" during the development? (Default BOINC home page might contain a link to "Miscellaneous links" page, where such rarely used local links could reside.)

Peter
ID: 20734 · Report as offensive
Profile Gundolf Jahn

Send message
Joined: 20 Dec 07
Posts: 1069
Germany
Message 20737 - Posted: 10 Oct 2008, 13:06:12 UTC - in response to Message 20734.  

It' still there, directly below "Site search".

The SETI version is missing all language selection links. Just automatic selection according to the browser's settings is there.

Oops, just saw the link, didn't follow it, since I, too, remembered it being like the Einstein one (long, long ago :-).

Gruß,
Gundolf
ID: 20737 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14733
Netherlands
Message 20740 - Posted: 10 Oct 2008, 17:06:39 UTC

I sent the Seti languages problem off to David and Eric. David fowarded it to Jens with this message:

David Anderson wrote:
Jens:
When this happens it means that one of the .po files has a syntax error.
Last time I fixed it by getting rid of ro.po (I think).

It looks like many of the .po files are out of date, and use tokens (like APPS_TITLE) instead of strings. These files won't work, and we may as well get rid of them.

-- David

ID: 20740 · Report as offensive

Message boards : Web interfaces : Template master page : language_select.php link missing

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.