internal error: shared memory

Message boards : API : internal error: shared memory
Message board moderation

To post messages, you must log in.

AuthorMessage
doogan

Send message
Joined: 21 Jun 07
Posts: 3
Message 11722 - Posted: 19 Jul 2007, 23:56:41 UTC

I'm trying to develop my first BOINC application, and I'm getting errors when the client tries to request for work I get an internal error. My cgi.log file looks like this:

shmget: No such file or directory
2007-07-05 22:47:42.1890 [PID=7568 ] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-08 22:21:50.8715 [PID=21686] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-08 23:22:44.2955 [PID=23594] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-09 00:22:33.3439 [PID=25104] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-09 01:22:28.0109 [PID=26566] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-09 01:28:35.1450 [PID=26713] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-09 02:30:48.0625 [PID=28232] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-09 03:30:32.3137 [PID=29688] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-09 04:30:17.4512 [PID=31160] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
shmget: No such file or directory
2007-07-09 05:31:18.4334 [PID=32656] [CRITICAL] Can't attach shmem: -144 (feeder not running?)

and so on like this. Any help would be much appreciated.
ID: 11722 · Report as offensive
doogan

Send message
Joined: 21 Jun 07
Posts: 3
Message 11723 - Posted: 20 Jul 2007, 0:08:48 UTC - in response to Message 11722.  

scratch that last post, I seem to have fixed that problem and have a different one now. The message for that is this:

shmat: Permission denied
2007-07-19 01:47:18.4982 [PID=2658 ] [CRITICAL] Can't attach shmem: -146 (feeder not running?)

What I did to fix the last problem was to change some of the ownerships and permissions, so I have a feeling that I need to do something similar. If that is the case, could someone tell me what the permissions need to be.
ID: 11723 · Report as offensive
Profile KSMarksPsych
Avatar

Send message
Joined: 30 Oct 05
Posts: 1239
United States
Message 11728 - Posted: 20 Jul 2007, 15:04:20 UTC

You'll probably want to post to the boinc_projects mailing list as the developers don't really frequent these boards.

You'll probably get a fairly speedy response as well.
Kathryn :o)
ID: 11728 · Report as offensive
Eric Myers
Avatar

Send message
Joined: 12 Feb 06
Posts: 232
United States
Message 11789 - Posted: 26 Jul 2007, 2:53:17 UTC - in response to Message 11723.  

scratch that last post, I seem to have fixed that problem and have a different one now. The message for that is this:

shmat: Permission denied
2007-07-19 01:47:18.4982 [PID=2658 ] [CRITICAL] Can't attach shmem: -146 (feeder not running?)

What I did to fix the last problem was to change some of the ownerships and permissions, so I have a feeling that I need to do something similar. If that is the case, could someone tell me what the permissions need to be.


See http://www.spy-hill.net/~myers/help/boinc/Create_Project.html#file_perms
-- Eric Myers

"Education is not the filling of a pail, but the lighting of a fire." -- William Butler Yeats
ID: 11789 · Report as offensive
zombie67
Avatar

Send message
Joined: 14 Feb 06
Posts: 135
United States
Message 11790 - Posted: 26 Jul 2007, 3:29:07 UTC - in response to Message 11728.  

You'll probably want to post to the boinc_projects mailing list as the developers don't really frequent these boards.

Wait....what? Then what's the point of having them? That's why I come here instead of just asking at the project's boards.
Reno, NV
Team: SETI.USA
ID: 11790 · Report as offensive
Nicolas

Send message
Joined: 19 Jan 07
Posts: 1174
Argentina
Message 12044 - Posted: 13 Aug 2007, 0:09:49 UTC - in response to Message 11790.  

You'll probably want to post to the boinc_projects mailing list as the developers don't really frequent these boards.

Wait....what? Then what's the point of having them? That's why I come here instead of just asking at the project's boards.

Oh who knows. Developers don't frequent these boards, but they refuse to close them (the dev-related ones like API). I really don't see the point. People post here only to be redirected to the lists...
ID: 12044 · Report as offensive
Keck_Komputers
Avatar

Send message
Joined: 29 Aug 05
Posts: 304
United States
Message 12048 - Posted: 13 Aug 2007, 12:36:42 UTC - in response to Message 11790.  

You'll probably want to post to the boinc_projects mailing list as the developers don't really frequent these boards.

Wait....what? Then what's the point of having them? That's why I come here instead of just asking at the project's boards.

I would consider Eric a developer (3 posts back), JM7 is also active here. So I would consider this forum a first place to post and the mailing lists a backup if your problem is not resolved.
BOINC WIKI

BOINCing since 2002/12/8
ID: 12048 · Report as offensive
Eric Myers
Avatar

Send message
Joined: 12 Feb 06
Posts: 232
United States
Message 12053 - Posted: 13 Aug 2007, 15:19:08 UTC - in response to Message 12048.  

I would consider Eric a developer (3 posts back), JM7 is also active here. So I would consider this forum a first place to post and the mailing lists a backup if your problem is not resolved.


I think it's safe to say that right now most of the developers don't read this forum, though I hope some of them will check here more often. I agree with John that posting here is a good first step. I like this format better than an e-mail list because we have a record (like a logook) of the discussion.

I think it would also be useful for those who know the system better (devs or alpha or just experienced users) to post tickets in Trac on behalf of newer participants who are reporting problems but may not be familiar with Trac.

-- Eric Myers

"Education is not the filling of a pail, but the lighting of a fire." -- William Butler Yeats
ID: 12053 · Report as offensive
Profile Gandalf

Send message
Joined: 23 Aug 07
Posts: 7
India
Message 13623 - Posted: 6 Nov 2007, 18:20:04 UTC

Hi doogan

I am also facing the same problem with cgi.log reading

2007-11-06 23:01:21.0463 [PID=6673 ] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
2007-11-06 23:01:21.0464 [PID=6673 ] [CRITICAL] uid 33 euid 33 gid 33 eguid33

and i've not been able to fix it.
ID: 13623 · Report as offensive
Nicolas

Send message
Joined: 19 Jan 07
Posts: 1174
Argentina
Message 13624 - Posted: 6 Nov 2007, 20:26:29 UTC - in response to Message 13623.  

Hi doogan

I am also facing the same problem with cgi.log reading

2007-11-06 23:01:21.0463 [PID=6673 ] [CRITICAL] Can't attach shmem: -144 (feeder not running?)
2007-11-06 23:01:21.0464 [PID=6673 ] [CRITICAL] uid 33 euid 33 gid 33 eguid33

and i've not been able to fix it.

Note "feeder not running?". Did you ./bin/start the project already?
ID: 13624 · Report as offensive

Message boards : API : internal error: shared memory

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.