Posts by Bill

1) Message boards : GPUs : RTX 3060 and CMP (Message 103103)
Posted 19 Feb 2021 by Bill
Post:
I see that Nvidia is going to nerf the performance of the 3060 if it is running algorithms for cryptocurrency, and that they are developing a Cryptocurrency Mining Processor (CMP) to be released later this year.

Just curious if anyone with more knowledge than me knows if the 3060 is going to be crippled in BOINC (I'm guessing no, but maybe?). Also curious if these CMPs would be good for crunching BOINC as well.

I thought I recall someone on the SETI message boards had a contact at NVidia when there was a driver problem. Perhaps they can contact that same person to get a better understanding of the situation? I'm mentioning it so the community could get ahead of a problem before it manifests with other 3060 users.
2) Message boards : Questions and problems : Boinc is running, but I can't see anything in Boinc Manager (Ubuntu 18.04.5) (Message 100656)
Posted 9 Sep 2020 by Bill
Post:
Thanks for dumbing it down, Keith. I tried the command line you provided, once with "$(whoami)", the other with my actual user name. I do understand that Linux is very finicky with case sensitivity, so I made sure capitalization was correct. However, regardless of what I type for the usermod command, there is no output, and when I check the groups command, it still only says "boinc" and "video". Am I doing something wrong?

PS - I feel like BOINC needs a forum group for "I'm using Linux for BOINC only, please help with my novice questions" forum. ;)
3) Message boards : Questions and problems : Boinc is running, but I can't see anything in Boinc Manager (Ubuntu 18.04.5) (Message 100620)
Posted 6 Sep 2020 by Bill
Post:
You are running the service version of BOINC. The BOINC client runs in the boinc group and belongs to that group as well as the video group if you use the gpu.
Your user needs to belong to those groups also.
Got it. For the record, this laptop does not have any usable GPUs. Old Core 2 Duo.

You will also need to add yourself to the boinc group in order for the Manager to connect:

# usermod -a -G boinc $(whoami)
Sorry, I understand what you said, I don't know how to apply usermod here. I typed in the code line verabim at a command prompt, and nothing happened. I even tried it with my user name.

You can check the users in the boinc group with:
$ groups boinc
boinc : boinc video
This is correct, boinc and video are the users for this group. I assume my user name should be in this list as well?

Check your file permissions of the gui_rpc_auth.cfg file. It should have a 640 or 755 attribute. There should already be a softlink to the file in the /etc/boinc-client directory.
Make another softlink to the file in your home directory.
$ cd ~/
$ ln -s /var/lib/boinc/gui_rpc_auth.cfg gui_rpc_auth.cfg
# chmod 640 gui_rpc_auth.cfg

You can either null out the default hashed password or put in your own. Save the file and reboot and you should connect the Manager to the client.
I tried the commands you provided here, nothing happened, at least nothing I could observe.

Here's where I'm really confused. I found the gui_rpc_auth.cfg file in two locations. One is in the etc/boinc-client folder as you mentioned. This has rw permissions for root, read-only for boinc, and no access for others. The second is in Home, with rw for the owner, read-only for my group, and none for other. I'm not sure what to do with that.

Additionally, in the Home directory there are other boinc files, all_projects_list, client_state, coproc_info, etc. Shouldn't all those files be in a separate boinc directory, like in Windows? What I don't get is how this all happened. I don't touch this computer for anything, it just crunches all day. The only thing I literally do is check for Ubuntu and Boinc updates on occasion, and run those when available.
4) Message boards : BOINC client : 7.16.11 available for testing for Windows and Macintosh (Message 100604)
Posted 5 Sep 2020 by Bill
Post:
Ok, I see what I did now. I did request an account over a year ago, I just had not used it. I found my password so now I have access to the account. I think I ignored the password earlier because I didn't understand it was linked to the alpha section of the Boinc website. Nothing in Dr. Anderson's email mentioned the alpha part of the Boinc website, and in my opinion, it isn't clear on the Alpha Instruction Wikitrac that you have to go there; it is first mentioned in a link under the "How to report test results" section.

I think I was getting it confused with the Google Group for alpha testers, which I have been lurking this entire time, and is mentioned more frequently on that page.
5) Message boards : BOINC client : 7.16.11 available for testing for Windows and Macintosh (Message 100596)
Posted 4 Sep 2020 by Bill
Post:
Ok, I see now. I haven't created an alpha account yet, but I did sign up for the alpha mailing list awhile ago. That was my confusion.

For those that don't know, the main alpha page is here: https://boinc.berkeley.edu/alpha/. This does not appear to be linked on the main BOINC website.

Also interesting, on that same page, I click on Create Account at the bottom of the page, and I get the error:
"Unable to handle request
This project has disabled account creation"

So, I don't know for those that are new how they can participate in this.
6) Message boards : BOINC client : 7.16.11 available for testing for Windows and Macintosh (Message 100589)
Posted 4 Sep 2020 by Bill
Post:
I seem to recall the alpha testing duration was rather short last time. Any idea how long we have to test before a final version is released?

Also, when I click on the alpha test result link, it asks for my password. I assume this is the same login as for the BOINC message board, but it says I have an invalid password. Should I be using a different login?
7) Message boards : Questions and problems : Boinc is running, but I can't see anything in Boinc Manager (Ubuntu 18.04.5) (Message 100574)
Posted 3 Sep 2020 by Bill
Post:
I'm running a laptop with Ubuntu 18.04.5 with the latest CostamagnaGianfranco version of BOINC. Its been working fine for a long time, but suddenly I haven't be able to see ANYTHING in BOINC manager. No tasks, no statistics, no disk usage. Its as if BOINC Manager is open, but no information is being displayed. The client is running, the laptop is warm.

When I load BOINC Manager, it says: "BOINC Manager - Connection Error - gui_rpc_auth.cfg exists but can't be read. Check the file permissions."

Additionally, when I try to quit out of boinc in the command window, I type 'boinccmd --quit', but I get back "Authorization failure: -155", which my limited research points to a permission problem as well.

I'm a Linux noob, so any hand holding would be helpful. Thanks!
8) Message boards : Questions and problems : Is it possible to disable applications in the app_config file? (Message 100541)
Posted 1 Sep 2020 by Bill
Post:
No, not that way. app_config.xml doesn't pass enough information back to the server about what work you can handle..
As a matter of interest, why wouldn’t max_concurrent = 0 work?
Hmm. Hadn't thought of that :-)

My worry would be that BOINC downloads a task, but never runs it. Bill would be fetching tasks from Einstein as normal, with no control over what comes down the line - rather different from, say, 'resource share 0' for a backup project.

One of us should try it sometime ...
My uneducated guess is that Richard is correct. However, I will give it a shot...once I troubleshoot a MIlkyway problem I am having.
9) Message boards : Questions and problems : Is it possible to disable applications in the app_config file? (Message 100532)
Posted 1 Sep 2020 by Bill
Post:
I have several computers running Einstein@home. Conventional wisdom suggests that when you run this project to either choose the Gamma-ray or Gravitational Wave application, but not both. I know you can enable/disable running these projects in the project preferences for my account, but that only applies if the computer is classified as "home", "school", etc. All of my computers are designated for home (being factually correct). Although I could change the assignment of where they are located, that means I am following a (potentially) completely different set of parameters (CPU % usage, max ram usage, etc.) per computer.

I suppose what I'm getting at is hypothetically speaking, if I had 20 computers, each running different projects, is there a way to cherry-pick which applications I want each computer to use?
10) Message boards : GPUs : I can't get Intel HD Graphics 4000 to work on Ubuntu 18.04 (Message 98535)
Posted 16 May 2020 by Bill
Post:
If the command lspci shows the intel GPU, then it might still work.
it's an older architecture, but not all Intel IGPs are supported.

There are only a few projects supporting Intel CPUs.
You'll need to install OpenCL for Intel

See this post:
https://boinc.berkeley.edu/forum_thread.php?id=13256&postid=96195
When I type lspci, I get:
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
So, something is there...
I'm trying to install OpenCL for Intel, but either it didn't work or I didn't do it right. Any additional hand-holding on that front would be hepful.
11) Message boards : GPUs : I can't get Intel HD Graphics 4000 to work on Ubuntu 18.04 (Message 98308)
Posted 3 May 2020 by Bill
Post:
Does intel_gpu_top work? (Install Intel GPU tools)
I don't think it does. I typed that in literally, and I got this output:
(intel_gpu_top:12236) intel-mmio-CRITICAL: Test assertion failure function intel_mmio_use_pci_bar, file ../../lib/intel_mmio.c:145:
(intel_gpu_top:12236) intel-mmio-CRITICAL: Failed assertion: !(error != 0)
(intel_gpu_top:12236) intel-mmio-CRITICAL: Last errno: 13, Permission denied
(intel_gpu_top:12236) intel-mmio-CRITICAL: Couldn't map MMIO region
Stack trace:
  #0 [_init+0x7b87]
  #1 [_init+0x5420]
  #2 [_init+0xe85]
  #3 [__libc_start_main+0xe7]
  #4 [_init+0x1c92]
Test (null) failed.
**** DEBUG ****
(intel_gpu_top:12236) intel-chipset-DEBUG: Test requirement passed: pci_dev
(intel_gpu_top:12236) intel-mmio-CRITICAL: Test assertion failure function intel_mmio_use_pci_bar, file ../../lib/intel_mmio.c:145:
(intel_gpu_top:12236) intel-mmio-CRITICAL: Failed assertion: !(error != 0)
(intel_gpu_top:12236) intel-mmio-CRITICAL: Last errno: 13, Permission denied
(intel_gpu_top:12236) intel-mmio-CRITICAL: Couldn't map MMIO region
(intel_gpu_top:12236) igt-core-INFO: Stack trace:
(intel_gpu_top:12236) igt-core-INFO:   #0 [_init+0x7b87]
(intel_gpu_top:12236) igt-core-INFO:   #1 [_init+0x5420]
(intel_gpu_top:12236) igt-core-INFO:   #2 [_init+0xe85]
(intel_gpu_top:12236) igt-core-INFO:   #3 [__libc_start_main+0xe7]
(intel_gpu_top:12236) igt-core-INFO:   #4 [_init+0x1c92]
****  END  ****
FAIL (-1.000s)

I'm not sure what to do next.

According to Intel's website:

To allow NEO access to GPU device make sure user has permissions to files /dev/dri/renderD*.
I looked in /dev/dri, and there is no renderD folder.
To be clear, Boinc does not see my GPU at all, but I'm guessing by this output, Ubuntu is not seeing my GPU either (at least not more than a generic VGA driver).
12) Message boards : GPUs : I can't get Intel HD Graphics 4000 to work on Ubuntu 18.04 (Message 98107)
Posted 28 Apr 2020 by Bill
Post:
I recently have started using this computer for Boinc, running Einstein@home exclusively. It has an Intel i7-3612QM, which has integrated Intel HD Graphics 4000.

For this computer, I changed the OS to Ubuntu 18.04 and then installed boinc (Costamagnagianfranco, currently on version 7.16.6).

Anyway, Boinc is not detecting the HD Graphics 4000. The event log says "No usable GPUs found". I've done some searching online, and it appears that this Ivy Bridge chip should be recognized for GPU support, as long as OpenCL 1.2 is available (please correct me if I am wrong).

I found Intel's support for OpenCL on Linux here, and literally, I ran these lines at terminal:
sudo add-apt-repository ppa:intel-opencl/intel-opencl
sudo apt update
sudo apt install intel-opencl-icd

Still, no luck. What am I missing? I'm a casual Linux user. That is, I search online enough to get me going, so please forgive me if I ask a bunch of noob questions going forward.

Any help would be appreciated. Thanks!
13) Message boards : Questions and problems : Ubuntu & Android BOINC Version Questions (Message 97564)
Posted 14 Apr 2020 by Bill
Post:
So I'm running 7.17 on two laptops with Ubuntu 18.04. What if I want to "downgrade" to 7.16.5? I downloaded the .sh file, and I'm not sure what to do. I also looked under Ubuntu software, and it says:

Version: 7.16.5+dfsg+202002271434~ubuntu18.04.1
Updated: 3/19/2020
Source: lp_ppa_costamagnagianfranco_boinc-bionic-main

That seems a bit contradictory to me. Anyway, I'd like to use the 'official' release for Linux to give it a test drive.

Sorry, this is probably a simple question, but I only use Ubuntu to run Boinc on these few computers, and it is few and far between when I sit down and Ubuntu, so I really don't know how to navigate the OS at all.
14) Message boards : Questions and problems : 200 tasks downloaded for a project with a resource share of 0? (Message 96035)
Posted 24 Feb 2020 by Bill
Post:
I see now. Can't the computer update project settings, then request for new work? That seems like a relatively easy fix? Unless that bogs down the servers too much?
15) Message boards : Questions and problems : 200 tasks downloaded for a project with a resource share of 0? (Message 96024)
Posted 24 Feb 2020 by Bill
Post:
I'm trying to figure something out here. I'm not sure if this is a bug or if I did something wrong.

My computer is running Boinc 7.16.3 with three projects: Einstein, MilkyWay, and Seti. I had been running all three with equal resource shares of 100 for most of January. My computer has 4c/4t, with an AMD APU (Vega 8) and Nvidia GPU (1660 Ti). I had enabled AMD/Nvidia GPU tasks for Seti (with no CPU tasks), and CPU/Nvidia tasks for both Einstein and Milkyway.

To make a long story short, I set Einstein to NNT until it went dry. I then set its resource share to 0, and enabled CPU/AMD/NV tasks. At that point, I had set MW & Seti to NNT. Even though there were plenty of CPU and NV GPU tasks in my queue, I downloaded 200 Einstein tasks for CPU/NV. Yes, I made sure my settings were saved online prior to updating Einstein in the client. Einstein tasks are being processed even though there are still seti/MW tasks downloaded.

My past experience was that if a project had a resource share of 0, it would only download enough tasks to keep a CPU/GPU busy if it was idle. Am I missing something?
16) Message boards : Questions and problems : Scheduler Concerns (Message 93294)
Posted 24 Oct 2019 by Bill
Post:
And especially with projects like Einstein that are still using very old server software with outdated application processing rate algorithms, then setting a very low cache level to only a couple of tenths of a day mostly fixes that projects problem of sending way too much work that can't be finished before the normal 14 day deadlines for tasks.
So this kindof gets to my point. Einstein is running in a way that either negativity affects itself (cancelling tasks because they get too many at once) or other projects (downloads too many tasks such that no other projects can send tasks). If I am a casual user, I am not aware of the rec half life option in cc config. If they are unaware of this switch and see that only one or two projects are completing tasks when they have signed up for five, what motivates them to stay signed up for so many projects? I mean no disrespect to Einstein or any other projects, but if the projects can't police themselves, doesn't Boinc have this responsibility?
17) Message boards : Questions and problems : Scheduler Concerns (Message 93291)
Posted 23 Oct 2019 by Bill
Post:
I forgot that detail, the tasks for Einstein were lost because I renamed my boinc directory for 7.14.2 to test 7.16.3. they were casualties that were picked up later, so that may have something to do with it.

I see what you are saying about the new projects catching up with the old one. So, if I have a computer crunching one project exclusively for nearly a year, does that mean the new projects have to crunch a lot before more tasks of the old project are downloaded?
18) Message boards : Questions and problems : Scheduler Concerns (Message 93277)
Posted 23 Oct 2019 by Bill
Post:
Basically, I'm curious how the Boinc scheduler is set up. My one computer crunches 24/7. It normally crunches Seti exclusively, but when I installed version 7.16.3 for beta testing, I thought I would crunch a few other projects that I have in the past (Miklyway and Einstein). I have encountered two symptoms that have caused a significant amount of tasks to be cancelled.

1. Milkyway: The N-body tasks (operating on one core) typically take a significant higher amount of time to crunch than their ETA. Because of this, tasks run longer, and with typically a two week deadline, a lot of tasks end up being cancelled as the deadline is crossed.

2. Einstein: I'm not sure what happened here, but I just had 300+ tasks error out due to the deadline. I know some of this was because Milkyway was hogging time, but I have been essentially crunching E@H tasks 24/7 for more than a week. I do recall that there were a good amount of E@H tasks that were cancelled a few weeks ago due to the M@W deadline (they had similar deadlines), and these were re-downloaded even though I had NNT set for E@H.

I have not had the time to sit down and document all of my steps to fully understand what is happening here. I feel that I have run Boinc during this time period as "set it and forget it". I was not suspending projects (at least, until I saw deadlines may not be reached, and that was to help focus on the tasks that needed to be done first). I was running the computer 24/7, and, I am pretty sure I have had the storage setting to 2 days or less. So, with task deadlines being 10-14 days out from when the task was downloaded, I am confused why for two projects I have had a plethora of tasks be abandoned.

I have brought this up on the Milkyway boards, but the only response I have gotten was to reduce the amount of tasks stored. Although that may be a way to deal with the symptom, I feel this does not cure the disease. Ultimately, I am concerned about the casual Boinc user experience. CPUs are starting to have more and more cores. I suspect that casual Boinc users could focus on one project, but I am willing to bet there are users who assign several projects to one computer. If their computer is cancelling and abandoning tasks because they expire, I could see this being a deterrent to the casual user.

Is there some further investigation that needs to be done? Perhaps there has been more discussion in details in Github, but I don't have the time to browse through all the issues there. So, apologizes if I'm asking something that has been brought up and debated several times before.
19) Message boards : GPUs : The same 2nd GPU question (Message 92994)
Posted 29 Sep 2019 by Bill
Post:
Sometimes NV and AMD drivers will need to be installed in a certain order. I thought it was NV that was more lenient and was to be installed 2nd but not so in your case. Maybe try DDU the drivers, NV and then AMD driver installs.
I ended up running DDU in the way you described. It didn't work quite right, but it was still necessary to do. It ends up, the AMD GPU was listed as an error code 43 under Windows. Long story short (in part, I don't recall my exact methodology), I put the 1660 Ti into the first x16 PCIe slot (PCIe2 for my motherboard), ran DDU, installed the Nvidia and then the AMD drivers. I was still getting the error code 43, but once I switched the HDMI cable from the 1660 Ti to the motherboard output, everything worked. I'm getting 8 GT/S for both GPUs (expected, I think), Boinc recognizes and runs on both GPUs, and when I run Timespy the graphics look like its running on the 1660 Ti and not the Vega 8.

I feel like something isn't quite right here, more with Windows than anything else, but I think I have it arranged in a way to make it work for what I need.
20) Message boards : GPUs : The same 2nd GPU question (Message 92895)
Posted 22 Sep 2019 by Bill
Post:
I just installed a GTX 1660 Ti into my computer that has been computing GPU tasks with a Ryzen 2200G. The 2200G is still in the socket. I plugged the 1660 Ti into the 2nd PCIe 3.0x16 slot so that the Vega 8 graphics could be used. HWinfo recognizes both GPUs, Windows 10 task manager only shows the Nvidia GPU. When I load BOINC, it says it can't find the AMD GPU:

9/21/2019 8:23:44 PM |  | CUDA: NVIDIA GPU 0: GeForce GTX 1660 Ti (driver version 436.30, CUDA version 10.1, compute capability 7.5, 4096MB, 3556MB available, 5714 GFLOPS peak)
9/21/2019 8:23:44 PM |  | OpenCL: NVIDIA GPU 0: GeForce GTX 1660 Ti (driver version 436.30, device version OpenCL 1.2 CUDA, 6144MB, 3556MB available, 5714 GFLOPS peak)
9/21/2019 8:23:44 PM |  | app version refers to missing GPU type ATI
I feel like I should be able to crunch with both the APU and the GPU. My cc_config file says:

<cc_config>
	<options>
		<use_all_gpus>1</use_all_gpus>
	</options>
</cc_config>
I feel like I've done everything I can. I also did a clean install of the Radeon 19.9.2, but that even says it can't find a graphics driver. Thoughts?


Next 20

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.