Posts by Marathon

1) Message boards : The Lounge : Suggestion: computer test mode for project (Message 94196)
Posted 11 Dec 2019 by Marathon
Post:
I have a suggestion for BOINC:

Allow the user to select a "test mode" on the user's computer for a specific project. When in test mode, that computer will be sent only work units that have been previously run and validated on other computers. The result of testing several work units will be an evaluation of the suitability of that user's environment for that project.

To help readers of this message understand what I am asking and why, here is some background:

In 2012, I got a desktop computer that was high-powered for the time. It had several CPUs, a fast clock, and a lot of memory. So, I joined a project that required a project that demanded intense computing. But, a lot of my results had errors. The problem was at my end: The work units for that project didn't like to be interrupted, and I was shutting my computer off every night. But, leaving it on 24/7 resulted in an significant increase in my electricity bill.

In some cases, it appeared my computer successfully completed work units, but the result didn't agree with the result from another computer. That meant the work unit had to be sent out again to another computer. It also meant my computer was wasting time producing results in error that could have been spent processing work units for other projects that would be successful.
2) Message boards : The Lounge : Cannot accept/decline friend requests; cannot read private messages (Message 92596)
Posted 26 Aug 2019 by Marathon
Post:
You're right. But, in addition, the way the pool manager works interferes with friend requests and private messages.

I don't even know if the friend requests and private messages were intended to be received by me or intended for the pool.
3) Message boards : The Lounge : Cannot accept/decline friend requests; cannot read private messages (Message 92551)
Posted 22 Aug 2019 by Marathon
Post:
I joined a gridcoin mining pool. As a result, I cannot retrieve private messages. I can neither accept nor decline friend requests.

This is not a bug report. This is not a complaint. It's just to let people know this can happen.
4) Message boards : Questions and problems : Show graphics not working on Ubuntu (Message 77863)
Posted 12 May 2017 by Marathon
Post:
It's fixed!

😳 Most of the solution was in the thread I referenced in my post: I added my user to the boinc group. I failed to notice it there.

The BOINC logs in /var/log had no useful information to help fix this. I found some messages from BOINC in /var/log/syslog corresponding to my attempts to "show graphics". Google said that these messages indicated that the program that generated an error wasn't a member of a package, so a debugging information request was ignored.

By chance, I found a hidden .BOINC directory in my home directory. It had a lot of messages like this:
** (boincmgr:2935): WARNING **: Invalid borders specified for theme pixmap:
        /usr/share/themes/Breeze/gtk-2.0/../assets/line-h.png,
borders don't fit within the image

But, those are warnings, so not relevant to my issue. What was relevant were these messages: execv: Permission denied

So, I tried "sudo boincmgr". That allowed me to use "show graphics" for Mapping Cancer Markers, the only type World Community Grid tasks that were on my computer at the time. It did not fix the problem with SETI@Home. I used Synaptic package manager instead of Discover, and found I could install more software for SETI@Home graphics.
5) Message boards : Questions and problems : Show graphics not working on Ubuntu (Message 77774)
Posted 7 May 2017 by Marathon
Post:
I suspect all attempt begin to draw a window frame. I suspect it has varying degrees of visibility, depending on how long it takes for the system to recognize an error and terminate the new window.
6) Message boards : Questions and problems : Show graphics not working on Ubuntu (Message 77769)
Posted 7 May 2017 by Marathon
Post:
I found a previous thread, https://boinc.berkeley.edu/dev/forum_thread.php?id=10704&postid=68399#68399 , but I'm unable to reply to it.

I've been using OpenSuSE for years, but, for at least the current and previous versions, I have not been able to run BOINC. So, I thought I'd give Ubuntu another try.

I recently installed KUbuntu 17.04 (Ubuntu with KDE).
BOINC version 7.6.33, X64 with wxWidgets 3.0.2, installed by Ubuntu Software Center ("Discover").

Currently, I'm running World Community Grid and SETI@Home.

BOINC runs very well, but I'm not able to see any graphics. When I select a SETI@Home v8.800 task with "Running" status, and click "Show Graphics", either nothing visible happens or a rectangle outline appears and vanishes, in nearly subliminal time. With Workd Community Grid, I see nothing when the task is Mapping Cancer Markers. When the task is FightAIDS@Home or one of the Zika tasks, the rectangle has a title bar, with text. But, there is no time to read the text before it vanishes.

When I was using BOINC on OpenSuSE, I used the Berkeley installer. When something wasn't working, I would run the BOINC Manager from a command window, which would allow me to see error messages, including those that came from using "Show Graphics." This allowed me to detect and fix several problems. But, this doesn't happen with my Ubuntu box.

The previous thread suggested looking for "stderr" files for BOINC. But the only "err" file I find is /var/lib/boinc-client/stderrgpudetect.txt, and it is empty.

I tried using the Boinccmd tool http://boinc.berkeley.edu/wiki/Boinccmd_tool to get a list of tasks, and then ask for graphics. But, the requests generates an "unknown op" error:

john@doe:/var/lib/boinc-client$ boinccmd --task http://setiathome.berkeley.edu/ 30mr08ag.7300.70860.13.40.43_0 graphics_window
Unknown op graphics_window
john@doe:/var/lib/boinc-client$ boinccmd --task http://setiathome.berkeley.edu/ 30mr08ag.7300.70860.13.40.43_0 graphics_fullscreen
Unknown op graphics_fullscreen


(The task name was typed just after the URL. It shows on a separate line here because that is where the lines broke with the font size in my command window.)

How can I find out why "show graphics" isn't working on my system?
7) Message boards : Questions and problems : How are benchmarks used? What happens if they are not accurate? (Message 55246)
Posted 7 Aug 2014 by Marathon
Post:
When I start my client, it sometimes runs some benchmarks. I wonder how the information obtained from running the benchmarks are used?

Also, my CPU will throttle back if it gets too hot, and it does tend to run hot. This means that when BOINC projects are running, the CPU will slow down to avoid overheating. So, I have to wonder if the benchmark information actually reflects how the computer performs when running BOINC tasks.
8) Message boards : Questions and problems : New install, can't find work units after reboot (Message 52680)
Posted 20 Feb 2014 by Marathon
Post:
Thanks, all. I think I finally got it.

Juha was correct: I had not noticed, and therefore not deleted the hidden file in my home directory. The information from Ageless was also helpful, even though I had previously seen that page. But, a big part of the problem was that a user BOINC was created by the Ubuntu installer. I had to delete that user manually.

(In case anyone is interested in minor details of this case history, here are some:
I re-installed the Ubuntu version using Muon. It found the downloaded work units -- they were in the same directory used by Ubuntu. But, whenever I shut down my computer and later restarted it, no tasks would run. BOINC seemed frozen. I forcibly killed the process, and then restarted it. I managed to finish the work units that way. Then, I went to work to try to fix the problems.)

Here is a suggestion: I'd like someone to create a "Test BOINC" project. The work units would only do some "dummy" work. They would allow users to check that BOINC properly sends and receives work units and other information, and BOINC shuts down and starts up properly when the user's computer is shut down and restarted.
9) Message boards : Questions and problems : New install, can't find work units after reboot (Message 52477)
Posted 9 Feb 2014 by Marathon
Post:
I tried removing all the BOINC files on my computer and then re-installing the Berkeley version. However, there is still something, somewhere, on my computer from the previous BOINC installation: When I start the manager, my old preferences / settings are still there, instead of the default.
10) Message boards : Questions and problems : New install, can't find work units after reboot (Message 52476)
Posted 9 Feb 2014 by Marathon
Post:
Yes. A few days before uninstalling, I used the "No new tasks" feature. I waited until all 3 projects had no tasks left. I used Muon to uninstall Ubuntu BOINC version before I installed the Berkeley version.

You seem to be on the right track, though. The Ubuntu version put the project data files in /var/lib/boinc-client. It seems my newly downloaded task data is there. So Muon didn't completely uninstall the Ubuntu version. Something on my computer remained that directed BOINC to use that. I'll try again.
11) Message boards : Questions and problems : New install, can't find work units after reboot (Message 52471)
Posted 9 Feb 2014 by Marathon
Post:
I use Ubuntu with KDE, 64 bit.

In order to protect the progress made by BOINC projects, before I shut down my computer, I use the BOINC manager to suspend the projects, and then exit the manager, selecting the option to suspend work. I normally then use the BOINC manager to resume the projects next time I restart my computer. I did that before shutting down my computer last night.

Yesterday, I downloaded and installed BOINC 7.2.33 (64 bit). I used the manager to join three projects. Two of these download some tasks and began running them. Today, when I try staring the BOINC manager, none of the projects show. It is as if I had installed BOINC, and stopped there, without joining any projects.

What happened? How can I resume running tasks already started?

I previously had a version of BOINC modified for Ubuntu installed using Muon package manager. That was version 7.2.7. I got tired of waiting for a new version to become available via Muon.
12) Message boards : Questions and problems : Show graphics on Linux (Message 30765)
Posted 2 Feb 2010 by Marathon
Post:
I recently installed a newer version of OpenSuSE (11.2) and the newest version of BOINC. I'm pleased to report Seti@home graphics are working again.

I suspect the problem was that I was missing a file or files, or environment variable. If I was missing files, the missing files may have been within BOINC, or there may have been an error in my BOINC security (permissions) that caused the problem. We may never know.
13) Message boards : Questions and problems : Show graphics on Linux (Message 28877)
Posted 19 Nov 2009 by Marathon
Post:
Could it be that I need to set an environment variable?
14) Message boards : Questions and problems : Show graphics on Linux (Message 28787)
Posted 16 Nov 2009 by Marathon
Post:
As far as I can tell, the way to do this on Open SuSE 11 is to check a box "accelerated graphics", and that box is checked. Is there another way I can check it?

(I use Linux the way most people use Windows. In my case, the user interface is KDE 4.)
15) Message boards : Questions and problems : Show graphics on Linux (Message 28686)
Posted 12 Nov 2009 by Marathon
Post:
james@linux-x15g:~/Research/BOINC> ldd boinc
linux-gate.so.1 => (0xffffe000)
libdl.so.2 => /lib/libdl.so.2 (0xb808b000)
libnsl.so.1 => /lib/libnsl.so.1 (0xb8074000)
libz.so.1 => /lib/libz.so.1 (0xb8060000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7f70000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7f58000)
libm.so.6 => /lib/libm.so.6 (0xb7f32000)
libc.so.6 => /lib/libc.so.6 (0xb7dee000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0xb7de0000)
/lib/ld-linux.so.2 (0xb80ad000)
james@linux-x15g:~/Research/BOINC>
16) Message boards : Questions and problems : Show graphics on Linux (Message 28594)
Posted 9 Nov 2009 by Marathon
Post:
I suspect that I need to install something on SuSE Linux that I don't have installed now, but I don't know what that is.

It might help if I knew how "show graphics" is supposed to work in Linux. Does anyone know of a page where I can read about this?

Also, is there a way I can try to run the graphics from a command line? If I could try that, I might see an error message I don't see when I try to show graphics from the client manager.
17) Message boards : BOINC client : Graphics not seen on Linux (Message 28587)
Posted 8 Nov 2009 by Marathon
Post:
Oops -- that message went to the wrong forum. Sorry about that.
18) Message boards : BOINC client : Graphics not seen on Linux (Message 28539)
Posted 7 Nov 2009 by Marathon
Post:
(There was a thread about this a while back, but I can't find it.)

I'm using SuSE Linux 11.0 with KDE 4.3.1 (ugh) at the moment. When I select a running SETI task, the "Show Graphics" button becomes enabled. But, when I click on it, nothing happens.

This was working when I had earlier versions of SuSE Linux. I suspect the problem is not with the BOINC software. Instead, I think the problem is that I don't have something installed that the BOINC/SETI graphics software needs, or I have it installed but BONIC/SETI can't find it.

Does anyone know what components I need to have installed for this to work? Also, are there any "environment variables" or other configurations that I should look at?

Also, is there a console command that I could try in order to run the graphics software? If there is, and I try it, I might see an error message that could provide clues.

Thanks.
19) Message boards : BOINC client : Suggestion: server request abort (Message 23937)
Posted 26 Mar 2009 by Marathon
Post:
This probably won't work nearly as well as people think it will work due to the simple fact that in many, many cases the client won't receive the abort order until it's too late. Why? Because they'll be in communications deferral for up to 24 hours. Perhaps 6.6 clients will contact projects for which they have overdue tasks more frequently, for example every 15 minutes?


A 24 hour delay would work in my case. The estimated time remaining on a work unit already 2 days overdue is 180 hours. I don't want to abort it, because I keep imagining other people given the same work unit have a similar estimate.
20) Message boards : BOINC client : Suggestion: server request abort (Message 23932)
Posted 26 Mar 2009 by Marathon
Post:
I have a work unit being processed that is overdue. If I check for messages using the manager, I see, as you might expect, a warning that I might not get credit for the work unit and I should consider aborting it.

I let it run because I wonder if it is overdue on other computers, as well.

I suggest a feature for checking overdue units, and allowing the server to request these be aborted:

* When a work unit is overdue, the client periodically reports information about progress on the work unit to the server.
* When the server has received, from some computers, completed results for work unit that are overdue on other computers, it records an "abort request pending" for those that are overdue.
* When the clients "check in", the server can send abort requests for appropriate work units.


Next 20

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.