Posts by Joseph Stateson

1) Message boards : Questions and problems : host ID not matching ID at boincstats: cannot set resource share (Message 101595)
Posted 16 Nov 2020 by Profile Joseph Stateson
I asked about this back in august over at boinc stats. I got not response but since things seemed to work OK it was not big deal.

by work OK i mean I can attach, detach projects, etc. We are using 7.16.11. This is my sons account that has the problem. He uses BAM!

His external CPID is fb4efe.... that matches his gridcoin address, the address shown at the BAM! main account page and a "find " shows the XML files in the boinc folder have the correct external cpid. I assume that fb4efe.. is correct.

However, the account manager xml files in that boinc folder show a "host_cpid" that is 90bc86d... I have no idea what that is and I never got a response at the BAM! forum. Is that the external_cpid? if so, it does not match the actual fb4efe... He has only 2 hosts at BAM! one has a CPID of c4fd555... the other's CPID is 2ae7f835. Neither are 90bc8ed.,..

The contents of the acct_mgr_request.xml file and acct_mgr_reply.xml show that %100 is used for all resource shares. This hostid's all match the hostid's at the project. I suspect the value 90bc86d... in those acct_mgr files need to be fb4efe... is that correct?

At the BAM! main account page there is an option to "change cpid" but the cpid they show in the dialog box is the external cpid. I do not want to change that as it takes a long time for gridcoin to sync and start paying and all indications are that the fb4efe.... is correct

I read the release notes for 7.16.11 and noticed the following "Client: if AM reply includes a project we're attached to under a different account, honor the params in the AM reply, e.g resource share"

I am not sure that that means. This system used to be mine. I deleted all my projects and added the BAM! manager to the boinc manager using his account at BAM! His account at bam was used to create project accounts. I looked through all my projects and I never had a "host_cpid" of 90bc86d...

I cannot figure out why he or I cannot set the resource share. We have no problem adding projects or setting other values.
2) Message boards : Questions and problems : possible to use boinccmd --quit when multiple clients are running? (Message 100881)
Posted 28 Sep 2020 by Profile Joseph Stateson
Read the User Manual for the Boinccmd tool.

The GUI rpc port can be specified as part of the hostname argument:

hostname can be a domain name, an IPv4 address, or an IPv6 address. If the client uses a non-default GUI RPC port, you can specify it as hostname:port, IPv4_addr:port, or [IPv6_addr]:port.

thanks, forgot about "--host hostname:port "

"boinccmd --help" is not the same as RTFM

I was setting up a second client so that gridcoin research could obtain project info for "user2" while the system was crunching for "user1". There was no need for user2 to crunch, just needed login info for gridcoin.

Has anyone ever considered allowing the manager to add the same project with a different username ie: account? Probably no need since multiple clients can run
3) Message boards : Questions and problems : possible to use boinccmd --quit when multiple clients are running? (Message 100878)
Posted 28 Sep 2020 by Profile Joseph Stateson
I looked at the boinccmd command line arguments (7.16.11) but do not see a gui_rpc_port option.
Is there a way to cause one of the client tasks to gracefully quit using the boinccmd program?

If I use kill task does that cause the client tasks to write a checkpoint and exit?

I assume I can use the manager and then quit the manager causing one of the clients to stop but that is awkward

thanks for looking
4) Message boards : Projects : recaptcha not allowing new accounts but boincstats did it (Message 100858)
Posted 25 Sep 2020 by Profile Joseph Stateson
OK, seems that this is a known problem and a solution given there.

read a complaint here with no response by management

Tried Firefox, Chrome and the newest Edge got same error. One difference: Chrome did not popup the "select [car] [train] [airplane] [crossroads}" dialog box. I have that Chrome extension PrivacyPass which is supposed to allow skipping that once valid login is done.

When connecting to Cosmology via boincstats I errored out 41 vbox tasks before I got around to looking at the tasks que. Guess I should have looked at that first before trying to create a profile and join a team. vt is enabled and vbox installed. not sure what the problem is but 23 cpus were assigned out of the 24 available.

this shows up on all three browsers, hope it helps someone
Warning: Creating default object from empty value in /home/boincadm/project/html/user/create_profile.php on line 205
5) Message boards : Projects : external_cpid is empty for some projects (Message 100836)
Posted 23 Sep 2020 by Profile Joseph Stateson
gpugrid and einstein do not filll

as a result the client_state.xml file has "missing" cpids.

I suspect they have not interest in fixing this as the problem only shows up on gridcoin apps.

Is there any harm in editing that file and filling in the CPID value as I know what it is.

thanks for looking
6) Message boards : Projects : recaptcha not allowing new accounts but boincstats did it (Message 100835)
Posted 23 Sep 2020 by Profile Joseph Stateson
Not sure what is going on but I tried creating accounts for one of my kids at amicable, cas and cosmology and the recaptcha failed for edge and chrome. Ublock was disabled so should have worked.

I used boincstats to create his accounts and was able to log in for him at those sites.

Is this a problem with the projects or are chrome and edge misconfigured?

AFACT active x (virus transfer protocol) is enabled on both browsers.
7) Message boards : Questions and problems : BOINC Manager V7.16.5 is issuing "annoying" messages which I would like to suppress (Message 97534)
Posted 12 Apr 2020 by Profile Joseph Stateson
With a number of "boinc rigs" I got tired of having to scroll through 1000's of annoying message just to find that the ones I wanted to see had already been purged off the 2000 limit that boinc tasks has.

FWIW, I added a message filtering capability to cc_config
<exclude_proj_msg>       <!-- put this in the flags section, not the options section -->
<proj_name></proj_name>  <!-- project name with correct syntax are isted in event messages -->
<msg_content></msg_content>  <!-- if enmpty, all are excluded -->

the message that were particularly annoying
<msg_content>settings do not allow fetching tasks</msg_content>
<msg_content>No work available</msg_content>
<msg_content>No work sent</msg_content>
<msg_content>No work is available</msg_content>
<msg_content>Resent lost</msg_content>
<msg_content>resend lost</msg_content>
<msg_content>already reported</msg_content>

Unfortunately, it only works with my app
8) Message boards : The Lounge : The Seti is Slumbering Cafe (Message 97297)
Posted 5 Apr 2020 by Profile Joseph Stateson
Just passed to say hello. I'm still alive.

My alcohol stock are depleting faster than the Seti WU.
At this rate it will last for only about one week only and i can refill it due the prohibition.
Did any one have a good link where i could read about how to produce moonshine in doors?

I picked up a water distiller for use with my Keurig machine as I got tired of cleaning the coffee maker. This was shorty before the corona virus hit. Timing worked out nice as it is hard to find distilled water. About 1/3 of the distillers listed by amazon did spirits and more show up googling "spirit distillers". My brother attended a renaissance fair 20 years ago and got into making mead and has a belly to prove it.

Have a nice day!

"Class 6" store at Ft Sam Houston
9) Message boards : Questions and problems : rosetta@home tasks don't download (Message 96810)
Posted 16 Mar 2020 by Profile Joseph Stateson
Network managers have lot of tools at their disposal. In addition to executables, the firewall can be programmed to block zips or allow zips but not those with executables inside. Depends on how secure or "locked down" down they want the system to be. I am guessing that there is also overhead (time) expended in examining the data which might cause the sender or receiver to give up.
10) Message boards : The Lounge : Best Mining Motherboards for BOINC? (Message 96704)
Posted 12 Mar 2020 by Profile Joseph Stateson
Got to looking at a 7 slot PCIe server: dual xeon 1366 for mining. multicore xeon's are considerably cheaper than any comparable gen 6 or gen 7.

Worked fine with Linux although I did have a problem with the AMD driver but that was due to the GPUs being unusual: "s9050" Windows 7 and 8.x worked fine with those low power HD7950 equivalents.
Currently have 8.1 installed only because I had an unused license.

DDR3 ECC server memory is cheap. The mombo is strictly for mining as no x16 slots and is not ATX or EATX size. Screw holes do not line up even with the mining rack.
Power supply requires an extra 8 pin but otherwise uses standard ATX power some of which have the extra 8pin.
It can do both Gen2 and Gen1 but not Gen3

I looked at inserting a license into the bios but didn't try. If one of my TB85 boards crap out I may get another and try my bios mod.
11) Message boards : Projects : Can we Cure Corona (Message 96676)
Posted 11 Mar 2020 by Profile Joseph Stateson
Insane, grocery here is out of Corona beer. How silly can people get!


poteet strawberry festival bought out all the corona beer from local grocery
12) Message boards : Projects : Can we Cure Corona (Message 96626)
Posted 10 Mar 2020 by Profile Joseph Stateson
Insane, grocery here is out of Corona beer. How silly can people get!
13) Message boards : Questions and problems : Highest PPD project on Nvidia GPU outside of Collatz? (Message 96609)
Posted 10 Mar 2020 by Profile Joseph Stateson
Unaccountably, GPUgrid has work. Starting about 2 weeks ago I noticed my queue was full on al systems. I had set GPUgrid to 100 resource and Einstein to 0 months ago and I rarely saw a GPUgrid. Big change. IMHO GPUGrid pays more GRC coins than other projects.

Currently, I have 18 GPUgrid executing (really need GTX-1060 or higher) and 22 queued. About 2 out of 3 are Linux.

My ATI boards all run Milkyway.
14) Message boards : BOINC client : purpose of XMLs: global_prefs and global_prefs_override on "leave apps in memory" (Message 96313)
Posted 3 Mar 2020 by Profile Joseph Stateson
Never paid much attention to any of those files. They show up during an install of boinc.
My "global_prefs.xml" is from WCG. Just looked at 4 Linux systems and one windows. They are all from WCG and I assume the rest of my "farm" also have WCG as the default source for parameters in global_prefs.xml. The first project I ever signed up for was SETI so unsure of how WCG got the default.

LHC at home has a warning that it does not checkpoint multi-core apps and recommends they be left in memory when restarting boinc. This applies only to Linux systems, and I was unaware of this until after I restarted boinc. It seems that the tasks resided in memory as the times did not get reset to 0 so I got to looking at why there were not reset.
jstateson@jysdualxeon:/var/lib/boinc$ grep "leave_apps" *.xml
global_prefs_override.xml:   <leave_apps_in_memory>0</leave_apps_in_memory>
global_prefs.xml:  <leave_apps_in_memory>0</leave_apps_in_memory>
global_prefs.xml:    <leave_apps_in_memory>1</leave_apps_in_memory>
global_prefs.xml:    <leave_apps_in_memory>1</leave_apps_in_memory>
global_prefs.xml:    <leave_apps_in_memory>0</leave_apps_in_memory>   <leave_apps_in_memory>0</leave_apps_in_memory>  <leave_apps_in_memory>0</leave_apps_in_memory>    <leave_apps_in_memory>1</leave_apps_in_memory>    <leave_apps_in_memory>1</leave_apps_in_memory>    <leave_apps_in_memory>0</leave_apps_in_memory>   <leave_apps_in_memory>0</leave_apps_in_memory>  <leave_apps_in_memory>0</leave_apps_in_memory>    <leave_apps_in_memory>1</leave_apps_in_memory>    <leave_apps_in_memory>1</leave_apps_in_memory>    <leave_apps_in_memory>0</leave_apps_in_memory>
sched_request_milkyway.cs.rpi.edu_milkyway.xml:   <leave_apps_in_memory>0</leave_apps_in_memory>
sched_request_milkyway.cs.rpi.edu_milkyway.xml:  <leave_apps_in_memory>0</leave_apps_in_memory>
sched_request_milkyway.cs.rpi.edu_milkyway.xml:    <leave_apps_in_memory>1</leave_apps_in_memory>
sched_request_milkyway.cs.rpi.edu_milkyway.xml:    <leave_apps_in_memory>1</leave_apps_in_memory>
sched_request_milkyway.cs.rpi.edu_milkyway.xml:    <leave_apps_in_memory>0</leave_apps_in_memory>   <leave_apps_in_memory>0</leave_apps_in_memory>  <leave_apps_in_memory>0</leave_apps_in_memory>    <leave_apps_in_memory>1</leave_apps_in_memory>    <leave_apps_in_memory>1</leave_apps_in_memory>    <leave_apps_in_memory>0</leave_apps_in_memory>

From the above it looks like the default WCG caused all projects to have the same parameters
(global),generic, home, school, work respectively (0),0,1,1,0 for "leave apps in memory"
I recall going to WCG and setting the 0,1,1,0 so can I assume that caused all the other projects to get set the same way ?
Looking at the "override" which shows "0" and reading this
It appears that the override in not applied automatically as an RPC call needs to be made to force it. Is that correct?

What is strange is that the Atlas app was "generic" venue and that was "0" in all of the above so it should have started from scratch but it seems to have been left in memory and picked up where it left off which is OK with me. OTOH, the project may have implemented checkpoint and didn't bother to update the warning.

If the venue is "work" and a "work" app is running on project X, and that venue requires the app be left in memory, I assume that BOINC will only leave that app in memory and not other venues or other project apps.
15) Message boards : BOINC client : Client lost track of how many CPUs were allocated. (Message 96296)
Posted 3 Mar 2020 by Profile Joseph Stateson
Do not want to repost everything that is over here

If you add up running tasks you are 7 short of the possible 24. I think the client allocated 8 CPUs for the first "atlas" but that project app only picked up one cpu, not 8. If it has only 1 CPU (not clear from looking at mpstat) then it will take weeks to finish. In any event, there are 7 unused threads and waiting WCG tasks that are unaccountably idle.
below image is from boinctasks but the manager shows exact same thing

16) Message boards : Questions and problems : 200 tasks downloaded for a project with a resource share of 0? (Message 96026)
Posted 24 Feb 2020 by Profile Joseph Stateson
I think what happens is that when your system contacts the projects it asks for data before doing anything else.

For example: Your system is in venue "default" and you go to the project and you set resource to 0.0 for venue "school" and select "school" for your system.
The next time your system contacts the project it asks for data and gets a boatload and then is told to switch to "school"
Thereafter, the next time it contacts the project its "school" venue says it can have only 1 work unit but only after finishing all tasks.

This has happened to me more times than I can remember. Suggest let a few tasks finish before aborting them all or you might get on the 24 hour blacklist.
17) Message boards : Questions and problems : AMD's Radeon open compute (RocM) has problem with boinc (Message 96003)
Posted 22 Feb 2020 by Profile Joseph Stateson
yea, next big thing if you buy the best AMD motherboard and GPUs money can buy.. Not going to repost everything from that thread over at Einstein, summery below as applies to linux:

ROCm or rocM or WTF it is called requires you have as many GEN3 PCIe lanes to the GPU as you have GPUs. It is part of all recent amdpro drivers, just needs to be activated to work.

Once installed, if you do not have enough "PCIe atomics" (nice word for gen3) then those GPUs not having a gen3 lane to the CPU disappear for apps like boinc. They will show up using, for example "clinfo", or "sensors" or any diagnostics program. So, like me, if you have 5 GPUs but boinc only sees a single one and all the diagnostics you run indicated there are 4 more GPUs available you starts suspecting that something is wrong with BOINC not realizing the problem is the AMD driver that wants to run only on a superhighway and ignores all the little x1 back roads.
18) Message boards : Questions and problems : AMD's Radeon open compute (RocM) has problem with boinc (Message 95996)
Posted 21 Feb 2020 by Profile Joseph Stateson
Been running the tests at Einstein using their beta app that relies on the RocM driver. Boinc does not see multiple GPUs, only the one in the X16 slot. Going to post url to the message over at Einstein rather than duplicate it all here. I actually was unaware of this driver prior to seeing the complaint over there that the app was not working.
19) Message boards : GPUs : PCI express risers to use multiple GPUs on one motherboard - not detecting card? (Message 95782)
Posted 9 Feb 2020 by Profile Joseph Stateson
This thread is really off topic. I am declaring it as a troll thread and am providing tools for identify abusers.
My pick for Peter is the "Wank - o - meter". Rest of you can decide what your are
Simplified - Numeric
0 1 2 3 [4] 5 6 7 8 9 10 

Simplified - Legend
    T R O L L - O - M A T I C 
PATHETIC ---------+---------INSPIRED 

Simplified - with watchdog
 0  1  2  3  4  5  6  7  8  9 10 
|**********************        | 
|**********************        | 
|            (o o) 
| -------oOO--(_)--OOo-------- 

Move along folks. Nothing to see here. Just a troll having a seizure.  Show's over. Keep it moving.
1 2 3 4 5 6 7 8 9 +10 +20 

1 2 3 4 5 6 7 8 9 +10 +20 

1 2 3 4 5 6 7 8 9 +10 +20 

Try to be a bit more subtle next time. Thanks for playing!

Better, but no bite. I am uninterested in getting into a flame war with you no matter how many personal attacks you make. If you insist on having a fight, go ahead and start without me.
[ reeky neighborhood watch Troll-O-Meter] 
[||||||||| ] 

 Not bad, as trolls go. The Lame-o-meter was off scale on the highest range and the Clue-o-meter wouldn't register. 
0  1  2  3  4  5  6  7  8  9  10 
|  |  |  |  |  |  |  |  |  |  | 

OMG! They said it couldn't be done, but this post rates: 
|           4 5            |
|        3       6         | 
|     2             7      | 
|   1                 8    | 
|  0         o         9   | 
|  -1      /               | 
|   -2    /                | 
|     -3 /                 | 
|      Troll-O-Meter       | 
Warning, troll-o-meters are susceptible to particularly stupid statements, and may give inaccurate readings under such conditions.  A shrill response generally indicates an effective complaint. 

| TROLL-O-METER(tm)      || 
|                        || 
| .---  .---             || 
|     |     | millitrolls|| 
| .---'     |    _  _    ||
| |         | . | || |   || 
|  ---'     '   `-'`-'   |/

A bit better, but still not enough to hook me. Better luck on your next cast! 
+----------------------+ +----------------------+ 
|0 1 2 3 4 5 6 7 8 9 10| |0 1 2 3 4 5 6 7 8 9 10| 
| \ TROLL-O-METER      | | WANK-O-METER    /    | 
|  \                   | |                /     | 
|   \                  | |               /      | 
|    \                 | |              /       | 
|     \                | |             /        | 
|      \               | |            /         | 
|       \              | |           /          | 
|Certifie\  next cal:  | |Certified / next cal: | 
| NIST    \ date 12/5  | | NIST    / date 12/5  | 
+----------------------+ +----------------------+ 


That was the Troll-O-Meter exploding. 
Fell for that one hook, line, and sinker.

+----------------+   ,.' 
| .0 .2 .4 .8 1.0|   ,.' 
|              ' | 
|              ` | ''..''..''% 
+------------`    | 
| Troll-O-Met`  (((o 
+-----------`      '., 
             ;            # 
|   PLEASE!   | 
| Do NOT Feed | 
|  The Troll  | 
      | | 
      | | 
  \ \ | | / /

         +-------------------+            .:\:\:/:/:.
         |   PLEASE DO NOT   |           :.:\:\:/:/:.:
         |  FEED THE TROLLS  |           :=.' - - '.=:
         |                   |           '=(\ 9 9 /)='
         | Thank you,        |             (  (_)  )
         |     Management    |             /`-vvv-'\
         +-------------------+            /         \
                 | |         @@@         / /|,,,,,|\ \
                 | |         @@@        /_//  /^\  \\_\
   @x@@x@        | |          |/        WW(  (  )  )WW
   \||||/        | |         \|          __\,,\ /,,/__
    \||/         | |          |     jgs (______Y______)
20) Message boards : Questions and problems : Manager without client (Message 95749)
Posted 8 Feb 2020 by Profile Joseph Stateson
I am guessing you already tried

sudo apt-get install boinc-manager

If you want the latest boinc version be sure to do the below first

sudo add-apt-repository ppa:costamagnagianfranco/boinc

However, there might be a problem accidently getting the boinc client when doing an update.

I assume the systems you want to control are on the local subnet. You might want to put in a remote desktop program such as\ VNC and use that.

Next 20

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.