Posts by Hollow_Pointe

1) Message boards : GPUs : CUDA Work Units do not Suspend when Computer in use (Message 41678)
Posted 17 Dec 2011 by Hollow_Pointe
Post:
Which version of BOINC are you running?

Click Activity and select Use GPU Based on Preferences.

'Use GPU based on preferences' is a global setting, not per project.

From what he says about SETI suspending, sounds like it's in operation already.

Maybe there's something odd about the way Einstein's app does, or doesn't, respond to BOINC's "suspend" directive - but I haven't heard anything about that being a common Einstein problem. The Einstein message board would be the place to ask.


Yes, I posted the same question there under my Einstein@home user name "Dogstar"
I've got 47 views and no replies. Not even "Ageless" the moderator has replied.
2) Message boards : GPUs : CUDA Work Units do not Suspend when Computer in use (Message 41677)
Posted 17 Dec 2011 by Hollow_Pointe
Post:
Which version of BOINC are you running?

Click Activity and select Use GPU Based on Preferences.


I'm running the current version I think, version 6.12.34 (X64).
3) Message boards : GPUs : CUDA Work Units do not Suspend when Computer in use (Message 41621)
Posted 14 Dec 2011 by Hollow_Pointe
Post:
This problem is particular to Einstein@home. Seti@home suspends as soon as I move the mouse. Launching a 3D game with CUDA in use results in terrible performance and sometimes freeze/crash.

I can quit the work units in Task Manager but I wonder if this could corrupt the work units and/or BOINC?

I have checked my settings in the standard edition of BOINC Manager. CPU and CUDA are set to suspend when computer is in use. My Einstein@home preferences are set to run CUDA applications when available.

Basicaly my system is:

CPU: i7-860
GPU: nVidea GTX260 (2) in SLI
Memory: 16GB
PSU: 950 watts/1080 peak watts
System: Windows 7 Pro 64 bit
Firewall/Antivirus: Norton Security Suite
4) Message boards : Questions and problems : Boinc will not connect to Client-Local Host (Message 41589)
Posted 11 Dec 2011 by Hollow_Pointe
Post:
Make sure boinc.exe, boincmgr.exe, boinc.scr, boincscr.exe and boincsvcctrl.exe are allowed access through your (Windows) firewall on TCP port 31416.
Separately boinc.exe needs to be allowed access to the internet through TCP ports 80 and 443.

Make sure that when you installed a 32bit BOINC, that it was installed into the C:\Program Files (x86)\BOINC\ directory, as this is the directory Windows reserves for 32bit programs. A 64bit BOINC needs to be installed in C:\Program Files\BOINC\

The different BOINC installer can be recognized by name.
The 32bit BOINC installer is named Boinc_version.number_windows_intelx86.exe
The 64bit BOINC installer is named Boinc_version.number_windows_x86_64.exe

Windows will not like it when you try to run a 64bit program from the reserved 32bit Program Files directory tree. Idem ditto with running a 32bit program from the 64bit Program Files directory. But only one of either gives a warning, or will plain refuse the program, I am just not sure which one.

Also make sure that the BOINC Data directory is outside the Program Files\ and Program Files (x86) directories. Not only are these reserved for the different bit-depths of programs, but also are programs not allowed to constantly write updates to these directories. This to make sure spam and other unwanted programs won't make use of these directories.


I have done everything suggeted above as best I could. The Firewall modifications presented in the above quote are a little unclear and do not exactly match the way the program is presented as monitored in Norton Security Suite. Some of them were TCP/UDP and so I changed them all to TCP as advised. Some of them only had 1 of the ports mentioned open so I opened all of the above ports. Of the program elements mentioned in the above quote only 2 client elements which targeted boinc.exe and 1 Boinc Manager which targeted boincmgr.exe had associated firewall rules presented in Norton Security Suite. One thing I need to mention is that I have Boinc installed on drive D:\ not C:\. Does that make a difference?

Right now it is hopeless. I have installed and reinstalled. I have verified installation in the proper 64 bit folder and that the data files are in a folder outside of the program folder. I deleted the gui_rpc_auth.config file.

Bionc will initially restart normally, but then I come back and find the sceensaver displaying the message "Boinc is not running." I check Boinc manager and sure enough find that it needs to "communicate with local client." With futher clicking the project list disappears and the tasks disappear. I manually remove boinc.exe from task manager, but find that boinc tasks in memory will not delete in task manager.

I have been running Seti@home and then BOINC non-stop 24/7 since 2004 and I have never encountered a problem like this. I hope and believe that this problem is very widespread and is an application problem with the new version.

I don't know if it matters but this is basically what I got for a computer:

CPU: i7-860
RAID mirror duel drive: C:\
Drive D:\ (installed)
RAM: 16GB
GPUs: GTX260 (2) in SLI
System: Windows 7 Pro 64bit
PSU: 950 watts/1080 peak watts

If this can't be fixed short of reinstalling Windows then I may try reinstalling an older 32 bit version of BOINC. And if that fails then I may have to uninstall and essentially resign from participating in BOINC.
5) Message boards : Questions and problems : Boinc 6.13.12 client stops working and disappears. (Message 41527)
Posted 8 Dec 2011 by Hollow_Pointe
Post:
I am running Boinc 6.12.13 and it often disconnects from the client, what ever that is and then I can't access any of my projects or see my tasks. Boinc screen saver will say that "Boinc is not running." The only way to get it started again is to restart the computer.

It's an app problem, not a firewall issue. If the firewall were the issue Boinc would not be able to connect at all. I am tired of this problem and if it continues I may drop out of Boinc altogether.

This evening it was acting up so I ran the 6.12.13 installer and got an option to repair the installation, so I tried it. Of course I made sure Boinc Manager was quit and out of Task Manager before I ran the installer. After a few seconds it finished and I got Boinc Manager up and it was reconnected to the client and all the projects were showing and everything was fine. I hope that's the fix.




Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.