Posts by Kurt Ergen

1) Message boards : Questions and problems : Boinc no longer connects in protected (service) mode (Message 40014)
Posted 5 Sep 2011 by Kurt Ergen
Post:
I was using version 6.10.58 when this all started, but I'm now using 6.12.33. I've also tested the legacy version 6.10.60. Same problem with all of them.

I mean that the manager doesn't connect with client. This is not a networking problem with the internet or something. I fully understand that the manager is just the interface for the client, but it appears to me that the newest ATI drivers are preventing the client from communicating with the manager not because of a connection issue, but the client its self is in conflict. It appears that no science work is being done at all.

Here are some screen pics:



Above is Boinc running with no problems with ATI's 11-6 version of the display drivers.



Above you can see the latest version of the drivers, 11-8 is shown here, but I get the same problem with 11-7 as well. Just sits there saying Connecting to localhost, and the icon in the notification area has a red symbol and the message "Reconnecting to client" (not shown in image)



Here I just wanted to show that the client isn't doing science work in the background. This is not merely a simple manager to client connection problem. The client isn't working at all. Although I should note that boinc.exe is running in the process tree.

One final note: The problems only start/stop after a reboot. It's not like boinc stops running as soon as I install the 11-8 drivers, it's only after the reboot. The same goes when I remove 11-8 and install the older 11-6 drivers. It won't start running again until I restart the OS. Thus I'm guessing the newer drivers are preventing the client from starting in the first place.
2) Message boards : Questions and problems : Boinc no longer connects in protected (service) mode (Message 40001)
Posted 4 Sep 2011 by Kurt Ergen
Post:
UPDATE:

I was able to track the problem down to the latest ATI Video Drivers. I'm able to run Boinc in Protected Application Execution mode with the generic Windows 7 Radeon HD 4800 video card driver and the official ATI version 11-6 drivers. Version 11-7 & 11-8 both block Boinc from running in Protected Application Execution mode from some unknown reason.
3) Message boards : Questions and problems : Boinc no longer connects in protected (service) mode (Message 39712)
Posted 18 Aug 2011 by Kurt Ergen
Post:
I'm having an odd problem I can't explain for the life of me and I'm looking for some input.

I've had Boinc running in Protected Application Execution mode on my current system for about a year with no problems. Last week I was updating my system (Windows updates & ATI Drivers). I got bored waiting for the updated to complete and opened Boinc manager to take a peek, but got a windows notification window asking if it was okay for the program to make changes to the computer. I just clicked No because I changed my mind and never seen that before when opening Bonic Manager. I also got some other weird boxes popping up saying something about not being able to connect as well.

I ignored it and finished my updates then rebooted my system. After that Boinc Manager would no longer connect. I tried everything: Turned off security, firewall, virus scanner. Attempted to reinstall Boinc with the latest version, but nothing worked. Other odd issues I noticed was I could not stop the service via services in computer management. It would only stop if I would close boinc manager and and check the box to stop running science applications, windows would pop up a window asking if the program can make changes to the computer and only if I clicked yes would it stop.

Nothing worked until I installed it without Protected Application Execution mode checked. I did however lose all current running tasks at the time to computation errors, but appeared to be running just fine, so I let it finish all remaining tasks (without errors). I came to the conclusion that it must be some sort of problem I created by playing with it while updating. Possibly some sort of raised privilege issue of running the service as it seemed to run no problem under my account, just no longer as a service. I decided to go ahead with a full re-install of Windows thinking this would solve the issue for sure.

After reinstalling everything, nothing was solved... Same issue still endures. It just refused to connect when running as a service, but appears to run no problem as a program under my account.

What could cause this? Hardware? or did Windows or ATI release an update that would cause such issues, any input would be helpful.

System:
Gigabyte 790GX Motherboard
AMD Phenom II X6 1090T CPU (Running @ 4.0GHz)
8GB G.Skill RAM (2x 4GB)
ATI Radeon HD 4890 Video Card
Windows 7 Ultimate 64bit




Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.