Posts by Duff_Moss

1) Message boards : Questions and problems : Boinc no longer connects in protected (service) mode (Message 40168)
Posted 13 Sep 2011 by Duff_Moss
Post:
I've had a chat with the BOINC developers on this one. The cause is this: "Basically the client stalls during initialization while attempting to detect CAL devices. Originally the API just errored out. Now cal_init() hangs."

Now, the only workaround they can think of is to "just skip GPU detection altogether when BOINC is installed as a service on Windows". But this will mean that when BOINC is installed as a service on Windows XP, that there the GPU detection will be disabled as well. To date the detection of the GPU while installed as a service would only not work on Windows 7 and Vista, XP would do it (since in XP the drivers are still in the same session as the limited user account).

So that would mean that either BOINC has to detect on which Windows version it's installed in before it decides to check whether a GPU is present and only do so when it's installed as a service... Or the developers will just disable the GPU detection all-together when installed as a service. I don't know which one they choose, let that be a surprise. ;-)


Thanks for the info. I suspected it must of been the ATI drivers, as it was the only thing that changed on my system. Any word on when they expect to have something ready for testing?
2) Message boards : Questions and problems : Multiple Managers getting confused with WU progress for multiple clients (Message 38733)
Posted 30 Jun 2011 by Duff_Moss
Post:
Not sure what I am doing wrong, but I can't get the boinc manager to launch as you have described:

c:\program files\boinc\boincmgr.exe -m -g 31418 -n localhost

It doesn't understand those switches. If I do a /h I dont see any of those switches listed?


3) Message boards : Questions and problems : Multiple Managers getting confused with WU progress for multiple clients (Message 38511)
Posted 17 Jun 2011 by Duff_Moss
Post:
Just check that the --detach command (as shown in the documentation) works properly for you. I recently hit a problem with it, and found that the actual source code uses --detach_phase_two, which worked better for my purposes.

Also, note that the new format --detach_console (shown in the revised documentation) will only start working from v6.12.34 at the earliest, and possibly not until v6.14



I definitely didn't use the detach command - so indeed it keeps the console open. I will give that a try too. Thanks also.

4) Message boards : Questions and problems : Multiple Managers getting confused with WU progress for multiple clients (Message 38510)
Posted 17 Jun 2011 by Duff_Moss
Post:
I do have both clients using a different port, but I wasn't launching the manager directly as you suggest. I would open the manager, which would of course connect the the 'default' client. I would open a second instance of the manager, which would also connect to the default client. I would then in the second manager connect to a new computer, and then specify the localhost with the second client's port.

So maybe it has something to do with that method. I will try as you suggest and see how it goes.

Thanks
5) Message boards : Questions and problems : CPU Throttling causing cuda task to not suspend when user active (Message 38509)
Posted 17 Jun 2011 by Duff_Moss
Post:
It definitely wasn't a boinctray problem. Boinctray was running.

If I watched the boinc manager task screen, it would mark all WUs as suspended, user active (or some such thing), indicating it detected user activity. But sometimes the currently running WU would just keep crunching away even though it was reported as suspended.

If I then let the computer go idle again, boincmanager would indicate the WU was running. If I then used the desktop again, bonicmanager would advise that the user was active and suspend the WUs. Here, again, sometimes the WU would actually suspend, but also sometimes would just keep going.

I turned on some debugging (can't remember which ones currently) which would show the client issuing a suspend command and a resume command. I saw that in those times that the WU kept running, the suspend command was not issued.

I then turned on some more debugging which showed the CPU throttle on and off commands, and they were issued every half a second. I noticed that when the suspend command was missed, a throttle on or off command occurred at the same time (hard to tell really due to the frequency, but it seemed that way after many observations).

When I turned the CPU throttle off, the WUs would suspend as they were supposed to EVERY time. This was a couple of months ago now and I've not had a single missed suspend since.

I'm sure there are other reasons for most people, but I looked on these boards at the time and couldn't find a resolution to my issue. I saw others in the same boat (had tried all other suggestions) and I simply offer that what I observed may help some others here too.
6) Message boards : Questions and problems : CPU Throttling causing cuda task to not suspend when user active (Message 38493)
Posted 16 Jun 2011 by Duff_Moss
Post:
Thought I'd post a solution to a problem I was having - that may be of use to others.

I was running a client on a PC with a NVIDIA card. I was only processing GPU tasks. I configured the system to suspend if the user was active, however I found that often as not, the cuda task would not suspend. It seemed completely random as to when it would or would not work correctly.

It drove me nuts for weeks and I eventually found it was the CPU throttling. I had CPU throttling set to 50% (from a former time when I was doing non cuda crunching) and I think it was creating a race condition, so that if the instruction to throttle coincided with the instruction to suspend the WU, it would sometimes get missed.

I didn't try it, but I suspect if the throttling was say use 80% of CPU, then the frequency of the failure would be less, as the client would be issuing a throttle command less frequently.

Either way, if you're having problems with tasks not suspending, and you have throttling turned on - turn it off and see if it helps you too.

I tried various BOINC versions and had the same issue.
7) Message boards : Questions and problems : Multiple Managers getting confused with WU progress for multiple clients (Message 38492)
Posted 16 Jun 2011 by Duff_Moss
Post:
Hi,

This problem has been bugging me for a while, and I can't seem to solve it.

I have two boinc clients running and two managers - one for each boinc client. That works well enough. The problem I have is that the elapsed time, progress and time to complete gets confused on the managers.

What seems to happen, is that both managers report the progress of the first active unit of the first client that is launched on the system. Besides that, all other details are correct (workunit name, project etc). I know the WU is processing properly as the progress is correct in the stderr.txt file. The WU completes ok - just the manager doesn't track it's progress correctly.


I am running BOINC 6.10.60


I am running two clients because I have one that is run as a service. Problem with run as a service is that it wont recognise my ATI GPU, so I run a second on demand client that only does GPU work.

Any ideas




Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.