Posts by Penguirl

1) Message boards : Questions and problems : Exclusive Applications Issue (Message 62984)
Posted 11 Jul 2015 by Penguirl
Post:
Thank you all for your help. I had to set the issue aside for a few days, when I came back to it I found that Heroes.app was no longer in the exclusive apps list so I added it again along with another app I found, HeroesSwitcher.app, and Exclusive Apps is now working as it should.

Again, thank you for your help. I appreciate it very much.
2) Message boards : Questions and problems : Exclusive Applications Issue (Message 62889)
Posted 3 Jul 2015 by Penguirl
Post:
Thank you for the suggestion Gary. The Exclusive applications interface in BOINCManager.app is strictly Add… or Remove. When you click Add… it brings up a small Finder window where you can select the app to add to the Exclusive Applications list. On a whim I tried using this Finder window to search for Heroes.app, which is what it shows up as in Little Snitch, and Finder found it (I never knew Finder would search a quasi-folder directory package thing). However after adding Heroes.app to the Exclusive applications list from Finder search BOINCManager.app still does not respect the setting.
3) Message boards : Questions and problems : Exclusive Applications Issue (Message 62879)
Posted 2 Jul 2015 by Penguirl
Post:
Thank you Ageless. BOINC is set to run based on preferences. I have tried to select the binary, Heroes of the Storm.app/Versions/Base36144/Heroes.app but the folder is grayed out in the Exclusive Applications window so I can’t select anything in it, even when logged it as admin (GUI, not cl). To view it in Finder I have to right click/Show Package Contents just to see inside it, and I can’t drag & drop the binary into the BOINC Exclusive Applications window either, even when logged in as Admin.

For what it’s worth, Heroes of the Storm.app/Versions/Base36144/Heroes.app is owned by me so I have full read/write permissions.
4) Message boards : Questions and problems : Exclusive Applications Issue (Message 62870)
Posted 2 Jul 2015 by Penguirl
Post:
I am having trouble getting BOINC to obey the Exclusive Applications setting. I have one entry in this field, the new Blizzard game Heroes of the Storm, and BOINC keeps running work units when I am playing this game forcing me to stop and restart it manually. The GPU is set not to run when computer is in use and it does respect this setting.

BOINC v7.6.2 (the current “stable” version was giving me a problem that I have now forgotten but 7.6.2 fixed it)
Installed as admin and then ran Charlie Fenton's script dated 01/06/2008 Make_BOINC_Service.sh
Mid 2010 Mac Pro, quad core Xeon @ 2.4 GHz
8 GB RAM
OS X v10.9.5
Heros of the Storm v1.11.6.2439 (latest version)
5) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51589)
Posted 28 Nov 2013 by Penguirl
Post:
I am using Silverlight 5.1.20913.0 which according to MacUpdate is the current version. Netflix is very strict about using the current version, if they detect a previous version they will tell you to upgrade and they will not let you use their streaming services until you do install the current version.

So windowed mode seems to be working correctly, it is just full screen mode that is not. I too am running BOINCManager 7.2.33 but getting different result. For the time being I have set the GPU to wait 120 minutes before starting to crunch BOINC projects which covers most movies.
6) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51539)
Posted 25 Nov 2013 by Penguirl
Post:
Let me be a little more specific. If I’m watching web video windowed the screen saver will activate, if I’m watching full screen the screen saver does not activate.
7) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51504)
Posted 24 Nov 2013 by Penguirl
Post:
I rebooted after setting Exclusive Applications and the GPU still goes back to work about 3:05 after the last user input while playing video. The screen saver is not an issue, it recognizes Flash, Silverlight, QuickTime, VLC, etc… as being active and does not run until 10 minutes after the video ends. MPlayer X used to not keep the system active but they’ve since fixed that bug and I’ve had no problems with movies & screen saver since.
8) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51485)
Posted 23 Nov 2013 by Penguirl
Post:
BOINCManager is not respecting the Exclusive Applications setting for browsers or players, at about 3:05 after the last user input the GPU resumes computation.
9) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51451)
Posted 22 Nov 2013 by Penguirl
Post:
If I understand correctly, BOINC is resuming your GPU applications after 3 minutes even though you are watching streaming videos. Is that correct?

I still can't reproduce this viewing YouTube videos with Safari 7. Please answer these 2 questions:
* Does BOINC resume GPU apps after 3 minutes when you watch YouTube videos with Safari 7? (You can check this by running /Applications/Utilities/Activity Monitor.)
*Are you using Safari 7 to watch Hulu and Netflix?

You might try adding the applications you use to view the video to the list of Exclusive Applications in BOINC's Computing Preferences dialog. (This application may be your web browser.) Please let me know if that solves your problem.


I do not have Flash Player installed system wide so I cannot test YouTube with Safari 7, even though I signed up for the html 5 beta (thanks Google). Using Chromium Version 30.0.1599.69 (226629) the current GPU project goes active a few seconds after 3 minutes of no user input, just streaming video. I watch Netflix on Safari, it uses Silverlight, and the result is the same - the GPU project goes active a few seconds after 3 minutes of no user input, just streaming video.

I will try adding Safari, Chromium, both QuickTime Players, MPlayer X, and Movist to the list of exclusive applications and get back to you on the result.
10) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51419)
Posted 21 Nov 2013 by Penguirl
Post:
Pretty much all of them that support Open CL for OS X I believe. Off the top of my head, Einstein, PrimeGrid, Collatz…

Do GPU process’ show up in Activity Monitor? Is there a specific name I should look for?
11) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51401)
Posted 20 Nov 2013 by Penguirl
Post:
I have been able to boil the issue down to this - if I have BoincManager set to use GPU based on preferences, three minutes after the last user input (which is what BOINC - Preferences is set to) the video becomes jerky or jagged. If I set BoincManager to suspend GPU the video remains stable. This applies to streaming video, local VIDEO_TS and local compressed (m4v) files.

The logs appear fine, they show the GPU adhering to the preference settings, but the issue is real and now reproducible.

I do not know if it might be related or not but some apps have developed serious memory leaks under 10.9, DefaultFolder X and MPlayer X being two of them (I have installed patched versions of both).
12) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51334)
Posted 15 Nov 2013 by Penguirl
Post:
I have been unable to reproduce the problem. The OS 10.9 (almost wrote OS 9 there lol) build number is: 13A603

If I do see the problem again I will attempt to get some relevant information from the logs. Thank you.
13) Message boards : BOINC Manager : 10.9 Mavericks & Open CL Issue (Message 51191)
Posted 6 Nov 2013 by Penguirl
Post:
Recently I upgraded to 10.9 Mavericks and a new issue has appeared. When watching web video such as Hulu or Netflix, windowed or full screen, Gecko or WebKit, BOINC/BOINCManager is not seeing that the computer is in use and starts computing work on the ATI Radeon HD 5770 in my 2010 Mac Pro while the video is still playing. BOINC/BOINCManager respects the “Only after computer has been idle for x minutes setting, it just does not see the computer is in use unless there is activity on an input device. This was true in v7.0.65 and it still holds true in v7.2.23.

Thank you all for your hard work.
14) Message boards : BOINC Manager : 6.12.26 Mac BOINC as Service Broken (Message 38558)
Posted 19 Jun 2011 by Penguirl
Post:
After switching back to 6.10.58 I have six computation errors, I've not caught any in the past.
15) Message boards : BOINC Manager : 6.12.26 Mac BOINC as Service Broken (Message 38553)
Posted 18 Jun 2011 by Penguirl
Post:
Currently I am running BOINC 6.12.33 as an app, 5 of the CPUs are running at low percentage just slightly above the system requirements, and 3 are at 0%. BOINC is connected to localhost, the WUs that are "running" are not elapsing any time. Quitting BOINCManager brought the 5 active CPUs down no nearly 0%.
16) Message boards : BOINC Manager : 6.12.26 Mac BOINC as Service Broken (Message 38455)
Posted 15 Jun 2011 by Penguirl
Post:
Turns out I already have /etc/sysctl.conf with the settings:

kern.sysv.shmmax=16777216
kern.sysv.shmmin=1
kern.sysv.shmmni=128
kern.sysv.shmseg=32
kern.sysv.shmall=4096

It must have carried over as I migrated machines.
17) Message boards : BOINC Manager : 6.12.26 Mac BOINC as Service Broken (Message 38410)
Posted 14 Jun 2011 by Penguirl
Post:
I have configured shared memory in the past on my PPC machines, does this still apply to a SL Xeon? It seems odd that this wasn't an issue with 6.10.x, it only started with the update to 6.12.x.

All of the <api_version> are at or above 6.

I have not yet tested without the launch daemon but I will let you know as soon as I do.
18) Message boards : BOINC Manager : 6.12.26 Mac BOINC as Service Broken (Message 38378)
Posted 13 Jun 2011 by Penguirl
Post:
The only BOINC related process running at the latest event (all CPUs are idle) is BOINCMenubar 2, no other BOINC process' are running with Activity Monitor.app set to show all process. BOINCMenubar 2 says "This Computer (localhost) Host not connected."

stderrdae.txt has a LOT of "shmat: Too many open files" at the beginning of the document, followed by a bunch of "md5_file: can't open projects/szdg.lpds.sztaki.hu_szdg/caa03215-1b38-489c-abd4-252c594ad6ff_f1075c82-cfb2-4ba5-bb7a-0b69cbe700c4_565740_1_1" in the middle, then "GetMACAddress returned 0x00000005" appears twice, and then a LOT of "shmat:Too many open files" again.

stdoutdae.txt shows normal looking start, resuming, uploading, etc… of workunits but ends with "12-Jun-2011 19:49:16 [yoyo@home] Computation for task ogr_110610103054_79_0 finished
12-Jun-2011 19:49:16 [yoyo@home] Resuming task ecm_es_1307868011_2_1232P.C271_1455_0 using ecm version 1
12-Jun-2011 19:49:18 [yoyo@home] Started upload of ogr_110610103054_79_0_0
12-Jun-2011 19:49:18 [yoyo@home] Started upload of ogr_110610103054_79_0_1
12-Jun-2011 19:49:18 [---] Can't open client_state_next.xml: fopen() failed
12-Jun-2011 19:49:18 [---] Couldn't write state file: fopen() failed; giving up"

I am using Make_BOINC_Service.sh dated 01/06/08 to use launchd

BOINCManager says at launch "BOINC Manager - Daemon Start Failed
BOINCManager is not able to start a BOINC client. Please start the daemon and try again."

And then the CPUs jumped to 100%, relaunch of BOINCManager works normally.
19) Message boards : BOINC Manager : 6.12.26 Mac BOINC as Service Broken (Message 38181)
Posted 5 Jun 2011 by Penguirl
Post:
I have no crash logs related to boinc in either of those locations, or in Console. I haven't pruned my crash logs since these incidents so it would seem that no crash entries were written.
20) Message boards : BOINC Manager : 6.12.26 Mac BOINC as Service Broken (Message 38056)
Posted 30 May 2011 by Penguirl
Post:
6.12.28 hung for a minute after installation, but then it connected to localhost and work commenced. Today upon unlocking the screen I found my CPUs at idle, launching BOINCManager showed it was disconnected from localhost.


Next 20

Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.