Posts by NullCoding*

21) Message boards : Projects : Pledge to run BOINC on my Android phone/gadget (Message 48458)
Posted 1 Apr 2013 by Profile NullCoding*
Post:
Nice list, Russell :)

-

I pledged to run BOINC on anything (ideally everything) in my house long ago. If I can be bothered to run Pentium IIIs and PowerMac (ppc) G4s, I may as well run something modern but beta.

Currently limited to my VZW HTC Droid DNA. It's got a 1,5GHz quad-core and running NativeBOINC 24/7 (plugged in, of course) I barely notice any performance issue...

Example stats...

I highly recommend NativeBOINC as it eliminates about 99% of the guesswork that can go into running a beta app - or in the case of BOINC, anything not yet officially supported. It's even in the app store.

Of course, if you find other platforms easier to use or whatever, go ahead - the credits are the same.

NativeBOINC comes bundled with Android-ported apps for some projects ready to go anyway, which is good for me because I have enough programming projects going at once...

I pledge to get BOINC running on my toaster, Macintosh LC II, and TI-84 graphing calculator within the next year! ;)
22) Message boards : Questions and problems : BOINC + Android (ARMv7 v7l) = Nope. (Message 48177)
Posted 13 Mar 2013 by Profile NullCoding*
Post:
Okay, the storage issue certainly makes sense. It doesn't explain why I was unable to get any work, but after more research noticed you are quite right in that there are very extremely few projects which currently offer a specific Android app. A couple offer apps for Linux on ARM, but they are usually the same projects with Android apps.

Hmm. I do need to learn more about how Android actually works. Knowing that will change how I develop my own apps ultimately.

Thanks for the replies, developers and all!
23) Message boards : Questions and problems : BOINC + Android (ARMv7 v7l) = Nope. (Message 48170)
Posted 12 Mar 2013 by Profile NullCoding*
Post:
Okay!

So I'm using NativeBOINC, which is really quite well-written.

It comes pre-bundled with up-to-date binaries for all current projects supporting ARM architecture - unofficially of course, but they run.

Well, they run, but not for very long, and the results aren't always usable. I'm only doing WUProp and SubsetSum WUs, and the former gets tons of computation errors (no output file) and SubsetSum WUs don't error out, but often return results that are simply wrong! It's a mathematical project, which leads me to believe the tasks done by ARM machines are quite literally doing incorrect math...how odd.

If I wasn't so preoccupied with my own current coding project(s), I'd offer all the help I can! I won't be that busy for much longer, I sure hope, and since my next endeavor involves Android coding / porting of applications I've already written, I see no reason why I can't include at least some BOINC testing :)

Thanks for the reply!

Meanwhile, the developers should "invest" in some of those little Android mini-PCs - like this - and by "invest" I mean politely request what's essentially petty cash from the operating budget. :P

There are Android boards targeted at developers! It's the future of portable computing, meaning computers that you can put in your pocket and carry around...I'm sure they already know about this but in case they didn't, now they do! I'm thinking of the Hackberry A10 and suchlike. I want one myself, and if I'm considering it, it must be affordable. heh.

I suppose Android is simply proliferated further than iOS and Windows CE or Windows Mobile or Windows Embedded. Not surprised. Well in any case I'll certainly be keeping up with all the developments!
24) Message boards : Questions and problems : BOINC + Android (ARMv7 v7l) = Nope. (Message 48156)
Posted 12 Mar 2013 by Profile NullCoding*
Post:
Oh felt I should mention that in the meantime I am simply using NativeBOINC, which appears to be working properly thus far.

If it's simply a matter of the official Berkeley version missing some kind of feature set specifically for my kind of phone, okay.

So it looks like this on a project. Cool.



All that said, I'm definitely interested in the porting of BOINC to Android in some kind of native form. I will definitely keep up with the progress and all!
25) Message boards : Questions and problems : BOINC + Android (ARMv7 v7l) = Nope. (Message 48155)
Posted 12 Mar 2013 by Profile NullCoding*
Post:
Cutting to the chase:

I was unable to find any information about how to run BOINC on Android - specifically, using the official Berkeley installer (.apk) on not a tablet, but a smartphone.

Granted, my particular phone is often referred to as a "fablet" (or "phablet?") i.e. "phone-tablet," as it's rather large in size. The screen itself is larger than an iPhone 4S. I have an HTC Droid DNA, which is comparable to the perhaps more commonly-seen Samsung Galaxy SIII. They are like a Nikon DSLR and a Canon DSLR. When it comes to brass tacks, hard to pick a clear winner.

In any case I happen to know my phone has a "quad-core CPU." Granted, I'm not entirely sure there are even any apps for Android in existence which can actually address all four...but I thought that if anything could, it'd be BOINC (hopefully).

I also happen to know that many, many people run / have run / continue to run BOINC on their smartphones - often models older than mine!

However, I installed the BOINC package from Berkeley (which I do recognize is a development release) and attached to a few projects that I knew to support Android.

All I'm getting is "This project does not support computers of type arm-android-linux-gnu."

hmm?

That and there's no way to edit computing preferences (I will NOT "root" my device - afraid I can't go into the exact reasons here though) that I can see, so for all I know it IS recognizing "four cores" but only using one, which I believe is the default setup (use "0%" of multi-core systems, i.e one core)

Here is my "host" at SubSetSum, which was specifically recommended to me for Android.

Here is another "host" at the same project with what appears to be an older (albeit apparently faster) CPU as well as an older OS, and it's gotten more credit than my quad-core i5-2350M 2,3GHz has in less calendar time! O_o

What on earth am I doing wrong here?

I assume I need to use an anonymous platform, but without direct access to the /data/ directory, I see no way so to do.

I also assume I need to change my computing preferences, but I cannot find a way to do that either.

I know there are other versions of BOINC for Android out there, but it's late and I'm just gonna leave this here for now and experiment with other apps tomorrow.

If I'm missing something obvious, please be nice about it...I tend to blow things out of proportion until I end up blaming things like overheated DIMMs and unstable overclocking and other irrelevant things.

tl;dr they told me this is a super-powerful phone; they are correct; it won't crunch; I would like it to; halp

:)
26) Message boards : GPUs : "This GPU does not support openCL" (Message 45923)
Posted 8 Oct 2012 by Profile NullCoding*
Post:
Beta drivers did not work. I tried both versions of 12,9 - one "without" .NET 4,0 and one with .NET 4,0 support...still getting the "does not support OpenCL" message.

I have yet to try rolling back to an earlier driver, but I'm somehow more confident that I need a driver supporting Win8, which means 12,8 and higher including the betas.

Later this afternoon I'll try an earlier version anyway - which do you recommend?
27) Message boards : GPUs : "This GPU does not support openCL" (Message 45901)
Posted 5 Oct 2012 by Profile NullCoding*
Post:
It's still a beta? Funny, didn't see Microsoft as the type to give me a full-featured server OS that's a beta without even telling me. Then again, why am I surprised? Win8 hasn't hit RTM yet so I guess I should have thought that one through.

I installed the drivers correctly. I am more willing to believe it is this particular version of driver. AMD says it's meant for Win8, but there's been nowhere near enough time for adequate testing with the developer preview. I will try also an older version (for instance the one that has my 6950 cranking out lots of credits), then if not satisfied, the beta drivers.

If all that fails, I'll dig up a legitimate version of Win7 (gotta be one around here somewhere) and start anew.

Problem is we'll have to wait til Monday or so for results; I'm currently out-of-state.

Thanks for the tips!
28) Message boards : GPUs : "This GPU does not support openCL" (Message 45892)
Posted 4 Oct 2012 by Profile NullCoding*
Post:
I built a machine yesterday that runs two AMD 6850s in CrossFire. It runs Collatz out of the box perfectly. But that's about it.

See, DistRTGen and POEM both require OpenCL (and essentially require app_info as well). But I get the message that "This GPU does not support OpenCL"

I call BS! Of course it supports OpenCL! I installed the latest Catalyst - twice, in fact, to be sure...

I am cleverly running Windows 8 Server (Windows Server 2012). Is that the problem...?

Or else how do I install OpenCL? I thought it came with Catalyst!
29) Message boards : Projects : News on Project Outages (Message 44833)
Posted 11 Jul 2012 by Profile NullCoding*
Post:
NumberFields@Home is temporarily down as of yesterday around 1900UTC.

-

Additionally, would anyone happen to know the status of either Enigma@Home or Mersenne@Home projects? Both are up but no work for some time. Just wondering.
30) Message boards : Questions and problems : BOINC 7.0.28 + XP x86 (Message 44757)
Posted 5 Jul 2012 by Profile NullCoding*
Post:
Nah you're right, I read too much into it. It's not really a big deal.

I haven't used BOINCTasks in quite some time. I'll check it out!

Or, yeah, add the project through command line.

Thanks for the advice. I guess I'll blame the computer on this one, since it's clearly not BOINC's problem. 7,0,28 has been perfectly stable for me everywhere else.

Happy crunching
31) Message boards : Questions and problems : BOINC 7.0.28 + XP x86 (Message 44755)
Posted 5 Jul 2012 by Profile NullCoding*
Post:
Please, do not post the complete contents of that file here. That's overkill.


I wouldn't dare. It's a bunch of gibberish anyway. Absolutely nothing helpful. It's barely readable, but from what I see, nothing in the file points to the crash when trying to add a project!

I may just try downgrading again, yeah. Thanks for the tip!

I assume that since you advice is to downgrade that you have no idea what causes this crash? Odd, isn't it.
32) Message boards : Questions and problems : BOINC 7.0.28 + XP x86 (Message 44744)
Posted 5 Jul 2012 by Profile NullCoding*
Post:
I upgraded BOINC and most of the software on my entire deployment today.

Everything was going fine until I tried to add a project!

This only happens on one machine. I try to open the add project dialog, click next, and BOINC freezes and quits.

XP Pro 32-bit
P4 520 @ 3,0GHz
GTX 460 OC

System and runtimes and drivers are fully up-to-date. Previously this one was running 6,12,34 perfectly fine, but I decided to upgrade. I understand there is no way to easily downgrade, or I would (if that would even solve this)

I did see another thread in here about problems on XP 32-bit, but I have not encountered any. It runs perfectly fine, but I cannot add any new projects!

Something I did wrong? Or what?

If it counts for anything, I have a machine running 32-bit Win7 Enterprise x86 and 7,0,28 with no issues whatsoever. Granted it is brand new and the P4 machine is definitely not.
33) Message boards : Projects : News on Project Outages (Message 41118)
Posted 11 Nov 2011 by Profile NullCoding*
Post:
FreeHAL is MIA. Or AWOL. Can't decide.

From what BOINC and FireFox will tell me the server(s) are down. Odd that all my machines were able to upload their work, but I can't get any more. :|

34) Message boards : Questions and problems : (OSX) BOINC suddenly unstable (Message 40809)
Posted 24 Oct 2011 by Profile NullCoding*
Post:
Ok, as of now I have completely removed BOINC and all its components from my laptop, and am instead running two VMs. They are both Windows variants and running perfectly fine, BOINCing it up. Later today when I've some time and am at home, I may try reinstalling again, but first I want to run some quick diagnostics on the machine.

A friend of mine is a more expirenced Mac tech than I, and when I informed him of this problem he said it's likely caused by either directory corruption, invalid permissions, or some kind of corrupt (most likely user-inflicted) OS file/s. Again, I'm at a loss as to what that could be.

BOINC is running fine on my older C2D MacBook, though it does get quite hot. No such problems with freezing up since I updated it to 6.12.35. Blah why do the most complex problems always happen to me. This doesn't even seem to be a problem reproducible on other machines...
35) Message boards : Questions and problems : (OSX) BOINC suddenly unstable (Message 40755)
Posted 21 Oct 2011 by Profile NullCoding*
Post:
Yes it is a MacBook Pro mid-2010. Been running BOINC on it for a year and a month now.

The CPU hovers between 76-85ÂșC. That's normal for this model at high load. Completely stable.

Currently it is running a PrimeGrid sub-project called PRPNet. This runs 4 instances of a VERY CPU-intensive program called LLR, a primality testing program. CPU usage at 400% (100% x2 cores x4 threads). It's fine.

If there was a problem with my memory then TechTool 6 would have picked it up. I ran a test, came up fine. That doesn't matter though, as I'll be popping in these shiny new 4GB modules (to make 8 total) within a few hours.

I'll start to blame my hardware when and if any other problems arise. A thorough computer check a month ago revealed nothing. Sure I'll check again when I've time. Right now though, not too worried.
36) Message boards : Questions and problems : (OSX) BOINC suddenly unstable (Message 40753)
Posted 21 Oct 2011 by Profile NullCoding*
Post:
Funny you should mention, as this is a year-old machine with warranty and modern-ish technology (pre-Sandy Bridge, sad face). The 8 GB RAM upgrade I've wanted for so long (Parallels and Adobe CS5, as the latter is my other job!) came in the mail literally yesterday afternoon.

If my laptop is broken somehow, I'll not be a happy camper. It's just that BOINC is the only thing not working. I don't think my laptop is angry at BOINC, or that there's a special BOINC chip on the mobo that's gone on the fritz.

Hell it might not be BOINC's fault. Could be OSX corrupted again. If that's the case, again, not a happy camper will I be. Unfortunately won't get a chance to run diagnostics til Monday.

All I know is my programs work, my internet works, my ports work, PRPNet works. BOINC doesn't.
37) Message boards : Questions and problems : (OSX) BOINC suddenly unstable (Message 40747)
Posted 21 Oct 2011 by Profile NullCoding*
Post:
That makes no sense.

Since I have not made any modifications to my OS there is no logical reason why this should suddenly be happening. It is a fresh install (~3 weeks ago) and BOINC ran fine until now minus a few freeze-ups when the client stopped communicating properly with the Manager, which happens on all my Mac systems.

I've had that problem before but never to the point where an app crashes upon opening.

In that case, I will no longer run BOINC on this machine until there is a more stable version available for OSX.
38) Message boards : Questions and problems : (OSX) BOINC suddenly unstable (Message 40737)
Posted 20 Oct 2011 by Profile NullCoding*
Post:
Ughh yes you're right...most descriptive thread on the topic I found was about Thunderbird and had little to do with OSX; mainly the discussion was focused on the app. Even I know thread 0 exceptions are the OS, not the app...

Today is not my day. Would have replied sooner but was fussing with WinServer 2008 active directory controls to no avail...poor kids locked out for no good reason, and I can't help 'em after 45 minutes or so...now it appears that the best solution for me here is to either do a complete repair install of my OS (which I would really rather not do, as I just did a fresh install) or downgrade to 10.6.7 (which makes no sense)

Well I'll eagerly await the developer's reply, since the complete BOINC reinstall did nothing.
39) Message boards : Questions and problems : (OSX) BOINC suddenly unstable (Message 40732)
Posted 20 Oct 2011 by Profile NullCoding*
Post:
Well I moved things into place properly and installed the newer BOINC to which you linked. Same error.

Process:         BOINCManager [60061]
Path:            /Applications/BOINCManager.app/Contents/MacOS/BOINCManager
Identifier:      edu.berkeley.boinc
Version:         BOINC version 6.12.41 (6.12.41)
Code Type:       X86 (Native)
Parent Process:  launchd [203]

Date/Time:       2011-10-20 09:49:10.048 -0400
OS Version:      Mac OS X 10.6.8 (10K549)
Report Version:  6

Interval Since Last Report:          295472 sec
Crashes Since Last Report:           13
Per-App Interval Since Last Report:  1 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      DCCB06FE-D236-416A-9D2F-FC1F0116715B

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Application Specific Information:
*** Terminating app due to uncaught exception 'NSImageCacheException', reason: 'Cannot lock focus on image <NSImage 0x1205cc0 Size={0, 0} Reps=(
)>, because it is size zero.'
*** Call stack at first throw:
(
	0   CoreFoundation                      0x90dc56ca __raiseError + 410
	1   libobjc.A.dylib                     0x924085a9 objc_exception_throw + 56
	2   CoreFoundation                      0x90dc53f8 +[NSException raise:format:arguments:] + 136
	3   CoreFoundation                      0x90dc536a +[NSException raise:format:] + 58
	4   AppKit                              0x92fc3596 -[NSImage _lockFocusOnRepresentation:rect:context:hints:flipped:] + 267
	5   AppKit                              0x92fc347f __-[NSImage lockFocusWithRect:context:hints:flipped:]_block_invoke_1 + 114
	6   AppKit                              0x92eb3820 -[NSImage _usingBestRepresentationForRect:context:hints:body:] + 189
	7   AppKit                              0x92fc3405 -[NSImage lockFocusWithRect:context:hints:flipped:] + 204
	8   AppKit                              0x9301a670 -[NSImage lockFocusFlipped:] + 138
	9   AppKit                              0x9301a5dd -[NSImage lockFocus] + 64
	10  AppKit                              0x93070af0 -[NSWindow _generateScaledBackground] + 318
	11  AppKit                              0x93070837 -[NSWindow(NSWindow_CarbonEventHandlers) _setWindowDepth] + 126
	12  AppKit                              0x9350575d -[NSWindow(NSWindow_CarbonEventHandlers) _installCarbonWindowEventHandlers] + 121
	13  AppKit                              0x93070368 -[NSWindow(NSCarbonExtensions) windowRef] + 561
	14  AppKit                              0x933cfe32 -[NSStatusBarWindow windowRef] + 80
	15  AppKit                              0x92e7261a -[NSWindow _reallyDoOrderWindow:relativeTo:findKey:forCounter:force:isModal:] + 1112
	16  AppKit                              0x934c6821 -[NSWindow orderFrontRegardless] + 82
	17  AppKit                              0x933cfaf3 -[NSStatusBar(NSStatusBarCGS) _CGSinsertWindow:withPriority:] + 355
	18  AppKit                              0x933cd71d -[NSStatusBar _insertStatusItem:withPriority:] + 80
	19  AppKit                              0x933d0e28 -[NSStatusItem _initInStatusBar:withLength:withPriority:hidden:] + 462
	20  AppKit                              0x933d0082 -[NSStatusItem _initInStatusBar:withLength:withPriority:] + 63
	21  AppKit                              0x933d00f1 +[NSStatusItem _itemInStatusBar:withLength:withPriority:] + 105
	22  AppKit                              0x933cd853 -[NSStatusBar _statusItemWithLength:withPriority:] + 58
	23  AppKit                              0x933cd8d3 -[NSStatusBar statusItemWithLength:] + 49
	24  SystemMenu                          0x017ad4f2 0x0 + 24827122
	25  SystemMenu                          0x017adce9 SetUpSystemMenu + 205
	26  BOINCManager                        0x0005630e 0x0 + 353038
	27  BOINCManager                        0x000564e4 0x0 + 353508
	28  BOINCManager                        0x00037166 0x0 + 225638
	29  BOINCManager                        0x00037645 0x0 + 226885
	30  BOINCManager                        0x002be14f 0x0 + 2875727
	31  BOINCManager                        0x00034d66 0x0 + 216422
	32  BOINCManager                        0x0002718a 0x0 + 160138
	33  BOINCManager                        0x000270b1 0x0 + 159921
	34  ???                                 0x00000002 0x0 + 2
)


Then it gives the whole "thread 0 crashed" and lists all the libraries, dependencies etc.

Mystifying. I'll run PRPNet for now.

I honestly changed nothing between the time 6.12.35 was running smoothly and the time it decided to crash and burn. Utterly bizzare.
40) Message boards : Questions and problems : (OSX) BOINC suddenly unstable (Message 40731)
Posted 20 Oct 2011 by Profile NullCoding*
Post:
Ok, thanks. That's a version meant for testing, no? I will give it a shot and post results in a few moments.

What about my system could bring up an error so unusual the developer's attention is required? (or is that SOC and I'm just over-thinking?)


Previous 20 · Next 20

Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.