Posts by MLx

1) Message boards : BOINC client : BOINC not working in NAT64? (Message 80267)
Posted 17 Aug 2017 by MLx
Post:
Ran Wireshark and sure enough - there are DNS queries going out for rnaworld.de and bam.boincstats.com, but the requested record is A, not AAAA.

I read somewhere (had a quick google session), that BOINC uses its own DNS resolver - is that (still) true? That's where the problem most likely is.

@Devs: If you don't have access to proper NAT64, macOS can be used to create such a network (System Preferences -> Sharing -> Internet) since 10.11 I believe (see link to guidelines in the OP). There is a small difference (all DNS queries from the client are changed to A queries to upstream DNS, so all connections use NAT64), though that shouldn't make a difference as long as the servers are available via IPv4.
2) Message boards : BOINC client : BOINC not working in NAT64? (Message 80265)
Posted 17 Aug 2017 by MLx
Post:
Has anyone tried using BOINC in a NAT64+DNS64 network? I've moved my laptop to such network (after previously using it in IPv4-only and dual-stack Internet-connected networks), and nothing seems to work - boincstats BAM won't connect (fails with Account manager RPC failed: transient HTTP error), projects won't connect (tried LHC@home, RNA World and climateprediction.net, all fail with Scheduler request failed: Server returned nothing (no headers, no data).)

BOINC 7.6.34 on macOS 10.12.6

Dev guide: https://developer.apple.com/library/content/documentation/NetworkingInternetWeb/Conceptual/NetworkingOverview/UnderstandingandPreparingfortheIPv6Transition/UnderstandingandPreparingfortheIPv6Transition.html

Long story short:
    IPv4-only servers must be accessed via hostname. The translated address from the 64:ff9b::/96 prefix is provided by the DNS64 server (using google's 2001:4860:4860::6464)
    IPv4 literals won't work, use high-level APIs that will work with either IPv4 and IPv6

3) Message boards : Projects : News on Project Outages (Message 36484)
Posted 19 Jan 2011 by MLx
Post:
Yoyo@home along with entire http://rechenkraft.net seems to be down for me. Does anyone have more details?
4) Message boards : Projects : News on Project Outages (Message 36036)
Posted 11 Dec 2010 by MLx
Post:
Any news on QuantumFIRE? It's been almost 2 months since the site went down, and a result I didn't get to upload is a month overdue. :(




Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.