Posts by breakone9r

1) Message boards : GPUs : I can't get Intel HD Graphics 4000 to work on Ubuntu 18.04 (Message 98144)
Posted 29 Apr 2020 by breakone9r
Post:
It's a possibly a permissions problem.

I had a similar issue:

In my case, I needed to add the boinc user to the render group, but I'm running OpenSUSE, so you might have to add it to a different group.

According to Intel's website:
To allow NEO access to GPU device make sure user has permissions to files /dev/dri/renderD*.
2) Message boards : GPUs : GPU set to suspend on activity, but only suspends when I open a console program or login remotely. - Linux (Message 98137)
Posted 29 Apr 2020 by breakone9r
Post:
Right now, I'm logged into X, no console open. only Firefox, and BOINC Manager running in the foreground. Status for my GPU apps (In this case, Milkyway@Home) is continuing to run, despite me typing this, and moving my mouse around.

However, if I open a console program, such as Konsole? Poof. It switches to suspended. I can verify both activity and suspend, as I have another program that allows me to set custom fan curves, voltages, and clock speeds and see temps and fan speeds for my Vega 56. (the program in question is named radeon-profile, for those who are curious.)

Also, even if I ssh in from another system (I just verified this by sshing in from my phone) it will switch to Suspended.

I mean, there's no GPU usage when I'm ssh'd in remotely.

What in the world is going on here?

System:
Ryzen 7 2700x
16G
1TB SSD
4TB HDD
Vega 56
System: Host: zenstation Kernel: 5.6.6-1-default x86_64 bits: 64 compiler: gcc v: 9.3.1 Desktop: KDE Plasma 5.18.4
tk: Qt 5.14.1 wm: kwin_x11 dm: SDDM Distro: openSUSE Tumbleweed 20200425
CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP arch: Zen+ rev: 2 L2 cache: 4096 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 118384
Speed: 2029 MHz min/max: 2200/3700 MHz boost: enabled Core speeds (MHz): 1: 1927 2: 2038 3: 2198 4: 2198 5: 2199
6: 2197 7: 2197 8: 2198 9: 1952 10: 2197 11: 2026 12: 2194 13: 1887 14: 1898 15: 2065 16: 2004
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Vega 10 XL/XT [Radeon RX Vega 56/64] vendor: ASUSTeK driver: amdgpu
v: kernel bus ID: 1f:00.0 chip ID: 1002:687f
Display: x11 server: X.org 1.20.8 compositor: kwin_x11 driver: amdgpu FAILED: ati unloaded: fbdev,modesetting,vesa
resolution: <xdpyinfo missing>
OpenGL: renderer: Radeon RX Vega (VEGA10 DRM 3.36.0 5.6.6-1-default LLVM 10.0.0) v: 4.6 Mesa 20.0.4
direct render: Yes
Info: Processes: 360 Uptime: 1h 12m Memory: 15.58 GiB used: 2.40 GiB (15.4%) Init: systemd v: 245 runlevel: 5
target: graphical.target Compilers: gcc: 9.3.1 alt: 9 Shell: zsh v: 5.8 running in: konsole inxi: 3.1.00




Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.