Posts by linuxcruizer

1) Message boards : Questions and problems : gui_rpc_auth.cfg exists but can't be read. Check the File permissions. (Message 104623)
Posted 26 Jun 2021 by linuxcruizer
Update: The following may be of interest: I discovered after the stop of a boinc account manager, no more issues. Next, I changed back from KDE to a Cinnamon Desktop. The operation of my Desktop with the boinc managers has gone back to being very stable. The two PCs that I have left with KDE desktops became stable after removing the Boinc Account Manager and tweaking /etc/default/boinc-client "# Set this to 1 to enable and to 0 to disable the init script.
ENABLED="1" (see footnote)
As stated in prior post, this allows the boinc client and boinc manager to run at startup.

I am not sure why the boinc account manager was causing me issues, or it maybe it was my layered distribution. I really like using a KDE desktop, but I have found that I have a new appreciation for the stability of my Cinnamon Desktop.

Thanks again for everyone's input, all of your heavy lifting has helped.

footnote: tweaking information was gleaned from <>
2) Message boards : Questions and problems : gui_rpc_auth.cfg exists but can't be read. Check the File permissions. (Message 104621)
Posted 25 Jun 2021 by linuxcruizer

I have been down this same rabbit hole, and it is very frustrating when you have 7 machines, and two of them (HPs) continued giving me the same errors that you experienced, and the other five PCs start services has the Boinc Manager GUI waiting on my desktop (setup using the commands found here <> , but I digress...).

I ended up aptitude purging as well, then with Krusader, I searched the entire filesystem for anything related to boinc and deleted. Rebooted, used the download instructions again, found on World Community Grid <>

Using the last command from the download guide of "boincmgr -d/var/lib/boinc-client", (no joy) and then "sudo boincmgr -d/var/lib/boinc-client" I again received the rpc password failure.

Using Krusader as root, I went into the "/etc/boinc-client/gui_rpc_auth and input my password (the one I use for Boinc for both Rosetta@home and World Community Grid) and saved.

Using Debian/Ubuntu/Linux Mint/KDE desktop distribution (don't ask, I just like it), I used the command <update-rc.d boinc-client defaults 98> in Konsole (Terminal) to start boinc-client at startup, and rebooted my computer.

The Boinc Manager was on the desktop waiting for me to add project(s) or using my account manager.

I then ran a status command of <service boinc-client status> on Konsole to make sure boinc was running and found this:
boinc-client.service - Berkeley Open Infrastructure Network Computing Client
Loaded: loaded (/lib/systemd/system/boinc-client.service; enabled; vendor preset: enabled)
Active: active (running) since Fri 2021-06-25 13:43:53 CDT; 38min ago
Docs: man:boinc(1)
Main PID: 1378 (boinc)
Tasks: 13 (limit: 17835)
Memory: 3.1G
CGroup: /system.slice/boinc-client.service
├─1378 /usr/bin/boinc
├─3071 ../../projects/>
├─4955 ../../projects/boinc.bakerlab.org_rosetta/rosetta_4.20_x86_64-pc-linux-gnu -run:pr>
├─4976 ../../projects/boinc.bakerlab.org_rosetta/rosetta_4.20_x86_64-pc-linux-gnu -run:pr>
└─4978 ../../projects/boinc.bakerlab.org_rosetta/rosetta_4.20_x86_64-pc-linux-gnu @foldit>

Jun 25 13:53:35 computer'sname boinc[1378]: 25-Jun-2021 13:53:35 [Rosetta@home] Started download of asy>
Jun 25 13:53:49 computer'sname boinc[1378]: 25-Jun-2021 13:53:49 [Rosetta@home] Finished download of as>
Jun 25 13:53:49 computer'sname boinc[1378]: 25-Jun-2021 13:53:49 [Rosetta@home] Started download of fol>
Jun 25 13:53:52 computer'sname boinc[1378]: 25-Jun-2021 13:53:52 [Rosetta@home] Finished download of fo>
Jun 25 14:01:59 computer'sname boinc[1378]: 25-Jun-2021 14:01:59 [Rosetta@home] Finished download of da>
Jun 25 14:02:22 computer'sname boinc[1378]: 25-Jun-2021 14:02:22 [Rosetta@home] Starting task pre_helic>
Jun 25 14:02:35 computer'sname boinc[1378]: 25-Jun-2021 14:02:35 [Rosetta@home] Starting task pre_helic>
Jun 25 14:02:35 computer'sname boinc[1378]: 25-Jun-2021 14:02:35 [---] Suspending computation - CPU is >
Jun 25 14:02:45 computer'sname boinc[1378]: 25-Jun-2021 14:02:45 [---] Resuming computation
Jun 25 14:02:58 computer'sname boinc[1378]: 25-Jun-2021 14:02:58 [Rosetta@home] Starting task foldit_20>
lines 1-24/24 (END)

Now remember, that the Boinc Manager started at system startup, so I decided to exit the Boinc Manager to determine if my Boinc application would start Boinc Manager. So, after closing Boinc Manager, I went to: start (application launcher)>Applications>System>Boinc and clicked on the icon which resulted in previous behavior of starting and then I right clicked on the Boinc Icon found at start>Applications>System>Boinc and chose edit application. I then went to the Applications Tab and entered the following:
Command: /var/lib/boinc-client
Work Path: boincmgr
and then clicked OK.

I checked the system monitor to insure that Boinc was not running and then again went to start>Applications>System>Boinc and clicked on the Application Icon for Boinc. The Boinc Manager came up and started with no issues.

This has been a long an arduous journey, fraught with downloading, uninstalling, purging, reinstalling, starting from boot, and finally hacking the command and work path for the Boinc Desktop Application in order to get things working.

From what I have learned from going through all of the searches, this is a common issue for some Distros and not for others. For instance, when I was running Linux Mint Cinnamon, Boinc just worked without any issues. I began having issues when I layered KDE on top of Linux Mint. Also, of note, I had updated my boinc-client/boinc manager to version 7.16.17(x64) wxWidgets version 3.0.4. I am still not sure why the rpc password issue began.

I found that if I did not purge all that was boinc before reinstalling, that nothing I did would work, and even after purging everything boinc, I still had to hack the Command and Work path of the boinc application to get the boinc client and boinc manager to start and behave properly.

This is definitely an issue that needs some attention. My experience has been purging, reinstalling, start the boinc-client at startup and then hack the Boinc Manager icon application properties. Has a lot of my issues been self inflicted? Probably. Is this going to work for everyone? Probably not.

Thanks to everyone for their input and feedback across this post. I wish you all good luck in finding the solution for all of those having similar issues.

Copyright © 2023 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.