Posts by bonze82

1) Message boards : GPUs : No GPU debian 10.2 non-root (Message 95745)
Posted 7 Feb 2020 by bonze82
Post:
I have a head scratcher for you guy's in trying to debug boinc to get the gpu to recognize i ran into an interesting find:
07-Feb-2020 00:02:35 [---] Data directory: /home/user
07-Feb-2020 00:02:35 [---] OpenCL: AMD/ATI GPU 0: AMD ARUBA (DRM 2.50.0 / 4.19.0-6-amd64, LLVM 7.0.1) (driver version 18.3.6, device version OpenCL 1.1 Mesa 18.3.6, 1022MB, 1022MB available, 50 GFLOPS peak)
07-Feb-2020 00:02:35 [---] OpenCL CPU: pthread-AMD A10-4600M APU with Radeon(tm) HD Graphics (OpenCL driver vendor: The pocl project, driver version 1.2, device version OpenCL 1.2 pocl HSTR: pthread-x86_64-pc-linux-gnu-bdver2)

applications > system > boinc shows this:
Fri 07 Feb 2020 12:41:37 AM CST | | Data directory: /var/lib/boinc-client
Fri 07 Feb 2020 12:41:37 AM CST | | OpenCL CPU: pthread-AMD A10-4600M APU with Radeon(tm) HD Graphics (OpenCL driver vendor: The pocl project, driver version 1.2, device version OpenCL 1.2 pocl HSTR: pthread-x86_64-pc-linux-gnu-bdver2)
Fri 07 Feb 2020 12:41:37 AM CST | | No usable GPUs found

To get the first log i logged into my user and brought up a terminal and typed su and the root password and typed in boincmgr. Why does going this route show gpu's with no projects yet the other route shows projects with no gpu's? Also I ran a cd to /var/lib/boinc-client and ran su > boincmgr and still no gpu's but projects were found. I usually use su - for root privileges for updates and various other admin stuff and su without the - for programs that need root rights with a gui.




Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.