Posts by Bryn Mawr

1) Message boards : Questions and problems : Service install. (Message 112740)
Posted 2 days ago by Bryn Mawr
I am considering deleting BOINC and re-installing as a service so it will start to run without the need to be logged in, e.g.. if the machine recovers from a power interruption while I am not here. I am assuming that the manager will operate in the same way as communication with the core should be exactly the same. In case... (!)... there are things I am missing, are there things I am missing?

I run mine as a service for exactly that reason, if I’m away from home for a couple of months and home has a power cut then I don’t want to loose a lot of crunching time.

But that’s Linux which installs as a service by default and I presume you’re Windows so …
2) Message boards : Questions and problems : Client downloads Tasks and runs not by Deadline Date Priority (Message 112614)
Posted 25 days ago by Bryn Mawr
Boinc Client (Windows 10) Version 7.22.2 (x64)

Hello - Is there a way to set the Client process tasks by Deadline date priority?

I note that when a fresh batch of Asteroids@Home are downloaded, that no matter the Deadline date of Einstein@Home is set at, the newly downloaded Asteroids@Home tasks start immediately and places the existing Einstein@Home tasks on 'hold'.

I'd rather set the client to process tasks by Deadline date in chronological order to ensure that each tasks are completed at or before their Deadline date.

Thanks in advance, David

Boinc has a complex mechanism to ensure that the maximum amount of work is completed without any of it missing the deadline.

This mechanism also ensures that your preferences as to the relative workload for each project is respected (in the long term).

What you are seeing is Boinc reacting to new work by saying “this project is behind in its workload so I’ll give it priority which I can do because the existing tasks are well within deadline”.

The less you touch this system the better it will run and no matter how much you try to tweak the system you will not get it to run in strict deadline date order.
3) Message boards : Questions and problems : NUCs and BOINC Projects (Message 112613)
Posted 25 days ago by Bryn Mawr

I was wondering if anyone has had any experience running the small-form-factor NUC computers with BOINC projects.

The reason I am considering NUCs is that I'm trying to reduce my energy usage. Therefore, my primary concern is not so much the performance. It is the heat. With my past power-hungry desktop machines with GPUs I was always able to run them at 100%, 24/7 because I installed cooling systems as necessary to keep temps within limits.

With off-the-shelf NUCs I'm not so sure that their stock cooling systems and designs would handle BOINC 100%/24/7. I'd hate to have to throttle them to keeps temps in line.

I'm looking at keeping the cost at below $400 per NUC and I will be needing at least two.

Any guidance? Thank you very much!

For somewhere around £400 / desktop I put together 2x24 thread machines that run flat out on all cores drawing less than 140 watts at the plug (OK, when the GPU is running a task the power draw can go up to 142 watts but I’ve never seen it above that).

I suspect that when you factor in the cooling in the small form factor and the efficiency cores in the intel chips, you would struggle to match that with an NUC.
4) Message boards : Projects : Anything and Everything to do with (WCG) World Community Grid (Message 112527)
Posted 14 Aug 2023 by Bryn Mawr
Tomorrow is Friday again. Let's see if my suspicions about how they handle sending out "new" tasks during weekends proves correct.
Did someone make a mistake? My job-cache was still full after a weekend away.

Nah, they restarted early.

Stopped mid-afternoon Saturday, restarted late afternoon Monday.
5) Message boards : Questions and problems : boinc-client crash (Message 112511)
Posted 8 Aug 2023 by Bryn Mawr
Linux Mint
Made a change in the preferences and the GUI stopped being responsive, failing to display anything. I tried to recover the change I made so I could report it, but the GUI would not respond and kept blinking. Nothing I tried, even reinstall after complete delete, made any difference. Did a manual delete of every file that had "boinc" in the name after another complete delete as I no longer have the will to continue.

Apoligies for all the project tasks that were incomplete and abandoned.

In the old days, it BOINC was very stable and the linux version did not have any serious problems. BOINC has come a long way and I am unable to cope with the problems. I am uncomfortable using the CLI because of the lack of knowledge of the commands and how they are supposed to perform. The "man" instructions are for the experts. Except for the simplest CLI tasks, the results are from not good to disasterous. Therefore I must give up on BOINC because a single change I made in the GUI crashed so bad there was no way to recover.

What was the change that you made? What version were you on? What OS version?

With that sort of information we can tell you how to recover.
6) Message boards : Questions and problems : Strange Behavior - Even amounts of "Work done" credit/Slow validation/Low GPU usage (Message 112402)
Posted 29 Jul 2023 by Bryn Mawr
The other thing that needs to be said is that GPU tasks require some CPU in order to run.

By setting CPU usage to zero you’re blocking GPU tasks as well.
7) Message boards : Questions and problems : Suspending Computation message meaning (Message 112357)
Posted 25 Jul 2023 by Bryn Mawr
Suspend when computer in use and Suspend GPU computing when computer is in use are both unchecked
Suspend when non-BOINC CPU usage is above 33.00% is checked

There are many background tasks that can take your computer over 33% usage which is what the message is telling you is happening.

As Boinc is ultra low priority so will give way to any work you want to do, it is safe to set that to 75% or even (as I do) 95%.
8) Message boards : Questions and problems : boinc can not connect ssl connection. http connection can connect (Message 112353)
Posted 24 Jul 2023 by Bryn Mawr
As further info.

WCG was due to go down today (25th) for 2 days to allow for data centre maintenance but it collapsed on the 21st and both the website and the servers have been down since then.

We can hope that it might rise again on the 27th but it might be next month before we see it.
9) Message boards : Projects : Anything and Everything to do with (WCG) World Community Grid (Message 112326)
Posted 21 Jul 2023 by Bryn Mawr
Website and server appear to have gone down earlier than expected.
10) Message boards : Questions and problems : Remove command button greyed out (Message 111871)
Posted 24 May 2023 by Bryn Mawr
I am using BOINC 7.20. In the BOINC Manager Advanced view, Projects I have two projects where the Remove button is unavailable: World Community Grid and Rosetta@home. These two projects were added automatically when I installed the BOINC software. I already had accounts for them but they were not manually added. I thought maybe that was significant.

Can someone please tell me if there is a way to fix the Remove button. It's an issue because I keep getting a message in Notices This project seems to have changed its URL. When convenient, remove the project, then add


The button is greyed out when you have joined the project through an account manager such as BAM or SU.

You can either remove the project from within the account manager or stop using the account manager from Boinc Manager > tools.
11) Message boards : Questions and problems : boinc-client reports wrong disk size (Message 111817)
Posted 16 May 2023 by Bryn Mawr

I have Ubuntu server 22.04 with boinc running as daemon, installed from git.

Boinc client reports 97.87GB disk size and 53.76GB free, but I have 2TB disk. So I am unable to get new tasks.
I have no idea why this is happening.
I don't know if it has anything to do with it, but I also installed cvmfs, go and singularity to run native ATLAS tasks.

Any help would be appreciated!

Kind regards,

user@user:/$ df -h -T gives:
Filesystem Type Size Used Avail Use% Mounted on
tmpfs tmpfs 51G 60M 51G 1% /run
/dev/mapper/ubuntu--vg-ubuntu--lv ext4 98G 40G 54G 43% /
tmpfs tmpfs 252G 0 252G 0% /dev/shm
tmpfs tmpfs 5.0M 0 5.0M 0% /run/lock
/dev/nvme0n1p2 ext4 2.0G 430M 1.4G 24% /boot
/dev/nvme0n1p1 vfat 1.1G 6.1M 1.1G 1% /boot/efi
tmpfs tmpfs 51G 8.0K 51G 1% /run/user/1000
cvmfs2 fuse 40G 1.8G 39G 5% /cvmfs/
cvmfs2 fuse 40G 1.8G 39G 5% /cvmfs/
cvmfs2 fuse 40G 1.8G 39G 5% /cvmfs/
cvmfs2 fuse 40G 1.8G 39G 5% /cvmfs/
cvmfs2 fuse 40G 1.8G 39G 5% /cvmfs/
cvmfs2 fuse 40G 1.8G 39G 5% /cvmfs/
cvmfs2 fuse 40G 1.8G 39G 5% /cvmfs/

user@user: sudo fdisk -l gives (shortened):
Disk /dev/loop0: 63.28 MiB, 66355200 bytes, 129600 sectors
Disk /dev/loop1: 63.34 MiB, 66412544 bytes, 129712 sectors
Disk /dev/loop2: 111.95 MiB, 117387264 bytes, 229272 sectors
Disk /dev/loop3: 49.84 MiB, 52260864 bytes, 102072 sectors
Disk /dev/loop4: 53.24 MiB, 55824384 bytes, 109032 sectors
Disk /dev/nvme0n1: 1.82 TiB, 2000398934016 bytes, 3907029168 sectors
Disk model: Samsung SSD 980 PRO 2TB
Disklabel type: gpt

Device Start End Sectors Size Type
/dev/nvme0n1p1 2048 2203647 2201600 1G EFI System
/dev/nvme0n1p2 2203648 6397951 4194304 2G Linux filesystem
/dev/nvme0n1p3 6397952 3907026943 3900628992 1.8T Linux filesystem

What parameters have you set in the disks tab of the computing options?

Boinc could be reporting the disk space it’s allowed to use rather than the total disk space installed.
12) Message boards : Projects : News on Project Outages (Message 111699)
Posted 1 May 2023 by Bryn Mawr
The WCG website has been down since 15:19 UTC with Error 500: java.lang.NullPointerException or System Error.
13) Message boards : Projects : World Community Grid needs help. can they get any here? (Message 111698)
Posted 1 May 2023 by Bryn Mawr
A couple of weeks ago WCG did make an announcement that the stats pages would be out of synch for some time as they were having to rebuild a lot of users & computers stats data from scratch.

IMHO, out of sync is not the same as missing devices. I have devices registered before 2019 that are crunching away but not listed. Users are posting their host ID's and the staff is forwarding the ID for manual entry into the database. That is NFG, and they need help.

They have said several times that they are working on the problem and that the manual entry is a temp workaround until the fix is in place. OK, it’s not ideal but it is as it is.
14) Message boards : Questions and problems : How to get Flatpak BOINC manager to let the client run when the manager window is closed? (Message 111601)
Posted 18 Apr 2023 by Bryn Mawr
After fighting with the repository (Kubuntu 22.04) version of BOINC Manager, I gave up and installed the flatpak version this past weekend. That's working just fine -- except I noticed that my CPU fan wasn't running at high level like it should when my Fx8350 is going full blast on all eight cores. A little poking, and I've determined that it runs fine per preferences when the BOINC Manager is open, but if I close the manager (either with the x button upper right, or with File, Close Window), computation stops.

I *think* this means the client service isn't running? The command that would tell the client to start on boot in the .deb install (sudo systemctl enable boinc-client) returns "Failed to enable unit: Unit file boinc-client.service does not exist." I presume this is because the flatpak doesn't offer a system service. There must be a flatpak command that I can put in my autostart so the client runs independent of the manager -- but I don't know what it is. flatpak run edu.berkeley.BOINC launches the manager (which starts the client), but the client ought to run in background whether the manager is running or not.

Or is this one of the ways in which the flatpak version isn't quite ready for prime time?

Vague memories (sorry but I’m not near my machines to check it out) that there is an option within BM to close the client when the manager closes.
15) Message boards : Projects : Anything and Everything to do with (WCG) World Community Grid (Message 111434)
Posted 27 Mar 2023 by Bryn Mawr
Post: will take about 74 hours.

Sounds good, but don't assume that is around the clock crunching. Spread over 8 hour days and no weekends or a standard 40 hour week, that could be 2 more weeks. So maybe 4/10?

That’s just the move - allow time for the resultant databases to be checked for integrity etc.

I’d be surprised if the move was not 24/7 but give them at least a day or so to verify before they restart.
16) Message boards : Projects : Anything and Everything to do with (WCG) World Community Grid (Message 111362)
Posted 20 Mar 2023 by Bryn Mawr
A further update from Cyclops :-),45101
17) Message boards : Questions and problems : Too many WUs were downloaded, all settings are ignored (Message 111344)
Posted 19 Mar 2023 by Bryn Mawr

I have heard that it is a bit tricky to persuade Ubuntu to work together with a newer version. But if it is needed, I would try.
Or is there an alternative for the <max_concurrent> to be used in the old BM ?

Instead of <max_concurrent> and specifying the app name you could try <project_max_concurrent> which appears to be more reliable.
18) Message boards : Projects : News on Project Outages (Message 111237)
Posted 9 Mar 2023 by Bryn Mawr
just restart/reconnect a storage system.

This can be completely different level of problem.
It's time to calm down and just wait for result.
Blaming them every day can't help this situation at all : )

Agreed - and this is not a problem to park at Krembil’s door, it’s totally the responsibility of the data centre.
19) Message boards : Projects : News on Project Outages (Message 111146)
Posted 1 Mar 2023 by Bryn Mawr
TN-Grid seems to be down again. Can't upload or download, getting message "Internet access OK - project servers may be temporarily down." Website also unavailable.

TN-Grid is working OK now.
20) Message boards : Questions and problems : Tasks completed not being credited to account (Message 111002)
Posted 4 Feb 2023 by Bryn Mawr
Recently I got a new android phone. I have installed Boinc 7.18.1. I am using android version 12. I have completed and uploaded about 14 tasks for world community over the last week . My phone even says "credit 768 on this device". When I go to world community website and login it says that I haven't competed any tasks in the last year. Just wondering why all the tasks I have completed and uploaded are not being credited to my world community grid account?

WCG is just coming out of a very troubled migration and the website is not fully working yet. If you go to results in My Contribution rather than History you will find your completed tasks.

Next 20

Copyright © 2023 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.