Posts by hadron

1) Message boards : The Lounge : These are no longer with us, may they have peace. (Message 113635)
Posted 16 Feb 2024 by hadron
Post:
Alexei Navalny, Russian opposition leader, dead at 47. No prize for guessing who's responsible.
2) Message boards : The Lounge : These are no longer with us, may they have peace. (Message 113436)
Posted 23 Jan 2024 by hadron
Post:
Norman Jewison, 97, Canadian film director and producer. Credits include: In the Heat of the Night (director), Jesus Christ Superstar and Fiddler on the Roof (director and producer).
3) Message boards : Projects : News on Project Outages (Message 113394)
Posted 18 Jan 2024 by hadron
Post:
It is almost as if Dr Millea doesn't care about the people who are crunching his data for him, so long as we continue to crunch it.
There are of course other possible explanations that projects heavily dependent on one person can suffer from such as illness. or worse. Just as many people do not prepare their personal lives for their death/illness, many especially if they do not expect problems do not prepare their professional lives for such events.

Quite possible; however, this situation has been ongoing for the past 2 years, without one bit of real news from anyone.
Some time ago, someone posted about contacting Saul Perlmutter at the BCCP. Did anyone actually do that? If so, nothing was reported here. I never contacted the Poincare institute for only one reason: in the end, all they really could do would be to pull the plug on the server.
4) Message boards : Projects : News on Project Outages (Message 113387)
Posted 18 Jan 2024 by hadron
Post:
Cosmology@home is down for at least 2 weeks now. Can't access website to find what is wrong.
Any1 knows anything?

Cosmology has been in its death throes for as long as the past 2 years. Some time late last year, it became impossible for anyone to log in (SSL error). As of just now, the web server is not accepting connections.
Attempts to contact the site owner, Dr Marius Millea, have been unsuccessful. It is almost as if Dr Millea doesn't care about the people who are crunching his data for him, so long as we continue to crunch it.
I found out that the site is running off a system at the Poincare Institute, Sorbonne University, in Paris. I was going to contact them to inform them of the situation, but instead I decided that I had had enough, and simply removed Cosmology@home from my boinc setup.
As far as I am concerned, C@H is dead -- and it has also been removed from the list of available boinc projects for the reasons stated above.
So my recommendation to you (and to anyone else) is that you just give up on the project, and go do some work for people who will actually appreciate what we are doing. There are plenty of worthwhile projects available, so find something that interests you and go crunching :)
5) Message boards : The Lounge : These are no longer with us, may they have peace. (Message 113353)
Posted 8 Jan 2024 by hadron
Post:
Mário Zagallo age 92, Brazilian football legend, the first of only three men to win the FIFA Men's World Cup as both player and manager (the other two are Germany's Franz Beckenbauer and France's Didier Deschamps). The only person to have done so more than twice.
6) Message boards : The Lounge : These are no longer with us, may they have peace. (Message 113221)
Posted 3 Dec 2023 by hadron
Post:
Chad Allan 80 - founding member of the Guess Who
7) Message boards : The Lounge : Science and Technology in the News (Message 112648)
Posted 7 Sep 2023 by hadron
Post:
Scientists in China have succeeded in teleporting information between photons further than ever before. They transported quantum information over a free space distance of 16 km (10 miles), much further than the few hundred meters previously achieved, which brings us closer to transmitting information over long distances without the need for a traditional signal.

All this means that it is possible to "collapse" an entangled quantum state into two un-entangled states (be they photons or whatever) over a much greater distance than before.
However, before you can do that, you must first arrange for that pair of entangled photons to get to the places where they will be observed (measured).
Photons will still need to travel causally (ie. at the speed of light) to reach those two points, so in actuality, it is not possible to transmit information without the need of a "traditional" signal.
8) Message boards : Questions and problems : How does one kill the BOINC Mgr and associated work processes in Ubuntu Linux? (Message 112483)
Posted 6 Aug 2023 by hadron
Post:
You can thank the distro devs for that. Boinc runs as a service and can't be killed by the user. With your version the only way to stop the client is to invoke superuser.

sudo systemctl stop boinc-client


I run an older client that still has the ability to stop the client and all processes through the Manager interface.

To restart the client if you aren't going to reboot use this.

sudo systemctl start boinc-client

You can indeed shut down the boinc-client service from the Manager -- you have to be a member of group boinc to use it, so that right is yours.
It seems the only thing you cannot do is restart the client, at least not that I have found.

Maybe Ubuntu is somehow different, it certainly wouldn't surprise me.
9) Message boards : Questions and problems : Systemd timeout stopping boinc-client (Message 112482)
Posted 6 Aug 2023 by hadron
Post:
If he's using systemd, the old logs will be in the system journal, not a text file.

Boinc still logs to stdoutdae.txt
10) Message boards : Questions and problems : project app causing client to crash. (Message 112481)
Posted 6 Aug 2023 by hadron
Post:
To me this sounds more like a CPDN error than a Boinc error. Perhaps you should ask them?
11) Message boards : Questions and problems : On Xubuntu 22.04, i cannot join a BOINC project (Message 111497)
Posted 3 Apr 2023 by hadron
Post:
I installed BOINC from the ubuntu repos.

When i want to start form the menu i get an error window:

"Impossible d'exécuter boinc manager
le changement de répertoire /var/lib/boinc-client a échoué (permission non accodrée)"

That suggest a permissions problem.

Ok, i managed to changes the permission of the folder. Now i get a boinc manager window that tells me:

"Boinc manager (pre release) ne peut pas démarrer un client BOINC. Merci d'exécuter le client et de réessayer."

Ok, i searched the net and found a workaround: i type in a terminal:

sudo systemctl start boinc-client

Before relaunching the boinc manager. And it finally works; With the GPU enabled. I leave this here in case someone would be in trouble like i was. But what a shoddy work by canonical !


This has nothing to do with Canonical. Systemd is an init process which has replaced all the previous Linux init processes, because it is much cleaner and solves many problems most, if not all, of those previous methods had. It has been the standard init process on all major Linux distributions since 2015.
Systemd is the first process started when you boot, the last to stop when you shut down; it is responsible for starting all the user space processes needed to run a clean system. As far as boinc is concerned, you are right; installing boinc from a repo creates a user "boinc" and a group, also called boinc. The boinc-client script tells systemd to run the client as user boinc.
If you want boinc to start whenever you boot your system, you also need to run the following:
sudo systemctl enable boinc-client

If you want to use the boincmanager gui, you will also need to add yourself to group "boinc":
usermod -a -G boinc <your_user_name>
12) Message boards : Projects : certificate problem at asteroids at home (Message 111285)
Posted 14 Mar 2023 by hadron
Post:
It's all good now.
https://asteroidsathome.net/boinc/


Took 6 hours for all my completed tasks to finally upload. I had a huge queue when the cert expired.
Problem was exacerbated by the WGC tasks that cannot upload yet. BOINC tried and failed each upload of WCG before going on to Asteroids.
I should have requested a restart of the transfers for just Asteroids.

I suspect all my WCG have passed their deadline.

The website is back up now.
WCG already announced this on Twitter on March 3:

"Additionally, the deadline of all existing WUs that are partially done will be extended and accepted once the hardware change is done."
https://twitter.com/WCGrid/status/1631819264809226241?cxt=HHwWgsC-ibi-saUtAAAA
Deadlines haven't yet been extended, but from the most recent tweet, it looks like they're still working on recovering all the databases.
13) Message boards : Questions and problems : gui_rpc_auth.cfg exists but can't be read. Check the File permissions. (Message 110252)
Posted 27 Oct 2022 by hadron
Post:
I've found a new (?) page, which may assist readers and save them wading through this whole thread.

Accessing BOINC on Linux

The final suggestion on that page is

exec su $USER
That only works if you want to launch BOINC Manager from the command line in terminal. If you want to use a graphical launch icon on your desktop, or a menu item created by your distribution, you'll need to reboot the machine.


That command should be sufficient to allow $USER to use the manager without rebooting or logging out and back in. In openSUSE 15.4, I added my own account to group boinc from YaST, the SUSE sysadmin tool, and was immediately able to use the manager. Presumably, every other distro's sysadmin tool should give the same result.
14) Message boards : Questions and problems : gui_rpc_auth.cfg exists but can't be read. Check the File permissions. (Message 110251)
Posted 27 Oct 2022 by hadron
Post:
The Linux tools for ensuring that the Manager can read - and thus supply - the requisite password from gui_rpc_auth.cfg are woefully inadequate.
No, the Manager should not need, and not be able, to read that file at all. The user has to provide the password to prove they're authorised to control the Client. To make that work the password has to be secret, enforcing a password and then allowing everybody to look it up is just absurd. You could add authorised users to the boinc group as you suggested and then allow only those to read the password file. In fact that's what I do, but I'm sure that's still not how it was intended to work. The Manager has the ability to read the password from a file but I don't think that was meant to read the Client's password file but one provided by the user. Correct me if I'm wrong. For me the whole concept of someone else reading the Client's private file is only added by the Linux packagers and it's another case where the convenience vs security decision goes in the wrong direction.


By default, no ordinary user is a member of group boinc; they must be added to that group at administrator level. If you are a member of group boinc, then it should be rather obvious that you are authorized to use boinc -- including the manager. Permissions 0640 are correct. Every user cannot then read the password file, because they are not members of group boinc.
15) Message boards : Questions and problems : Log to file other than /var/log/messages (Message 110228)
Posted 25 Oct 2022 by hadron
Post:
I'm running a large server with 192 cores. Consequently, /var/log/messages gets cluttered with messages of started and finished tasks.

Is there a setting somewhere which would use a different file for this output, or suppress it altogether?


What logging facility does that server use? If it is rsyslog (most likely), as root create /etc/rsyskog.d/boinc.frule as follows:

if ($programname == 'boinc') \
then {
-/var/log/boinc-client.log
stop
}

If you wish to suppress boinc logging (not really recommended, unless you are certain you will never have a problem), then simply omit the filename:

if ($programname == 'boinc') \
then {
stop
}

In either instance, it will be necessary to reload the rsyslog service: systemctl reload rsyslog.service
16) Message boards : Projects : World Community Grid has announced an extended outage from Feb 14 to April 22, 2022 (Message 110039)
Posted 7 Oct 2022 by hadron
Post:
I've just turned WCG off for now -- no new tasks, and it will remain so until I see something positive from the rest of you.
Meanwhile, if anyone's interested, Rosetta is back with a massive dump of new tasks, and LHC has started up its 3rd run, so there is a lot of work there too.
17) Message boards : Projects : World Community Grid has announced an extended outage from Feb 14 to April 22, 2022 (Message 109968)
Posted 3 Oct 2022 by hadron
Post:
I tried opening the website in an incognito window. It opened i-n-c-r-e-d-i-b-l-y slowly, especially the photographs - but it looked as if it was all there.

Then, I clicked for the latest news. And the latest news is ...

{"errors":[{"error":"An unexpected error occurred: Could not open Hibernate Session for transaction; nested exception is org.hibernate.exception.GenericJDBCException: Unable to acquire JDBC Connection"}]}

I get the same. Errors nearly everywhere except a very limited number of pages.
One place that does seem to work is the "Contact Us" page. I just sent them a note telling them they'd better let us know what is going on, or they'd start shedding volunteers fast. Now to sit back and see if anyone bothers to reply. Here's the URL, in case anyone else wishes to join in: https://www.worldcommunitygrid.org/viewContactUs.do
18) Message boards : Questions and problems : Unable to launch BOINC CLIENT/MANAGER since upgrade (Message 109950)
Posted 2 Oct 2022 by hadron
Post:
But I still haven't got a clue why other people are having so much trouble. The keys seem to be:

  • Learn the systemctl commands for systemd (stop, start, enable, disable)
  • Add your user account to the boinc group
  • reboot


Glad to see things have returned to what they should be for you. Hopefully it will stay that way from now on.

I would make a couple of small changes to your list items:
    Learn the systemctl commands
    Add your user account to group boinc, and if using VirtualBox add user boinc to group vbox-users
    Log out/log in to complete your user's addition to group boinc (in openSUSE at least, this does not appear to be necessary if you use YaST's user manager to do this task -- try it with your distro's equivalent to see if it works for you)
    Instead of rebooting, simply enable boinc-client service: sudo systemctl enable boinc-client
    And now start boinc-client: sudo systemctl start boinc-client

19) Message boards : Questions and problems : BOINC on Ubuntu 22.04.1 LTS (Message 109903)
Posted 28 Sep 2022 by hadron
Post:
I've installed BOINC, but I get an error message when starting the BOINC manager:
BOINC Manager (Pre-release) - Daemon Start Failed
BOINC Manager (Pre-release) is not able to start a BOINC client. Please run the client and try again.

How does one run the client?

BOINC Version: 7.18.1 (x64)
wxWidgets Version: 3.0.5

What is the result of running "sudo systemctl status boinc-client"?
If it is disabled, you must first enable it: sudo systemctl enable boinc-client

When the package is installed, it will have created a user and user group, both named boinc. To be able to use the Boinc Manager, you must add your own user to group boinc. I don't know how to do that in Ubuntu.
If you have installed VirtualBox so you can run VMs inside Boinc, that package should have created a user group named something like vboxusers (that is what it is named in openSUSE). You must add user boinc to that group, or the client will not be allowed to run any VMs.

Finally, you should be ready to go: sudo systemctrl start boinc-client.

If things are set up in any way similar to what they are in openSUSE, that should be the last time you ever need to start the boinc client this way. Henceforth, it should be started automatically whenever the systemd target multi.user (aka runlevel 5) is reached.
20) Message boards : Questions and problems : Unable to launch BOINC CLIENT/MANAGER since upgrade (Message 109902)
Posted 28 Sep 2022 by hadron
Post:
Great. I see that Mint have released an upgrade tool for converting v20.3 installations like mine to v21. I was planning to reduce my computing load from 01 October anyway (when my electricity supplier increases their prices yet again), so I'll take a crunching timeout and try it out.

My working hypothesis for the problem you encountered rests on one simple fact: BOINC v7.18.1 was never released for the desktop operating systems Apple, Linux, Windows. It was only ever released for Android. I suspect the Ubuntu repo maintainers saw the Android release notice, and pulled a broken source tree. Now I just need some help in proving it, and examples like this help me down that route.

If all that is true, then ask the folks at openSUSE what they did to make it work -- because 7.18.1 does work here, quite well.
I am having one problem -- I cannot access the VM Console in the Boinc manager, and I have tried just about everything I can think of to make it work.

boinc-client runs as a systemd service when target multi.user (aka runlevel 5) is reached (it is not enabled by default, so must first be enabled: su - systemd enable boinc-client). When boinc is installed, it creates a user and user group, both named "boinc". The client runs as user boinc, and to enable the manager to communicate with it, it is necessary to add yourself to group boinc. Additionally, if VirtualBox is installed, the boinc user must be added to group vboxusers (created when VBox is installed) -- otherwise, boinc-client cannot create a virtual machine.
All this works just fine, except as noted above.


Next 20

Copyright © 2024 University of California.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.