Bug in newer server code for computer preferences ?????

Message boards : Questions and problems : Bug in newer server code for computer preferences ?????
Message board moderation

To post messages, you must log in.

AuthorMessage
David Ball

Send message
Joined: 2 Dec 06
Posts: 69
United States
Message 47333 - Posted: 17 Jan 2013, 4:53:02 UTC

Machine info:
Multiple q6600 quads running Vista 32 and BOINC 7.0.28 with "home" compute preferences.
One C2D E6420 (basically conroe 6400 but with all 4 megs of L2 cache) running Vista 32 and BOINC 7.0.28 with "work" compute preferences.

I normally maintain my "Computing Preferences" in my account on the SIMAP website. I keep one set of "default" preferences which runs on the quads and a set of "work" preferences which run on the C2D which has a nVidia 9600 GT graphics card.

Recently, I've joined some new projects and I happened to edit my "computing preferences on one of those projects (fightingmalaria@home IIRC). I just made a simple change to one of the (default IIRC) preferences like time slice or how much work to fetch. It appeared to work so I didn't really look through the 2 sets of preferences in detail on the project website.

Once I had gone through my 3 crunchers and had them contact that project to get the updated "computing preferences", I noticed that something seemed strange. It appears that the project had randomly combined values from the default and work preferences and had sent "computing preferences" to my machines that only had the merged "default" computing preferences and no "work" computing preferences.

They had already been propagated to other projects so I ended up having to go back to SIMAP, fix the merged default settings and re-create the work settings. Again, only the "Computing preferences" were scrambled, afaik.

I wrote it off to a one time glitch but it has happened a couple of more times, once on fightingmalaria and once on another recently joined project. I don't recall what the other project was but it was either a new project or LHC, which I re-joined now that they have work again.

As long as I change the preferences at SIMAP or Seti (when Seti is up), I never have a problem.

Here's the image with my stats so you can see what projects I am attached to.



David Ball
ID: 47333 · Report as offensive
skgiven
Avatar

Send message
Joined: 19 Aug 08
Posts: 87
United Kingdom
Message 47350 - Posted: 17 Jan 2013, 14:54:16 UTC - in response to Message 47333.  

I think there are some differences between server versions, and IIRC some projects allow you to set one of the non-default/primary Preferences as the Default Preferences. So, for example on one project Work could be the Default project.
ID: 47350 · Report as offensive

Message boards : Questions and problems : Bug in newer server code for computer preferences ?????

Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.