using git fails to download boinc code

Message boards : Questions and problems : using git fails to download boinc code
Message board moderation

To post messages, you must log in.


Send message
Joined: 3 Dec 12
Posts: 15
United States
Message 46910 - Posted: 25 Dec 2012, 0:54:22 UTC

I need to compile boinc on a centos 6 platform and all my attempts at using "git" have failed. It seems to run and start to build the ~.git directory with files and directories then it errors out with:

command --> git clone

response follows:

Cloning into 'boinc'...
error: Failed connect to; Connection timed out (curl_result = 7, http_code = 0, sha1 = 48a99ce70a6cadc52f5149a3d71a54c8eeac911c)
error: Unable to find 251bc57d23b1cb529a897e5d4c8e1cb61f614244 under
Cannot obtain needed commit 251bc57d23b1cb529a897e5d4c8e1cb61f614244
while processing commit 4f34508bce208f69e146bebc0d14285fb2d45e44.
error: Fetch failed.

does this seem like a server error or a network error on my end? I have not had other issues with downloading rpms or other large files.

Does a boinc tar file exist somewhere or is git my only option.

I am really feeling "boinc'd" out at the moment :>)

ID: 46910 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert

Send message
Joined: 29 Aug 05
Posts: 15461
Message 46911 - Posted: 25 Dec 2012, 1:42:45 UTC - in response to Message 46910.  

I'll forward your plight to the Captain. :-)
ID: 46911 · Report as offensive

Send message
Joined: 3 Dec 12
Posts: 15
United States
Message 46912 - Posted: 25 Dec 2012, 2:27:58 UTC - in response to Message 46911.  


Still having the problem. I did open the "git" port on a firewall but it did not make a difference.

This all started with installing nvidia drivers. Could not get them to install in FC17 so I tried Ubuntu. Again "no joy". Tried Centos 6 and voilla!!! Then I went looking for boinc for centos. Thought the best solution would be to download code and compile, but ....
ID: 46912 · Report as offensive

Send message
Joined: 5 Dec 12
Posts: 42
Message 46926 - Posted: 27 Dec 2012, 18:03:31 UTC - in response to Message 46912.  

You're going about this the wrong way.

Going from an established, mature distro like Fedora or Ubuntu to a a less established and less mature distro only invites problems. Mature, established distros simply have way more people watching, testing and fixing than do distros like centOS. I know for sure centOs users are going to leap to the defense of their pet and say how wellit works for them but hey.... the point is the chances it's going to work well for YOU. You cannot beat having more eyes watching and more hands fixing unless the distro is so plugged up with politics and fighting the whole thing comes so a standstill as seems to be the case with openSuSe but Fedora and Ubuntu don't seem to have that problem, IMHO.

I have never had any problem with nvidia drivers on Fedora or Ubuntu. The folks at nvidia know Ubuntu is the most widely used distro so they know their product better install there hassle free. Fedora is very popular too and the same argument applies. CentOS isn't so popular so it gets less attention. Glad it worked for you but you're better off getting the nvidia driver to install on Ubuntu than jumping to centOS because you will have a difficult time getting BOINC code to compile on any platform let alone an obscure platform like centOS. Again, in about 10 minutes you'll see posts here claiming how easy it is but they won't tell you how to do it and if they do you'll likely find following their suggestions to the letter will not give you what you want which is BOINC binaries. Been there a thousand times and it's not the way you want to go. Git is just the beginning of your woes. If you get around git be prepared for a dozen more problems such as missing libraries you cannot find for love nor money and if you do they won't install on your distro anyway. Catch 22? No, catch1022 but don't take my word for it, nooooo, jump all the hoops yourself, you owe it to yourself to experience the frustration.

Reinstall Ubuntu and do whatever you have to do to get the nvidia drivers to install. A million other users have done it and you can too. Don't make the stupid mistake of thinking that just because you have the highest release number that that means it has the best chance of working. NO!!! Go to the forums where the people who have it working hang out (the gpugrid forums) and read, it's all there, all you have to do is read and think. Or you can just beg and grovel until they tell you what you're doing wrong.

The reason you want to stick with Ubuntu at any cost if you're running BOINC is because the BOINC installers pretty much guarantee the Berkeley installer (find out what the Berkeley installer is if you don't what it is at this point) will work on the current Ubuntu LTS. Find out what Ubuntu LTS is if you don't know exactly what LTS means. If you don't like all that convenience then the alternative, the BOINC package from Ubuntu repositories, works very well too although in your case you don't want to go that route because the resulting daemon install won't work with the nvidia drivers unless you jump a number of additional hoops. That's the easy recipe: Ubuntu, Berkeley installer, nvidia. Or do it the hard way.

"Windows" -- an American English word, meaning "A real operating system is too hard for me."
ID: 46926 · Report as offensive

Message boards : Questions and problems : using git fails to download boinc code

Copyright © 2024 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.