Compiling BOINC from source code (5.10 >> 6.1)

Message boards : API : Compiling BOINC from source code (5.10 >> 6.1)
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 15492
Netherlands
Message 12269 - Posted: 1 Sep 2007, 12:49:36 UTC
Last modified: 1 Sep 2007, 12:50:26 UTC

A warning for people that download and compile their own BOINC versions. At this moment, when you download BOINC code from /Trunk/ it will download the new 6.1.0 source code.

This code depends on the scientific module and graphics module to be separate modules. Present science applications with the graphics/screen saver code built in will no longer show their graphics, unless you separate them. See Roadmap to BOINC 6.0 for that information.

If you want to use updated 5.10 code, be sure to your source code download from /branches/boinc_core_release_5_10

So instead of using this command;
svn co http://boinc.berkeley.edu/svn/trunk/boinc

use this command;
svn co http://boinc.berkeley.edu/svn/branches/boinc_core_release_5_10

If you have any problems still, don't hesitate to ask.
ID: 12269 · Report as offensive
Nicolas

Send message
Joined: 19 Jan 07
Posts: 1179
Argentina
Message 12515 - Posted: 15 Sep 2007, 16:43:07 UTC

Always use trunk for the API or the server code.
Always use latest stable branch for the client.
ID: 12515 · Report as offensive
Eric Myers
Avatar

Send message
Joined: 12 Feb 06
Posts: 232
United States
Message 12536 - Posted: 17 Sep 2007, 2:18:28 UTC - in response to Message 12515.  

Always use trunk for the API or the server code.
Always use latest stable branch for the client.


Neither one of them builds, at the moment (on Linux, at least).

-- Eric Myers

"Education is not the filling of a pail, but the lighting of a fire." -- William Butler Yeats
ID: 12536 · Report as offensive
Eric Myers
Avatar

Send message
Joined: 12 Feb 06
Posts: 232
United States
Message 14266 - Posted: 12 Dec 2007, 14:39:30 UTC - in response to Message 12515.  

Always use trunk for the API or the server code.
Always use latest stable branch for the client.


I disagree with this plan. First of all, it doesn't say what to do if you are building apps.

If you are building apps, you need to use the stable 5.10 branch (right now).
That's the same branch being used to build the client.

So I would hope that the server code would also work on that branch.
I'll be testing it out on Pirates@Home in a bit.


-- Eric Myers

"Education is not the filling of a pail, but the lighting of a fire." -- William Butler Yeats
ID: 14266 · Report as offensive
Pepo
Avatar

Send message
Joined: 3 Apr 06
Posts: 547
Slovakia
Message 19932 - Posted: 3 Sep 2008, 12:37:29 UTC

Starting with BOINC 6.3.9 tag, MS Visual Studio 2003 solution files were deprecated for some/most of the BOINC subprojects. (I think they were not more completely updated and checked for some time already, but the necessary changes were minimal - 2-3 missing files.)

Peter
ID: 19932 · Report as offensive
Nensi

Send message
Joined: 22 Jun 10
Posts: 2
United States
Message 33484 - Posted: 22 Jun 2010, 5:41:31 UTC - in response to Message 19932.  

Hi friends, I am first time here and really found ti good by all means, Infact the topic is good to read and and sending this page to my other firends because they are always asking me for the good resources to read out
ID: 33484 · Report as offensive
Nensi

Send message
Joined: 22 Jun 10
Posts: 2
United States
Message 33485 - Posted: 22 Jun 2010, 5:42:27 UTC - in response to Message 19932.  

Keep it up dude
Nensi
ID: 33485 · Report as offensive

Message boards : API : Compiling BOINC from source code (5.10 >> 6.1)

Copyright © 2024 University of California.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.