Will there be a viable boinc for Ubuntu 22.04 LTS soon

Message boards : Questions and problems : Will there be a viable boinc for Ubuntu 22.04 LTS soon
Message board moderation

To post messages, you must log in.

AuthorMessage
David Pickett

Send message
Joined: 1 May 14
Posts: 22
United States
Message 113441 - Posted: 25 Jan 2024, 3:35:44 UTC

The boinc for Ubuntu 22.04 LTS went south a few weeks back, and I have been waiting patiently for an update. I had been running the flatpak install. Both flatpak and apt install version fail, differently. Flatpak fails to link, and apt install gets illegal instruction.
ID: 113441 · Report as offensive     Reply Quote
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2526
United Kingdom
Message 113442 - Posted: 25 Jan 2024, 5:53:40 UTC - in response to Message 113441.  

The boinc for Ubuntu 22.04 LTS went south a few weeks back, and I have been waiting patiently for an update. I had been running the flatpak install. Both flatpak and apt install version fail, differently. Flatpak fails to link, and apt install gets illegal instruction.


Can you be a bit more explicit about what has happened when it, "went South" If the problem were affecting all with 22.04LTS I would expect to see several posts about this by now.
ID: 113442 · Report as offensive     Reply Quote
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2526
United Kingdom
Message 113443 - Posted: 25 Jan 2024, 10:25:54 UTC - in response to Message 113442.  

Should have said, specific.
ID: 113443 · Report as offensive     Reply Quote
David Pickett

Send message
Joined: 1 May 14
Posts: 22
United States
Message 113445 - Posted: 25 Jan 2024, 17:20:01 UTC - in response to Message 113442.  

I posted details on boinc users but I guess the developers do not read that. I would expect both to run without special procedures, as the online doc and past experience does not imply otherwise:

apt version:

dgp@dgp-p6803w:~
$ sudo apt install boinc-client boinc-manager
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Suggested packages:
boinc-client-opencl boinc-client-nvidia-cuda libgl1-mesa-glx
The following NEW packages will be installed:
boinc-client boinc-manager
0 upgraded, 2 newly installed, 0 to remove and 5 not upgraded.
Need to get 2,136 kB of archives.
After this operation, 7,691 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu jammy/universe amd64 boinc-client amd64 7.18.1+dfsg-4 [508 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu jammy/universe amd64 boinc-manager amd64 7.18.1+dfsg-4 [1,628 kB]
Fetched 2,136 kB in 0s (4,616 kB/s)
Preconfiguring packages ...
Selecting previously unselected package boinc-client.
(Reading database ... 233268 files and directories currently installed.)
Preparing to unpack .../boinc-client_7.18.1+dfsg-4_amd64.deb ...
Unpacking boinc-client (7.18.1+dfsg-4) ...
Selecting previously unselected package boinc-manager.
Preparing to unpack .../boinc-manager_7.18.1+dfsg-4_amd64.deb ...
Unpacking boinc-manager (7.18.1+dfsg-4) ...
Setting up boinc-client (7.18.1+dfsg-4) ...
Setting up boinc-manager (7.18.1+dfsg-4) ...
Processing triggers for desktop-file-utils (0.26-1ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu3) ...
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for mailcap (3.70+nmu1ubuntu1) ...
dgp@dgp-p6803w:~
$ gdb boincmgr
GNU gdb (Ubuntu 12.1-0ubuntu1~22.04) 12.1
Copyright (C) 2022 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from boincmgr...
(No debugging symbols found in boincmgr)
(gdb) run
Starting program: /usr/bin/boincmgr
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".

Program received signal SIGILL, Illegal instruction.
0x000055555565455d in ?? ()
(gdb) where
#0 0x000055555565455d in ?? ()
#1 0x000055555565e053 in ?? ()
#2 0x00007ffff5e29ebb in call_init (env=<optimized out>, argv=0x7fffffffdfe8,
argc=1) at ../csu/libc-start.c:145
#3 __libc_start_main_impl (main=0x555555654120, argc=1, argv=0x7fffffffdfe8,
init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>,
stack_end=0x7fffffffdfd8) at ../csu/libc-start.c:379
#4 0x0000555555661745 in ?? ()
(gdb) q
A debugging session is active.

Inferior 1 [process 217611] will be killed.

Quit anyway? (y or n) y
dgp@dgp-p6803w:~
$

flatpak:

dgp@dgp-p6803w:~
$ flatpak install edu.berkeley.BOINC
Looking for matches…

edu.berkeley.BOINC permissions:
ipc network pulseaudio x11 dri



ID Branch Op Remote Download
1. [✓] edu.berkeley.BOINC.Locale stable i flathub 4.3 kB / 899.7 kB
2. [✓] edu.berkeley.BOINC stable i flathub 19.5 MB / 16.4 MB

Installation complete.
dgp@dgp-p6803w:~
$ which boincmgr
dgp@dgp-p6803w:~
$ find / -name boincmgr -ls 2>/dev/null
919574 4204 -rwxr-xr-x 2 root root 4303456 Jan 25 12:09 /var/lib/flatpak/app/edu.berkeley.BOINC/x86_64/stable/5fe1aee3e6ac01474678310b04489228765899a38b899b367235650a8cae497e/files/bin/boincmgr
79432284 4 drwx------ 3 dgp dgp 4096 Oct 15 2021 /mnt/37e7c8a7-a11a-41b9-8b5e-107f726a5475/Arc2/dgp2022/dgp/.var/app/edu.berkeley.BOINC/cache/boincmgr
75628724 4 drwx------ 3 dgp dgp 4096 Oct 15 2021 /mnt/37e7c8a7-a11a-41b9-8b5e-107f726a5475/edu.berkeley.BOINC/cache/boincmgr
dgp@dgp-p6803w:~
$ /var/lib/flatpak/app/edu.berkeley.BOINC/x86_64/stable/5fe1aee3e6ac01474678310b04489228765899a38b899b367235650a8cae497e/files/bin/boincmgr
/var/lib/flatpak/app/edu.berkeley.BOINC/x86_64/stable/5fe1aee3e6ac01474678310b04489228765899a38b899b367235650a8cae497e/files/bin/boincmgr: error while loading shared libraries: libwx_gtk3u_html-3.2.so.0: cannot open shared object file: No such file or directory
dgp@dgp-p6803w:~
$ find / -name 'libwx_gtk3u_html-3.2.so*' -ls 2>/dev/null
1048999 0 lrwxrwxrwx 1 root root 25 Jan 25 12:19 /var/lib/flatpak/app/edu.berkeley.BOINC/x86_64/stable/5fe1aee3e6ac01474678310b04489228765899a38b899b367235650a8cae497e/files/lib/libwx_gtk3u_html-3.2.so -> libwx_gtk3u_html-3.2.so.0
1049002 0 lrwxrwxrwx 1 root root 29 Jan 25 12:19 /var/lib/flatpak/app/edu.berkeley.BOINC/x86_64/stable/5fe1aee3e6ac01474678310b04489228765899a38b899b367235650a8cae497e/files/lib/libwx_gtk3u_html-3.2.so.0 -> libwx_gtk3u_html-3.2.so.0.2.1
918364 1024 -rwxr-xr-x 2 root root 1046736 Jan 25 12:18 /var/lib/flatpak/app/edu.berkeley.BOINC/x86_64/stable/5fe1aee3e6ac01474678310b04489228765899a38b899b367235650a8cae497e/files/lib/libwx_gtk3u_html-3.2.so.0.2.1
dgp@dgp-p6803w:~
$
ID: 113445 · Report as offensive     Reply Quote
David Pickett

Send message
Joined: 1 May 14
Posts: 22
United States
Message 113447 - Posted: 25 Jan 2024, 18:54:08 UTC

I did some digging inside files in the flatpak dist and discovered the right launch for boincmgr flatpak is:

/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=boincmgr edu.berkeley.BOINC

But it balked at the fact that I moved the files off my ssd and put a symlink to a HD dir in their place. I seem to have broken something by moving the files to my hard disk from my ssd. When I moved the files back, it launched and found my old projects. So apparently moving the files to a different disk is a bit more involved. It would be nice if the code was not symlink adverse. Maybe I have to move the parent dir and all the flatpak app subdirs.

Flatpak run is so complicated. You;d think it would put a viable script somewhere normal. Was it a failed install? Did I need to reboot after? Not seeing any online help to discover how to more properly install and run flatpak boincmgr/boinc.

Not sure why the other install does not work.
ID: 113447 · Report as offensive     Reply Quote
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2526
United Kingdom
Message 113448 - Posted: 25 Jan 2024, 20:56:43 UTC

I have stopped using both deb and flatpack myself, opting to compile from source but tracking down the packages containing the required libraries can be time consuming.
ID: 113448 · Report as offensive     Reply Quote
David Pickett

Send message
Joined: 1 May 14
Posts: 22
United States
Message 113457 - Posted: 26 Jan 2024, 21:00:40 UTC - in response to Message 113448.  

Maybe if I delved into the souce I could fix the hatred of symlink problem! I have been there in open source land before!
ID: 113457 · Report as offensive     Reply Quote
vorix

Send message
Joined: 22 Oct 23
Posts: 4
Austria
Message 113524 - Posted: 31 Jan 2024, 9:16:07 UTC

@David Pickett

I recommend you install BOINC 7.20.5 from this PPA: https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/boinc

I'm using it on Pop OS 22.04, which is based on Ubuntu 22.04 and this version of BOINC works fine.
It's possible I had to do something after installation so the BOINC manager can communicate with the client (not sure - that problem may have been with some other BOINC version on Ubuntu 20.04).
ID: 113524 · Report as offensive     Reply Quote

Message boards : Questions and problems : Will there be a viable boinc for Ubuntu 22.04 LTS soon

Copyright © 2024 University of California.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.