Boinc won't start on Linux Mint

Message boards : BOINC Manager : Boinc won't start on Linux Mint
Message board moderation

To post messages, you must log in.

AuthorMessage
stratos412

Send message
Joined: 6 Dec 20
Posts: 12
Message 112426 - Posted: 2 Aug 2023, 7:56:06 UTC

Hello all.

I have a problem starting BOINC client on Linux MInt 21 (kernel 5,15,0.78-generic) after the upgrade from Linux 20)
I get this error from crash report. Can anyone help?


[quote]
==================================================================
 Info                                                              
===================================================================
           PID: 2160 (boincmgr)
           UID: 1000 (stratos)
           GID: 1000 (stratos)
        Signal: 4 (ILL)
     Timestamp: Wed 2023-08-02 10:47:39 EEST (1min 26s ago)
  Command Line: boincmgr
    Executable: /usr/bin/boincmgr
 Control Group: /user.slice/user-1000.slice/session-c3.scope
          Unit: session-c3.scope
         Slice: user-1000.slice
       Session: c3
     Owner UID: 1000 (stratos)
       Boot ID: d8a728161e824589b1d6c18bdec3b4d7
    Machine ID: 939972095cf1459c8b22cc608eff85da
      Hostname: OLDDirector
       Storage: /var/lib/systemd/coredump/core.boincmgr.1000.d8a728161e824589b1d6c18bdec3b4d7.2160.1690962459000000.zst (present)
     Disk Size: 1.3M
       Message: Process 2160 (boincmgr) of user 1000 dumped core.
                
                Found module linux-vdso.so.1 with build-id: 3da8dece167cc88c99d5493d8a0cc6c18bc24e47
                Found module UTF-32.so with build-id: 62026277c3fc604541f4d1facbc5be96a0e0acc0
                Found module libsasl2.so.2 with build-id: b8a924f277180f8743a0c6463a379b1a4ad1aae5
                Found module libp11-kit.so.0 with build-id: a0ffe1d002de5812dc718186172efb78604ddf2c
                Found module libcrypto.so.3 with build-id: af9d9ce956e6c1589bc9ceeb36c8c693efca776a
                Found module libgmp.so.10 with build-id: f110719303ddbea25a5e89ff730fec520eed67b0
                Found module libhogweed.so.6 with build-id: 3cc4a3474de72db89e9dcc93bfb95fe377f48c37
                Found module liblber-2.5.so.0 with build-id: 3ed97b9c7019fe0f810db723481020089b14f9d5
                Found module libldap-2.5.so.0 with build-id: 64c7706f152e87eb8f4d84b59eb488b8448eea0e
                Found module libgnutls.so.30 with build-id: ededb83d3498ef77e1f7011b79f025efd7eb498f
                Found module libnettle.so.8 with build-id: 3d9c6bf106ef53d625b7b1c8bb1300e84598a74a
                Found module libssh.so.4 with build-id: 79d65cbf334a121bab20865a9612eea088c1566a
                Found module librtmp.so.1 with build-id: 9517ef375cd71ea3da824b4118f1599735093d66
                Found module libnghttp2.so.14 with build-id: 90a67111383c58bfff9fac96da818cc62e5b68c9
                Found module libcurl-gnutls.so.4 with build-id: cf9564321cd0baf433dd5d24ec5fdcbc33082635
                Found module libdebuginfod.so.1 with build-id: d29aedf4071eec65900c14478ce6f0734b37903f
                Found module libresolv.so.2 with build-id: 7fd7253c61aa6fce2b7e13851c15afa14a5ab160
                Found module libkeyutils.so.1 with build-id: ff27227afa5eeddccab180dd29bd7fcff94aea7c
                Found module libmd.so.0 with build-id: cd2d2f71b3967ebde30e2aa43b8eb63339020c06
                Found module libkrb5support.so.0 with build-id: 85c1fccae74910b1afbe878af2202ec6139d8fc2
                Found module libcom_err.so.2 with build-id: ce0901f10854b3c9276066b98d9a72303206e0d5
                Found module libk5crypto.so.3 with build-id: 8bc1e44d4148b2b533d5a97335114565d94197f8
                Found module libkrb5.so.3 with build-id: 62434c49e8118c49a9d60a0795705c806524782d
                Found module libidn2.so.0 with build-id: 45b73e0e1c46a76be22f572ee98c60af5768bf8f
                Found module libunistring.so.2 with build-id: ca5149da8d5a298b8f286ffca3d6e2402ec0fe01
                Found module libudev.so.1 with build-id: 9183eed17e70543d81d9cddda160df12a445f94a
                Found module libGLX.so.0 with build-id: ac8b68a74f1ead77477f89bc98998ecb064e3ae5
                Found module libGLdispatch.so.0 with build-id: 19c339ecd74c020f1db1342213a07114f4baf5e0
                Found module libbz2.so.1.0 with build-id: e56b62c27bcc7ace8f9be36b255bd7b31bfde405
                Found module libelf.so.1 with build-id: 0eaf2d056fb292c3da2d99fa16c13d0ec798f121
                Found module libbrotlicommon.so.1 with build-id: 43a72967cf84155914c8b3e915926733d1e57c11
                Found module libbsd.so.0 with build-id: 9a6c72469251e2feb63e175ef5cb944ce6e00df3
                Found module libXdmcp.so.6 with build-id: 6b60f99504aa1d3999ea02a14366d1a39d6c5dcf
                Found module libXau.so.6 with build-id: 7089b383cacbfc1760634a3be19a923e51fe3315
                Found module libdatrie.so.1 with build-id: 128b6874a47f2b783d9e9060d3caaee4110bfd3d
                Found module libevdev.so.2 with build-id: 453d5adc374cf78a17327783c6971a44b0e35a9c
                Found module libgssapi_krb5.so.2 with build-id: a05177e3a955af79b999bbc081b0f7bf9fb21c87
                Found module libpsl.so.5 with build-id: 2b1afc1a3bc8bdb016e432c50db058632e7895b9
                Found module libgudev-1.0.so.0 with build-id: b8325dee54d53266618de95232d1755edea29006
                Found module libX11-xcb.so.1 with build-id: f0a537068940d282177d86e6ac358fc7ba5dad97
                Found module libEGL.so.1 with build-id: 236d96c92ee2914a0e90e06e01b79dfcba0f7b41
                Found module libGL.so.1 with build-id: fe7c476406e1e41b511089398540d618177a7dcb
                Found module liborc-0.4.so.0 with build-id: 5a67015c3a49d05abd48d44529240d3c5be7b21d
                Found module libdw.so.1 with build-id: 617605522f344006b53d0ebd33b69527098c5fce
                Found module libunwind.so.8 with build-id: 7535e1d6fc2959b541329a7cd113164deacf5b8c
                Found module libgpg-error.so.0 with build-id: 3fbec71c67bee60d8aef00697ee187079b0fb307
                Found module libbrotlidec.so.1 with build-id: 4b1f390dd6e24d49684db8b2443d082379e8e977
                Found module libwoff2common.so.1.0.2 with build-id: 081c598dfcd160d49d940edd395af8a5e636829b
                Found module libicudata.so.70 with build-id: b1c2496dd0543023c7a19c961bb7f3abc818f465
                Found module libcap.so.2 with build-id: b4bf900abf14aabe12d90988ceb30888acb2bcb0
                Found module liblz4.so.1 with build-id: a85971851cd059f1af80d553c8e7170d42ec59a1
                Found module libatomic.so.1 with build-id: 7f5d0a270ff82aad3a38cd529c40c8f1353848cc
                Found module libpcre2-8.so.0 with build-id: 184a841c55fb7fe5e3873fcda8368c71016cd54c
                Found module libblkid.so.1 with build-id: cdf95a964e3302bb356fefc4b801fae8c4340b31
                Found module libexpat.so.1 with build-id: d212d1f61d04a1e60fccad1a8c118428cfd9be42
                Found module libgraphite2.so.3 with build-id: 5ffbc76fc948f6b88d766a7210c2e6a329a6c278
                Found module libatspi.so.0 with build-id: 2843c68233d5ba81da3d6bc31422e49472873dba
                Found module libdbus-1.so.3 with build-id: 63e8b99215502138cb63afd6d65851a5e837ed49
                Found module libdeflate.so.0 with build-id: 702adff4f2f7536b32bba66ecaab25f470674927
                Found module libjbig.so.0 with build-id: 5ae70eb022297d6be039f37f3005fa9be544d394
                Found module liblzma.so.5 with build-id: b85da6c48eb60a646615392559483b93617ef265
                Found module libzstd.so.1 with build-id: 5d9d0d946a3154a748e87e17af9d14764519237b
                Found module libuuid.so.1 with build-id: 64c0d0cb22fa2bdeca075a0c0418ba5ff314b220
                Found module libICE.so.6 with build-id: cf39da2f7c723f976c6e676704e218513e2b0b2b
                Found module libXrender.so.1 with build-id: 7ccbfa4c24e93c42fa50dd2e42fa277630f9650c
                Found module libxcb-render.so.0 with build-id: cb521131fd3b0f2ee6056cbc2014b3b8ef0d5c0e
                Found module libxcb.so.1 with build-id: 1bef862a339557aa16c34c7a4b27f8f3aea90517
                Found module libxcb-shm.so.0 with build-id: edb24ef4079aa423edcc50a3bb0dfb912fe8a57a
                Found module libpixman-1.so.0 with build-id: 5e936cdac032b6048d9d1a8c0bb0e4a10c86d48c
                Found module libthai.so.0 with build-id: afa54530349e68380815d606d15dbfda8952799f
                Found module libXext.so.6 with build-id: 9fb1880e02dfa11a8c39cd1a170109de08302059
                Found module libwayland-cursor.so.0 with build-id: abcd1ab467757354ac36fd0938b82d47d7aebe1f
                Found module libxkbcommon.so.0 with build-id: a4b17d939092101dc8f6b2a1d70eaf1fddb2dd51
                Found module libXcursor.so.1 with build-id: d936a5db46d8babb0f2cc490df36b6b18a16d8aa
                Found module libXrandr.so.2 with build-id: 069f930a2b41f3908a1a92b1a51c38bd13a559e2
                Found module libXinerama.so.1 with build-id: 9823bebfa26a681265db4aeb09abf44deec38401
                Found module libdrm.so.2 with build-id: 9c7cb19295d20e515902cb0710326a0b8d6394c8
                Found module libgbm.so.1 with build-id: 246f671fbf3db74dfff3a65f6fe724b9bbdf5596
                Found module libseccomp.so.2 with build-id: 5e29725d7f0bd8cb9a04f40eb45d6b75ca6bfbd2
                Found module libmanette-0.2.so.0 with build-id: 6c98dd21d30aa2213d766bf2c3a5501abb56265e
                Found module libwayland-client.so.0 with build-id: a85980f4efa33fa5cadfbf257349fef99d499427
                Found module libwayland-egl.so.1 with build-id: e13dfac5961e8fb58c54984fe8110a73c2f5ef99
                Found module libwayland-server.so.0 with build-id: 75c4598a62c3c6e94868467866488cdfba049e7d
                Found module libXdamage.so.1 with build-id: 8358b7625700dc247fa21fb4304cba877a28bb04
                Found module libXcomposite.so.1 with build-id: 2c84db5342304ba1a76db7dd9b7a3bfaa8a716ce
                Found module libhyphen.so.0 with build-id: ff1638c45b2dd10e898808e28b77c89b32c8121f
                Found module libtasn1.so.6 with build-id: 2fde6ecb43c586fe4077118f771077aa1298e7ea
                Found module libsecret-1.so.0 with build-id: f1bc90f2861b0a48efde601947460df81f47597b
                Found module libenchant-2.so.2 with build-id: 6567af9845ef81015bb3eb15df79c7322ad55a08
                Found module libsoup-2.4.so.1 with build-id: 3e41ed6c93570797554d1e1f59efe631a0e3c2c9
                Found module libwebp.so.7 with build-id: 8abe271daab53b3f0663bd3bb99f9230cc75a2b1
                Found module libwebpdemux.so.2 with build-id: fc57578bdb0f8d362687e2551f822265f252703a
                Found module libopenjp2.so.7 with build-id: 8fca055b4b5787b0db2397d2dfe8de5b6fbf53f2
                Found module libgstfft-1.0.so.0 with build-id: f30ee75ee1aa4b61ba625dbfb9dd1f94a0ae2be6
                Found module libgstgl-1.0.so.0 with build-id: dd15de40b6fa09bb5032a30e0e4035c971f8d452
                Found module libgstvideo-1.0.so.0 with build-id: 1b4aaf5b9e44b671ca2a7397d16a0df3feb78b00
                Found module libgsttag-1.0.so.0 with build-id: 9828ba43c2c8aa4b39479b7bb7b2be3e5c78c8c4
                Found module libgstaudio-1.0.so.0 with build-id: ebac36e5979264b9666292c05ae6770cc2e91fda
                Found module libgstpbutils-1.0.so.0 with build-id: a32fd14c232155b79c3c705919cd9747b4e09811
                Found module libgstreamer-1.0.so.0 with build-id: ebda18376729c74f804450ea604d98752468b65a
                Found module libgstbase-1.0.so.0 with build-id: 32e2a77fe22377f118bcf70c01c1e8549d78e7a1
                Found module libgstapp-1.0.so.0 with build-id: 6fea33f4e09c06584bd7c129144976754ba5448e
                Found module libgstallocators-1.0.so.0 with build-id: 963a5bff2fdb54ac331490114ce0520c5d64bd87
                Found module libgcrypt.so.20 with build-id: 60a5e524de0ed8323edf33e9eb9127a9eee02359
                Found module libharfbuzz-icu.so.0 with build-id: a095e684d573592116a17180c207981cfd7c0c08
                Found module libfreetype.so.6 with build-id: bc6c65a19e6f75fea5e74a7fd6c0b91182e1a8b0
                Found module libwoff2dec.so.1.0.2 with build-id: 7ee907a44c16fed44822070c07e0dcbeb33754a4
                Found module liblcms2.so.2 with build-id: 0bda30d5d03a817e234844b5414ea1dc25dc824a
                Found module libxslt.so.1 with build-id: 3076207dc96a219dbe8aa3a15613f5a6814d14b5
                Found module libsqlite3.so.0 with build-id: 0f2f07c3459119c3759ed803ccf46906be78bee4
                Found module libxml2.so.2 with build-id: 1cf4a22fbe15a77baca28e9c824592b8b5d852ff
                Found module libicuuc.so.70 with build-id: bef3ff1d70aadd68aab07d858a759360c8b919ae
                Found module libsystemd.so.0 with build-id: e45f7492c0f62251620378d7224ad0371a8d1f98
                Found module libicui18n.so.70 with build-id: ff2dbcdd92cbe5a63d20291e295d8fed9f87d35b
                Found module libjavascriptcoregtk-4.0.so.18 with build-id: 0964d187a28ad25911e253b2bca5f49ad48c8a3e
                Found module libWPEBackend-fdo-1.0.so.1 with build-id: 67724f32e7943a136bd5c419c9906a86e7e38795
                Found module libwpe-1.0.so.1 with build-id: 08dbb3ef676b87569c3e0a13cc55e3848a659527
                Found module libselinux.so.1 with build-id: 6fa53202ce676297de24873c886443b2759bfd8a
                Found module libmount.so.1 with build-id: eeb33f2b4b9c3eb0a29575eb9932ef08663bd836
                Found module ld-linux-x86-64.so.2 with build-id: 61ef896a699bb1c2e4e231642b2e1688b2f1a61e
                Found module libpcre.so.3 with build-id: 3982f316c887e3ad9598015fa5bae8557320476a
                Found module libffi.so.8 with build-id: 59c2a6b204f74f358ca7711d2dfd349d88711f6a
                Found module libfontconfig.so.1 with build-id: 0bb435fdd5ec37178e14ea03bb36f779a4b72a94
                Found module libharfbuzz.so.0 with build-id: 3b9c495c079286b8d1f55d0937a0a771593eb7e6
                Found module libpangoft2-1.0.so.0 with build-id: fc7f13d8298f5e10fb1acbaa5472ec8b6fbf2bd9
                Found module libfribidi.so.0 with build-id: 6e075a666e1da8ffdb948d734e75d82b1b6dc0fb
                Found module libepoxy.so.0 with build-id: 5ea53a2b100e4b044eee19d5222881a724abf046
                Found module libatk-bridge-2.0.so.0 with build-id: 7e8009077fbdcd7bf094c51bf78742b96f216d73
                Found module libatk-1.0.so.0 with build-id: b93088667fbd06f6b72d273403d352e7c0554698
                Found module libcairo-gobject.so.2 with build-id: 71b5bd37d77ea1862d2ed00e9f6ead482f307db8
                Found module libXfixes.so.3 with build-id: a9c550a40b8154a3b4b5e2ac182bb50c013c3f18
                Found module libXi.so.6 with build-id: 8ff5a3ac871a90fd9d0a7917c61f748a41c6b5ee
                Found module libgmodule-2.0.so.0 with build-id: 8b369a368c3070d179ddf64724ffc229c3f214b5
                Found module libz.so.1 with build-id: 30840b79ac329ecbf1dec0bb60180eed256d319f
                Found module libtiff.so.5 with build-id: ac76776cbb1c36670c833fdf62b86ba5f86ef9ab
                Found module libjpeg.so.8 with build-id: c54abff9294357e28532a76a049a4cb2542fc15b
                Found module libpng16.so.16 with build-id: d58bf7c11ac793d528926238d831792b5ef792cf
                Found module libSM.so.6 with build-id: 6b32192c8a8870a8fe04403f537e806da93a1dd8
                Found module libpangocairo-1.0.so.0 with build-id: 65987e60b791e0eb6231575b8d5cfd33a6379b22
                Found module libX11.so.6 with build-id: d1d3345a252a40a004cbd02011a651930e172ccd
                Found module libcairo.so.2 with build-id: 60a39c3684e41370bd0a59ed1ecbdccf47e30069
                Found module libpango-1.0.so.0 with build-id: 42c8896c53d9d22dc73ba7a78b326d61f34e4442
                Found module libgdk-3.so.0 with build-id: 97b768ef80858a79741be2492754d948989e63c6
                Found module libwebkit2gtk-4.0.so.37 with build-id: 3840b4b21f7b1b13449507038b6622968bd5fc79
                Found module libgio-2.0.so.0 with build-id: 07bd46a1bb58e321e6aabc67135d054e6b78069d
                Found module libgdk_pixbuf-2.0.so.0 with build-id: 374b383e3b68b5d8b552519094129f401596e502
                Found module libc.so.6 with build-id: 69389d485a9793dbe873f0ea2c93e02efaa9aa3d
                Found module libgcc_s.so.1 with build-id: e3a44e0da9c6e835d293ed8fd2882b4c4a87130c
                Found module libm.so.6 with build-id: 27e82301dba6c3f644404d504e1bb1c97894b433
                Found module libstdc++.so.6 with build-id: e37fe1a879783838de78cbc8c80621fa685d58a2
                Found module libglib-2.0.so.0 with build-id: c74e800dfd5f72649d673b44292f4a817e45150b
                Found module libgobject-2.0.so.0 with build-id: 7c47809b4e688382aab4127a2e07496450c5e6b0
                Found module libgtk-3.so.0 with build-id: 9a340345f5e200f42140f3cb4bacb407e91843f8
                Found module libwx_baseu-3.0.so.0 with build-id: 2c598c22915c07b7ea2a4f67cab1fb81fbb0f4ce
                Found module libwx_baseu_net-3.0.so.0 with build-id: 586503861773eff97e8ecbd2fa142c6446a01c76
                Found module libwx_gtk3u_core-3.0.so.0 with build-id: 63d405584aa1e3c4cfa135a633bdcb3b045b2904
                Found module libwx_gtk3u_adv-3.0.so.0 with build-id: 7bfef3f10aa7cf0da88cc168376384ef2975c035
                Found module libwx_gtk3u_html-3.0.so.0 with build-id: 7b898e601274c93c946a10bbe83254f73f0fd7fb
                Found module libwx_gtk3u_webview-3.0.so.0 with build-id: e210c63096a5fb1dd97e2fb9b1a04ef38fa0e0bf
                Found module libnotify.so.4 with build-id: 9f17eb75ce0087dc0e9e2049eeb47d37883006e3
                Found module libboinc.so.7 with build-id: 80df7dbe2305c2f0831cf490c8953de704fb58e3
                Found module boincmgr with build-id: 313b3a7d3ad4e5b5a9786e2b58809d7ca509109c
                Stack trace of thread 2160:
                #0  0x000056457cd5e55d n/a (boincmgr + 0x10055d)
                #1  0x000056457cd68053 n/a (boincmgr + 0x10a053)
                #2  0x00007f6ccea5eebb call_init (libc.so.6 + 0x29ebb)
                #3  0x000056457cd6b745 n/a (boincmgr + 0x10d745)
===================================================================
 GDB Log                                                           
===================================================================
[New LWP 2160]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `boincmgr'.
Program terminated with signal SIGILL, Illegal instruction.
#0  0x000056457cd5e55d in ?? ()

===================================================================
 GDB Backtrace                                                     
===================================================================
[New LWP 2160]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `boincmgr'.
Program terminated with signal SIGILL, Illegal instruction.
#0  0x000056457cd5e55d in ?? ()
#0  0x000056457cd5e55d in ?? ()
#1  0x000056457cd68053 in ?? ()
#2  0x00007f6ccea5eebb in call_init (env=<optimized out>, argv=0x7ffe7a611578, argc=1) at ../csu/libc-start.c:145
#3  __libc_start_main_impl (main=0x56457cd5e120, argc=1, argv=0x7ffe7a611578, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe7a611568) at ../csu/libc-start.c:379
#4  0x000056457cd6b745 in ?? ()

===================================================================
 GDB Backtrace (all threads)                                       
===================================================================
[New LWP 2160]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
Core was generated by `boincmgr'.
Program terminated with signal SIGILL, Illegal instruction.
#0  0x000056457cd5e55d in ?? ()

Thread 1 (Thread 0x7f6cc4402b00 (LWP 2160)):
#0  0x000056457cd5e55d in ?? ()
No symbol table info available.
#1  0x000056457cd68053 in ?? ()
No symbol table info available.
#2  0x00007f6ccea5eebb in call_init (env=<optimized out>, argv=0x7ffe7a611578, argc=1) at ../csu/libc-start.c:145
        j = 0
        jm = <optimized out>
        addrs = <optimized out>
        l = <optimized out>
        init_array = <optimized out>
#3  __libc_start_main_impl (main=0x56457cd5e120, argc=1, argv=0x7ffe7a611578, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe7a611568) at ../csu/libc-start.c:379
No locals.
#4  0x000056457cd6b745 in ?? ()
No symbol table info available.
#0  0x000056457cd5e55d in ?? ()
#1  0x000056457cd68053 in ?? ()
#2  0x00007f6ccea5eebb in call_init (env=<optimized out>, argv=0x7ffe7a611578, argc=1) at ../csu/libc-start.c:145
#3  __libc_start_main_impl (main=0x56457cd5e120, argc=1, argv=0x7ffe7a611578, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffe7a611568) at ../csu/libc-start.c:379
#4  0x000056457cd6b745 in ?? ()

[/quote]
ID: 112426 · Report as offensive
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2563
United Kingdom
Message 112427 - Posted: 2 Aug 2023, 9:21:26 UTC
Last modified: 2 Aug 2023, 9:22:48 UTC

does it start with
sudo systemctl start boinc-client
?

Edit: What is the BOINC version installed?
ID: 112427 · Report as offensive
stratos412

Send message
Joined: 6 Dec 20
Posts: 12
Message 112428 - Posted: 2 Aug 2023, 10:02:41 UTC
Last modified: 2 Aug 2023, 10:05:03 UTC

Boinc Client: 7.18.1 +dfsg-4
Boinc Manager: 7.18.1 +dfsg-4
Boinc: 7.18.1 +dfsg-4

Those are installed via ''Software Manager'' of Linux Mint

I also installed them via terminal.

I tried the ''sudo systemctl start boinc-client''. It seems that is running on the Process list, but it won't open.
I get the same error in the System Reports.

EDIT: I suppose that some packages that the upgrade linux tool found them ''not compatible'' , I had to keep them...
ID: 112428 · Report as offensive
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2563
United Kingdom
Message 112429 - Posted: 2 Aug 2023, 10:54:07 UTC - in response to Message 112428.  
Last modified: 2 Aug 2023, 10:54:32 UTC

It is a problem with 7.18 which is designed to only run on Android. Sadly some of the package mangers haven't spotted this yet.
If you use Gianfranco's version it should work. Get instructions here
ID: 112429 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 5082
United Kingdom
Message 112430 - Posted: 2 Aug 2023, 11:16:41 UTC
Last modified: 2 Aug 2023, 11:24:07 UTC

I went through exactly the same process some time ago. I was running Mint 20.3, with a late version of BOINC 7.20.x from Gianfranco Costamagna's PPA.

The upgrade to Mint 21 went smoothly, but Mint 21 rejected the PPA (all PPAs) because of a change in security policy. Instead, it installed v7.18.1 from it's own repositories - and in my case, it ran.

I can only surmise that there is a difference in one of the support libraries between the Mint repository and the PPA: since the problem only affects the Manager component, the usual finger of suspicion points at the wxWidgets GUI component library.

We're in a bit of a transitional phase at the moment. The other main platforms (Android, Apple, Windows) have transitioned to v7.22.2, but the Linux repository maintainers have been markedly slow to follow suit - even Gianfranco hasn't got that one out yet. The BOINC developers are working on an in-house Linux installer, but again incredibly slowly.

I think it would be helpful if you could escalate this - and your excellent error log - to GitHub, where most issues are thrashed out these days. You could either reopen my https://github.com/BOINC/boinc/issues/4930 (give me a shout if you can't open it, and I'll open it for you), or start a whole new issue. This has been going on for far too long, and a fresh voice on git might dispel the prevailing mood of "Oh no - not him/that again."

In the meantime, I've had some success with doing a binary file replacement on Mint 21 - you can download 'artifacts' automatically generated by CI testing on GitHub for any recent pull request. They are statically linked, so you should just need the boincmgr binary. Again, I can guide you through that process. Or Dave can guide you through the steps for a self-build of the Manager on your own system.
ID: 112430 · Report as offensive
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2563
United Kingdom
Message 112432 - Posted: 2 Aug 2023, 12:16:50 UTC
Last modified: 2 Aug 2023, 12:18:53 UTC

I did save the list of things I had to install to get the master to compile on my current setup after a clean install of this is what I needed on top of the instructions on this site for compiling from source.
ID: 112432 · Report as offensive
stratos412

Send message
Joined: 6 Dec 20
Posts: 12
Message 112433 - Posted: 2 Aug 2023, 15:36:48 UTC

I couldn't manage to work in with Boinc Manager.
I will work it again, but just to do my job for now, I have installed BOINC MANAGER (Flatpak) from Linux Mint ''Software Manager''.
Seem that package works fine so far.
ID: 112433 · Report as offensive
stratos412

Send message
Joined: 6 Dec 20
Posts: 12
Message 112434 - Posted: 2 Aug 2023, 15:48:38 UTC

OK. Another issue came up.
I got an error from BOINC ''Virtualbox is not installed'', but I have already installed oracle virtualbox 6.1.38_ubuntu r153438. :/
ID: 112434 · Report as offensive
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2563
United Kingdom
Message 112435 - Posted: 2 Aug 2023, 15:58:08 UTC - in response to Message 112434.  

OK. Another issue came up.
I got an error from BOINC ''Virtualbox is not installed'', but I have already installed oracle virtualbox 6.1.38_ubuntu r153438. :/


Worth looking at this over at LHC
ID: 112435 · Report as offensive
stratos412

Send message
Joined: 6 Dec 20
Posts: 12
Message 112436 - Posted: 2 Aug 2023, 16:20:33 UTC - in response to Message 112435.  

Tried it and get error on number 3 command
''boinc -dir ${HOME}/boinc give ''Illigal instruction (core dumped)''.


Every time Linux gets a major update, half of software/ packages got broken for some reason.
Unfortunately, I am a noob using Linux and I got really depressed when I have to set up things from the start....
It is really time consuming and sometimes I have to do a clean install on Linux OS and start all over again...
ID: 112436 · Report as offensive
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2563
United Kingdom
Message 112437 - Posted: 2 Aug 2023, 16:44:38 UTC - in response to Message 112436.  

It is really time consuming and sometimes I have to do a clean install on Linux OS and start all over again...
Been there, done that one. It is probably worth exploring the forums of a few of the projects that use VB. You are certainly not going to be the only one who has had this problem. I still can't get all the projects that use VB to work on my box but as my main project is one that doesn't use it, I can live with that. And as you have discovered, it is not unusual to find one version of something works when another doesn't. I am using VB7.0
ID: 112437 · Report as offensive
stratos412

Send message
Joined: 6 Dec 20
Posts: 12
Message 112453 - Posted: 4 Aug 2023, 20:31:13 UTC - in response to Message 112437.  

I tried some things but I cannot get to work Virtualbox with BOINC in Linux Mint.
I had the latest version installed 7.0. I removed it and installed version 6.1.34, since I have read it is more compatible with BOINC.
Same issue, ''virtualbox is not installed''.

I don't know if it is a compatibility issue with BOINC (flatpak) or a general issue with Linux Mint 21.0

LINK
https://www.virtualbox.org/wiki/Download_Old_Builds_6_1 (VERSION 6.1.34 for Ubuntu 22.04)
ID: 112453 · Report as offensive
computezrmle

Send message
Joined: 2 Feb 22
Posts: 81
Germany
Message 112455 - Posted: 5 Aug 2023, 6:06:49 UTC - in response to Message 112453.  

Your computers don't meet some essential requirements to run VirtualBox tasks.
See an extended answer here:
https://lhcathome.cern.ch/lhcathome/forum_thread.php?id=6023&postid=48343
ID: 112455 · Report as offensive

Message boards : BOINC Manager : Boinc won't start on Linux Mint

Copyright © 2024 University of California.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.