boinc 7.16.12 won't install (on macos 10.7)

Message boards : Questions and problems : boinc 7.16.12 won't install (on macos 10.7)
Message board moderation

To post messages, you must log in.

AuthorMessage
shloime

Send message
Joined: 25 Nov 20
Posts: 2
Canada
Message 101759 - Posted: 25 Nov 2020, 3:30:52 UTC

i'm currently running boinc version 7.16.11, and i got a message that an update was available. i downloaded the 7.16.12 installer for mac os, but the installer says that "its digital signature is invalid", and it aborts the install.

afaik, the wiki says that the minimum system requirement is mac os 10.4, and i'm running 10.7.5 on a nice little i7-powered mini server. so, i think, i meet the minimum. (maybe the wiki is out of date?) or maybe there's a problem with the update? (i downloaded it 3 times, just in case it was a file transfer error, even though that's unlikely with tcp/ip.)

please advise.
ID: 101759 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4498
United Kingdom
Message 101761 - Posted: 25 Nov 2020, 11:50:10 UTC - in response to Message 101759.  

There's nothing much we can do at this end - digital signatures are issued to the developer, and tightly guarded.

But I've sent an email to the developer concerned, and drawn attention to this report.

There may be a delay in responding, because of time-zones.
ID: 101761 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4498
United Kingdom
Message 101787 - Posted: 26 Nov 2020, 17:14:22 UTC

Charlie has provided some more background privately. It seems there was a subtle change in the digital signature system round about version 10.9 - older versions of the Mac OS can't read the newer signatures.

Owners of older Macs can go on running BOINC version 7.16.11 - Charlie has made that visible again on the download all page, in case you don't have a copy to hand. He's also replaced 7.16.12 with 7.16.13 - no change to the actual program, just an extra safeguard to stop people trying to install it on the older Macs.

There's no added benefit in upgrading to 7.16.12/13 anyway - those versions were only released to support the brand new 'Apple Silicon' range launched this month.
ID: 101787 · Report as offensive
CWVB

Send message
Joined: 31 Oct 17
Posts: 1
Germany
Message 101801 - Posted: 27 Nov 2020, 12:46:04 UTC - in response to Message 101759.  

Same issue:

i'm currently running boinc version 7.16.11, and i got a message that an update was available. I downloaded the 7.16.13 installer for mac os, but the installer says that "its digital signature is invalid", and it aborts the installation.

BOINC says that the minimum system requirement is mac os 10.4, and i'm running 10.11.6 on an iMac Early 2008. so, i think, i meet the minimum. Maybe there's a problem with the update? (i downloaded it 3 times, just in case it was a file transfer error, even though that's unlikely with tcp/ip.)
Signatur for BOINC 7.16.11 was installed by Charlie Fenton (R2TC2Z4282)

please advise.
ID: 101801 · Report as offensive
Charlie Fenton
Project developer

Send message
Joined: 17 Jul 06
Posts: 270
United States
Message 101824 - Posted: 27 Nov 2020, 22:00:15 UTC - in response to Message 101804.  
Last modified: 27 Nov 2020, 22:03:18 UTC

I have unlocked this thread again. This is an ongoing issue under investigation.
Charlie Fenton
BOINC / SETI@home Macintosh & Windows Programmer
ID: 101824 · Report as offensive
Charlie Fenton
Project developer

Send message
Joined: 17 Jul 06
Posts: 270
United States
Message 101870 - Posted: 1 Dec 2020, 13:50:08 UTC

I have released BOINC 7.16.14 for Macintosh which I believe has fixed this problem, but it requires MacOS 10.9.0 or later.

BOINC 7.16.11 is the last version that will run on MacOS 10.7 or 10.8. Unfortunately, the logic on the server will continue to tell users of those MacOS versions that there is newer version available and will offer them BOINC 7.16.14. You can find older releases of BOINC at https://boinc.berkeley.edu/download_all.php.
Charlie Fenton
BOINC / SETI@home Macintosh & Windows Programmer
ID: 101870 · Report as offensive
shloime

Send message
Joined: 25 Nov 20
Posts: 2
Canada
Message 101879 - Posted: 1 Dec 2020, 21:47:14 UTC - in response to Message 101787.  
Last modified: 1 Dec 2020, 21:48:12 UTC

thanks for the info. maybe the system requirements page should be updated to reflect the fact that boinc 7.16.12 cannot be installed on mac os versions prior to 10.9? as well as the information that users with older systems (10.4-10.8) can use boinc version 7.16.11 instead.
ID: 101879 · Report as offensive
Charlie Fenton
Project developer

Send message
Joined: 17 Jul 06
Posts: 270
United States
Message 101881 - Posted: 2 Dec 2020, 0:25:55 UTC

I have created a ticket for this and its related issues. https://github.com/BOINC/boinc/issues/4116.
Charlie Fenton
BOINC / SETI@home Macintosh & Windows Programmer
ID: 101881 · Report as offensive

Message boards : Questions and problems : boinc 7.16.12 won't install (on macos 10.7)

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.