no WSL detected

Message boards : Questions and problems : no WSL detected
Message board moderation

To post messages, you must log in.

AuthorMessage
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 101437 - Posted: 2 Nov 2020, 21:38:41 UTC

I guess that since the last thing mentioned about WSL is in 7.12or 7.14, no changes have been made since?
Because right now, on no windows host I have WSL detected where I use in fact docker which requires WSL.
ID: 101437 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4498
United Kingdom
Message 101438 - Posted: 2 Nov 2020, 21:50:24 UTC - in response to Message 101437.  

Have you, yourself, added WSL to your Windows 10 system? That's a pre-requisite, not installed by docker, whether it needs it or not.
ID: 101438 · Report as offensive
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 101442 - Posted: 2 Nov 2020, 22:22:38 UTC - in response to Message 101438.  

True you are not obligated to do so and use the hyperVM but I'm using WSL2 backend so:
yes WSL is required by docker
Install Windows 10, version 1903 or higher.
Enable WSL 2 feature on Windows. For detailed instructions, refer to the Microsoft documentation.
Download and install the Linux kernel update package.
ID: 101442 · Report as offensive
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 101443 - Posted: 2 Nov 2020, 22:23:13 UTC - in response to Message 101438.  

Have you, yourself, added WSL to your Windows 10 system? That's a pre-requisite, not installed by docker, whether it needs it or not.

So I guess your API doesn't work anymore
ID: 101443 · Report as offensive
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 101444 - Posted: 2 Nov 2020, 22:31:26 UTC
Last modified: 2 Nov 2020, 22:32:08 UTC

Before someone say that I should doublechecked....
https://share.riseup.net/#YTSHYVJsNq_Yut3HNW2x4g
ID: 101444 · Report as offensive
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 101717 - Posted: 22 Nov 2020, 23:03:01 UTC

So still no answers, where should I report any bugs in boinc ? Because this is clearly a bug and this has nothing to do with an error on the client?
ID: 101717 · Report as offensive
Vitalii Koshura

Send message
Joined: 29 Mar 17
Posts: 9
Ukraine
Message 102010 - Posted: 7 Dec 2020, 5:35:10 UTC

I see no picture on the link you mentioned. Could you please re-add it?
ID: 102010 · Report as offensive

Message boards : Questions and problems : no WSL detected

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.