nVidia not detected on MXLinux (Debian)

Message boards : Questions and problems : nVidia not detected on MXLinux (Debian)
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Yavanius
Avatar

Send message
Joined: 19 May 15
Posts: 120
Antarctica
Message 100249 - Posted: 9 Aug 2020, 5:55:46 UTC

Have a Latitude E6420 notebook with an NVS4200M chipset (Optimus) with current MXLinux.

I installed the 390 legacy drivers then installed BOINC. Both are from Stable. The GPU wasn't detected. I tried adding the BOINC CUDA package which has worked before on Ubuntu based distributions. Most recently I was testing Bodhi and after I installed the Legacy package BOINC picked it up right away.

I tried restarting BOINC and rebooting to no effect. I can't seem to find anything on my searches to resolve this especially since a lot info is several years old.

I tried: adduser boinc render (I remember that from Ubuntu many years ago) to no effect either.

The MXTool shows the driver is installed. I don't see a way offhand to verify it's active though.

If you need more info, you'll have to point me in the right direction as my Linux troubleshooting is not that in-depth. Otherwise, TIA for any aide you can provide.
ID: 100249 · Report as offensive
MarkJ
Volunteer tester
Help desk expert

Send message
Joined: 5 Mar 08
Posts: 272
Australia
Message 100260 - Posted: 9 Aug 2020, 12:39:13 UTC - in response to Message 100249.  
Last modified: 9 Aug 2020, 12:42:40 UTC

Have a Latitude E6420 notebook with an NVS4200M chipset (Optimus) with current MXLinux.

I installed the 390 legacy drivers then installed BOINC. Both are from Stable. The GPU wasn't detected.
<snip>
I tried restarting BOINC and rebooting to no effect. I can't seem to find anything on my searches to resolve this especially since a lot info is several

Under Debian I install nvidia-driver and nvidia-kernel-dkms. If you want OpenCL you’ll also need nvidia-opencl-icd. You’ll have to reboot after installing them.

Given it’s an old GPU you might be out of luck with CUDA support.
MarkJ
ID: 100260 · Report as offensive
Profile Yavanius
Avatar

Send message
Joined: 19 May 15
Posts: 120
Antarctica
Message 100271 - Posted: 11 Aug 2020, 2:03:07 UTC - in response to Message 100260.  

Still no luck. Rebooted just to make sure.


I don't what it could still run. Last I checked it could do SETI but that's gone. Einstein went to a minimum of 1 gb of VRAM some years ago. I'd like to see what it might run still.

Yav
ID: 100271 · Report as offensive

Message boards : Questions and problems : nVidia not detected on MXLinux (Debian)

Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.