ubuntu 19.04 and AMD drivers

Message boards : GPUs : ubuntu 19.04 and AMD drivers
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Joseph Stateson
Volunteer tester
Avatar

Send message
Joined: 27 Jun 08
Posts: 641
United States
Message 91311 - Posted: 1 May 2019, 7:06:54 UTC
Last modified: 1 May 2019, 7:09:33 UTC

I put ubuntu 19.04 on one of my systems then realized (after everything was working) that latest AMD drivers were for 18.30.

The AMD install fails with "broken packages" messages.

This was just a minimal server install. I assume the problem is 19 and not that I put in a minimal install.

Has anyone gotten those "18" AMD ubuntu drivers to work with 19? If not, then I will have to install 18.30

[EDIT] The video board, RX-560, works fine but BOINC sees no useable GPU so I assume I need that driver.
ID: 91311 · Report as offensive
Profile Joseph Stateson
Volunteer tester
Avatar

Send message
Joined: 27 Jun 08
Posts: 641
United States
Message 91325 - Posted: 1 May 2019, 13:53:00 UTC

hmm - tried just the the opencl install as explained here
https://linuxconfig.org/install-opencl-for-the-amdgpu-open-source-drivers-on-debian-and-ubuntu

didn't get too far. the amd package for 19.10 said it could only be installed on 18.04 !!!

Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-core 19.10-785425 [2,416 B]
(Reading database ... 100259 files and directories currently installed.)
Preparing to unpack .../amdgpu-core_19.10-785425_all.deb ...
ERROR: This package can only be installed on Ubuntu 18.04.


Should have checked out the available drivers before putting in the latest & greatest ubuntiu.
ID: 91325 · Report as offensive
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2568
United Kingdom
Message 91327 - Posted: 1 May 2019, 16:58:43 UTC

Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-core 19.10-785425 [2,416 B]


No graphics card here so I am probably missing something but I am impressed that there even is a driver for 19l10 when Ubuntu 19.10 doesn't come out till October!
ID: 91327 · Report as offensive
Profile Joseph Stateson
Volunteer tester
Avatar

Send message
Joined: 27 Jun 08
Posts: 641
United States
Message 91330 - Posted: 1 May 2019, 18:05:27 UTC - in response to Message 91327.  

Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-core 19.10-785425 [2,416 B]


No graphics card here so I am probably missing something but I am impressed that there even is a driver for 19l10 when Ubuntu 19.10 doesn't come out till October!


Actually, I missed it: The 19.10 is the version of the AMD driver, not Ubuntu

https://askubuntu.com/questions/1139717/amd-latest-driver-18-04-install-on-19-04-min-server
ID: 91330 · Report as offensive
Profile Dave
Help desk expert

Send message
Joined: 28 Jun 10
Posts: 2568
United Kingdom
Message 91337 - Posted: 2 May 2019, 4:57:37 UTC

Get:1 file:/var/opt/amdgpu-pro-local ./ amdgpu-core 19.10-785425 [2,416 B]


Actually, I missed it: The 19.10 is the version of the AMD driver, not Ubuntu


I should spotted that. I blame old age.
ID: 91337 · Report as offensive

Message boards : GPUs : ubuntu 19.04 and AMD drivers

Copyright © 2024 University of California.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.