Daemons not starting

Message boards : Server programs : Daemons not starting
Message board moderation

To post messages, you must log in.

AuthorMessage
Blaubunt

Send message
Joined: 26 Apr 19
Posts: 1
Germany
Message 91221 - Posted: 26 Apr 2019, 8:40:00 UTC
Last modified: 26 Apr 2019, 8:40:15 UTC

Hey guys,
I am trying to setup a boinc server with a custom project and applications.
With the example_app the server runs perfectly.
But when it comes to my own project with application it is telling me on project startup that the daemons get startet, but on the status page of the project it shows the 3 daemons (feeder,transitioner and file_deleter) as not running. Also there are Workunits ready to send but not being send out to the client.

Does anybody know any solution for this problem?
ID: 91221 · Report as offensive
ChristianB
Volunteer developer
Volunteer tester

Send message
Joined: 4 Jul 12
Posts: 321
Germany
Message 91223 - Posted: 26 Apr 2019, 14:35:16 UTC

Please take a look at the logfiles of the daemons. They are on the server in your project root directory in a folder called logs_(hostname). The project start script just tries to start them if there are startuperrors they appear in the logfile. Also you could try to run the daemon command yourself (as boincadm) and see what it is complaining about.
ID: 91223 · Report as offensive

Message boards : Server programs : Daemons not starting

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.