Linux: doesn't start (standard Ubuntu 16.04 LTS 64 Bit)

Message boards : Questions and problems : Linux: doesn't start (standard Ubuntu 16.04 LTS 64 Bit)
Message board moderation

To post messages, you must log in.

AuthorMessage
dentaku

Send message
Joined: 14 Dec 06
Posts: 74
Germany
Message 79807 - Posted: 27 Jul 2017, 10:48:02 UTC
Last modified: 27 Jul 2017, 11:19:49 UTC

Oh boy, many months ago, I tried to get BOINC running again but it didn't run anymore. Today, I downloaded the latest version, even followed the instructions on https://boinc.berkeley.edu/wiki/Installing_BOINC but it doesn't run on my pretty standard Ubuntu 16.04.02 LTS (64 Bit) system:

./boincmgr: error while loading shared libraries: libwx_gtk2u_html-2.8.so.0: cannot open shared object file: No such file or directory

I tried to link the existinbg libs:

ln -s /usr/lib/x86_64-linux-gnu/libwx_gtk2u_html-3.0.so.0 libwx_gtk2u_html-2.8.so.0
ln -s /usr/lib/x86_64-linux-gnu/libwx_gtk2u_adv-3.0.so.0 libwx_gtk2u_adv-2.8.so.0
ln -s /usr/lib/x86_64-linux-gnu/libwx_gtk2u_core-3.0.so.0 libwx_gtk2u_core-2.8.so.0
ln -s /usr/lib/x86_64-linux-gnu/libwx_baseu_net-3.0.so.0 libwx_baseu_net-2.8.so.0
ln -s /usr/lib/x86_64-linux-gnu/libwx_baseu-3.0.so.0 libwx_baseu-2.8.so.0

and start BOINC with

DIRECTORY=$(cd `dirname $0` && pwd)
cd $DIRECTORY

export LD_LIBRARY_PATH=/Daten/Programme/BOINC/lib/:$LD_LIBRARY_PATH
export DISPLAY=:0

./run_client --daemon
./run_manager

but then I get:

./boincmgr: /Daten/Programme/BOINC/lib/libwx_baseu_net-2.8.so.0: version `WXU_2.8' not found (required by ./boincmgr)
./boincmgr: /Daten/Programme/BOINC/lib/libwx_gtk2u_html-2.8.so.0: version `WXU_2.8' not found (required by ./boincmgr)
./boincmgr: /Daten/Programme/BOINC/lib/libwx_gtk2u_adv-2.8.so.0: version `WXU_2.8' not found (required by ./boincmgr)
./boincmgr: /Daten/Programme/BOINC/lib/libwx_baseu-2.8.so.0: version `WXU_2.8' not found (required by ./boincmgr)
./boincmgr: /Daten/Programme/BOINC/lib/libwx_gtk2u_core-2.8.so.0: version `WXU_2.8.5' not found (required by ./boincmgr)
./boincmgr: /Daten/Programme/BOINC/lib/libwx_gtk2u_core-2.8.so.0: version `WXU_2.8' not found (required by ./boincmgr)


We live in 2017 ... 64 BIt is many many years standard. Please provide a standard 64 Bit Client.
BOINC 7.2.42 (x86_64) on Linux Ubuntu 16.04 (64 Bit), AMD APU 7850K 3.7 GHz, 32 GB RAM.
ID: 79807 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14729
Netherlands
Message 79809 - Posted: 27 Jul 2017, 11:42:14 UTC - in response to Message 79807.  

BOINC is built by volunteers.
BOINC in Linux is built by its package maintainers, so look for the latest newest version in your repository.
As far as I know, Gianfranco has released 7.6.33

You can read about him in https://wiki.ubuntu.com/GianfrancoCostamagna/CoreDevApplication.
Available BOINC versions from him are at https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/boinc including instructions on how to install his repository.
ID: 79809 · Report as offensive
Juha
Volunteer developer
Volunteer tester
Help desk expert

Send message
Joined: 20 Nov 12
Posts: 801
Finland
Message 79814 - Posted: 27 Jul 2017, 16:21:57 UTC - in response to Message 79807.  

You didn't say which one of the various latest versions you downloaded and from where. Looking at the errors it's probably 7.2.42 downloaded from this site.

7.2.42 is built with wxWidgets 2.8. wxWidgets 2.8 and 3.0 are not compatible with each other. A program built with one will not run with libraries from the other. Since Ubuntu 16.04 doesn't have wxWidgets 2.8 in its repositories you will not be able to easily run 7.2.42 on 16.04.

Like Ageless said, on Linux it's easiest to install BOINC from repository.
ID: 79814 · Report as offensive

Message boards : Questions and problems : Linux: doesn't start (standard Ubuntu 16.04 LTS 64 Bit)

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.