Moving BOINC data file folder isn't working

Message boards : Questions and problems : Moving BOINC data file folder isn't working
Message board moderation

To post messages, you must log in.

AuthorMessage
Zeiss Ikon

Send message
Joined: 2 Jul 17
Posts: 36
United States
Message 79438 - Posted: 2 Jul 2017, 19:07:17 UTC

I'm using BOINC 7.6.33 64-bit in Kubuntu 14.04.5 LTS (also 64-bit); I run CPU-only tasks for Milkyway, and GPU-only tasks (on nVidia GTx950 with up to date driver) for Einstein. If it matters, I have a Core2Quad 2.7 GHz with 8 GB RAM, running OS and BOINC from an SSD.

I'm having trouble with disk space availability (again) in my OS partition, which is currently 30 GB, so I'm trying to move the BOINC data folder to another location that has about 30+ GB of free space (and won't tend to fill up if I forget to delete old kernel versions, as my OS partition does). I've followed the instructions here, but now when I start BOINC manager I see a report that there is zero disk used, zero available, and zero storage for both projects. I know the instructions are three years old and for an older version of Ubuntu, but I found all the same folders and files as expected, so I expected this to work.

I used Dolphin with root privilege to move the boinc-client folder to my ~/, where I renamed to ~/.boinc-client, then I edited /etc/default/boinc-client to have BOINC_DIR="/home/myuser/.boinc-client" as instructed. All of this was done with BOINC manager closed from its File menu, with the "stop all tasks" option checked -- but when I start BOINC Manager, now, it has no projects, no tasks, and shows no disk available or used.

What have I done wrong, and how can I fix it?
ID: 79438 · Report as offensive
Juha
Volunteer developer
Volunteer tester
Help desk expert

Send message
Joined: 20 Nov 12
Posts: 801
Finland
Message 79439 - Posted: 2 Jul 2017, 20:14:05 UTC - in response to Message 79438.  

Permissions for /home/myuser probably doesn't allow 'boinc' user any access.

If you really want to have the data directory inside your own home directory you'll need to change /home/myuser to have read and/or execute permissions for others and /home/myuser/.boinc-client read, write and execute permissions for others. Or you could run BOINC under your user account by changing BOINC_USER in /etc/default/boinc-client.

Notice that at some point after 14.04 Ubuntu switched from Upstart to systemd as init system. /etc/default/boinc-client is not used in BOINC's systemd init script.
ID: 79439 · Report as offensive
ProfileAgentb
Avatar

Send message
Joined: 30 May 15
Posts: 265
United Kingdom
Message 79441 - Posted: 2 Jul 2017, 21:41:21 UTC - in response to Message 79438.  

Personally, i'd would return everything back to normal and check working / you haven't broken ownership and permissions. I would not put it in my home directory - for several reasons.

Juha's suggestion in this related thread is how i have done and would do a move.

If you have sudo privs then if the second drive is mounted as /hdd1 then .
# Stop boinc then
cd /var/lib
sudo cp -rp boinc-client /hdd1/boinc-client 
sudo mv boinc-client boinc-backup
sudo ln -s /hdd1/boinc-client

# restart boinc

of course you need to understand what these do and work out a recovery if it goes wrong.

good luck!
ID: 79441 · Report as offensive
Zeiss Ikon

Send message
Joined: 2 Jul 17
Posts: 36
United States
Message 79447 - Posted: 4 Jul 2017, 11:54:51 UTC - in response to Message 79441.  

Agentb, I saw that thread, but didn't try to follow that process because 16.04 doesn't work the same as 14.04 in a number of ways (systemd vs. upstart being a significant change in itself). For space reasons, I must move my BOINC working directories. The partition with my home folder has about 55 GB free; the one with the OS, even after I clear out old kernels, would have no more than about 10 GB, and tends to fill up with frequent kernel updates.

I did correct the ownership and permissions for the folder when I moved it, but I'm not sure how to even tell if BOINC is looking in the right place -- I suspect it's not, because it's reporting that it has zero space for anything.

If I'm understanding your/Juha's method correctly, it's better to put the BOINC data on another hard disk, rather than a different folder or partition on the same physical drive? I don't see how that matters with the way Linux manages filesystems. What I tried first, using GUI tools, is essentially the same process you give above, except I didn't make a backup copy. Making a symlink to the new folder location didn't work; I got the same result I have now (i.e. BOINC reports it has no space, no tasks, and no projects). That was the point where I started the search that led to attempting to alter BOINC configuration files.

The last time I had any major problem with BOINC not working, I wound up having to purge and reinstall; I'm willing to do that now, but since there's no option during installation or setup to put the task storage in a different place, I'll still need to relocate BOINC storage.
ID: 79447 · Report as offensive
Zeiss Ikon

Send message
Joined: 2 Jul 17
Posts: 36
United States
Message 79461 - Posted: 4 Jul 2017, 20:48:21 UTC - in response to Message 79447.  

Okay, problem solved, and with a method that's likely to work for anyone on any version of Linux.

Previous to my original post here, I'd moved the BOINC storage from /var/lib/boinc-client to ~/.boinc-client, and created a symlink replacing /var/lib/boinc-client. It might be that my 14.04 is using systemd; I'm running a 4.4 series kernel (mainly because it seems to be faster than the 3.13 series). However that may be, the method in the link I originally posted for repointing the client to see the new location for its storage hadn't worked; it was still reporting no space available and no tasks.

If you prefer, you could use any storage volume with enough free space in place of ~/ and there's certainly no requirement to hide the storage folder.

To solve this, I purged the boinc meta-package: using synaptic, I marked every installed package that came up in a search for boinc for complete uninstallation. During the process of removing those packages, I was prompted whether to remove the storage folder containing project and task information -- I answered NO.

Once that was done, I took the opportunity to auto-remove many old kernel versions (Ubuntu seems to send kernel updates once a week or more, and doesn't automatically remove them regardless of their age).

After finishing the auto-remove, I reinstalled BOINC using the boinc-client-nvidia-cuda metapackage, and added the boinc-manager metapackage to obtain the GUI controls. Once done, and the system restarted, BOINC Manager reports 50+ GB free (indicating it is using the ~/ storage) and has downloaded new tasks for both of my projects (CPU tasks for Milkyway, and GPU for Einstein). Existing Einstein tasks were preserved.

Now, my BOINC projects are storing their data in a partition that has (relatively) lots of space, and isn't subject to filling up without my noticing (I don't store photos or music on the SSD; they live on a couple platter drives in the same machine). As a bonus, I once again have approximately 15 GB free in the OS partition.
ID: 79461 · Report as offensive

Message boards : Questions and problems : Moving BOINC data file folder isn't working

Copyright © 2024 University of California.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.