Linux version outdated

Message boards : BOINC client : Linux version outdated
Message board moderation

To post messages, you must log in.

AuthorMessage
Kiska

Send message
Joined: 12 Apr 12
Posts: 19
Australia
Message 67423 - Posted: 2 Feb 2016, 2:05:46 UTC

The latest version for download for linux x64 is 7.2.42, which is almost 2 years outdated. And the development version is also about 1 1/2 years outdated. So when will Linux receive the more recent version?
ID: 67423 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14938
Netherlands
Message 67424 - Posted: 2 Feb 2016, 2:14:43 UTC - in response to Message 67423.  

BOINC development doesn't build BOINC anymore. Most package maintainers of the different distros have now added 7.6.22 as recommended on their repositories. And if not 7.6.22, then at least an earlier 7.6

Development halted at the moment wxWidgets 3.0 (a key component of BOINC Manager) got broken and stayed broken on various distros despite updates.
And because the developers are no longer being paid for their work on BOINC -they work elsewhere to pay the bills- I wouldn't expect this to change any time soon either.

So, best check in your distro's repositories for how to install BOINC as a package.
ID: 67424 · Report as offensive
Kiska

Send message
Joined: 12 Apr 12
Posts: 19
Australia
Message 67428 - Posted: 2 Feb 2016, 9:47:30 UTC - in response to Message 67424.  

The problem is that Ubuntu software centre and its repo, is giving me 7.4.23, a developmental build, to me. My Linux distro is Ubuntu 15.04. So is there a guide to build 7.6.22 for Ubuntu available as well as a guide to allow BOINC manager on another computer to access it?
I've already tried with the remote_hosts.cfg file, but it won't let me connect on the same network no less, also I have not made a error on the password, actually the gui_rpc_auth is blank
ID: 67428 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14938
Netherlands
Message 67429 - Posted: 2 Feb 2016, 10:53:44 UTC - in response to Message 67428.  
Last modified: 2 Feb 2016, 10:55:47 UTC

The problem is that Ubuntu software centre and its repo, is giving me 7.4.23, a developmental build

You'll have to ask the package maintainer about that, it's not something I can answer. See at http://packages.ubuntu.com/search?keywords=boinc-client what the present versions are for each Ubuntu distro.

And otherwise you can go for the PPA (personal package archive) from Locutus of Borg, who releases new versions regularly: https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/locutusofborg-ppa.

If it's not available on older Ubuntu versions, it may just not be possible to build it on those versions, or it's running into the wxWidgets bug there.

If you truly want to try to build BOINC for your version of Ubuntu, you can do that from http://boinc.berkeley.edu/trac/wiki/CompileClient#Linux.
ID: 67429 · Report as offensive

Message boards : BOINC client : Linux version outdated

Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.