No usable GPU found

Message boards : GPUs : No usable GPU found
Message board moderation

To post messages, you must log in.


Send message
Joined: 14 Feb 15
Posts: 7
Message 63135 - Posted: 21 Jul 2015, 13:06:38 UTC

Linux, 64 bits (Debian 8.1.0)
AMD Radeon R9 270X

I installed the AMD/Ati last driver from the AMD website. It seems to be correctly installed and seeing my GPU.
Guess what : it doesn't work with boinc (no usable GPU found)

I tried to restart boinc-client once everything is on
Guess what : it doesn't work

I tried to type this command like a monkey typing keys he doesn't understand
xhost local:boinc &> /dev/null
Guess what : typing blind commands NEVER works (or just once and only for 1 machine) and it's always what I'm doing with this never operating system. I'm tired !

I tried to run it as root by modifying the boinc-client script
Guess what : it doesn't work

I tried to type another command :
apt-get install boinc-amd-opencl
It installed a lot of things, but conflicted with files that have been "manually" installed by AMD drivers.
I replaced those files by the ones it was trying to install (if I keep my not working configuration it's not usefull)

My system doesn't start anymore (blinking cursor at the top-left part of the screen)


As always on Linux, everything is delivered not working. As if billions of people tryied to work hard to make it impossible to work the same way on 2 differents machines. Add thousands of distributions and versions of it, apt-get as only chance to get something installed because of librairies conflicting with everything, new ones not working with scary old softwares that cannot be upgraded because they don't work for thousands of the sames reasons.

And here we are :
an huge piece of outdated shit populated by tens of thousands of bugs (more than 80 000).

If only (if only ! it would be a dream) GPU on boinc was the only thing that didn't work. Every year, I try. I never, never never never had a computer fully working on Linux. USB3 missing, sound missing, video driver buggy, going to sleep every 30 seconds on my laptops (know bug on last ubuntu few month ago), cannot be installed on EFI with Windows because apt-get upgrade failed to write correctly the EFI partition - system crashed, nvidia-intel hd 4600, optimus bumblebee etc not working, backlight : not working, and placing a shortcut on the desktop on "MATE" environnement : sometimes the desktop freezes (I had that on several computers)

One year ago, LXDE decided to make huge font size and I realized after typing blind commands as root during 2 days that the only way to change that, was to create a "fake screen" that is defined as bigger as mine by creating new files somewhere on the file system. They told me to install the Nvidia driver but it didn't worked because of the Intel HD card.

Here we are... I'm tired
ID: 63135 · Report as offensive

Send message
Joined: 14 Feb 15
Posts: 7
Message 63227 - Posted: 24 Jul 2015, 15:14:46 UTC

I tried a second time (it seems that I love pain !), only with amd-libopencl1 : then, the problems I had were the "standard problems") and now it's working.

I didn't install the boinc-amd-opencl package because it crashed my computer last time (seriously... sorry for my "hard" words about linux in my previous message, but this kind of thing turn me completely mad ! It's every time...)

But only amd-libopencl1 this time. link was missing so I entered the following command :
ln -s /usr/lib/

And it seems that, even when all this is done, "xhost +si:localuser:boinc" command should be done again at every start, at least before "boinc-client" start.
ID: 63227 · Report as offensive

Message boards : GPUs : No usable GPU found

Copyright © 2024 University of California.
Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.