virtualbox 5.0 not recognized by boinc

Message boards : Questions and problems : virtualbox 5.0 not recognized by boinc
Message board moderation

To post messages, you must log in.

AuthorMessage
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 63004 - Posted: 11 Jul 2015, 15:50:25 UTC

virtualbox 5.0 is very big improvements for the installation and use with linux VM.

Sadly, boinc doesn't recognize the hypervisor so -> hypervisor failed
ID: 63004 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14732
Netherlands
Message 63005 - Posted: 11 Jul 2015, 16:16:48 UTC - in response to Message 63004.  

I will forward the message to higher up, whomever that is these days.

But also know, the old adage on this: "We recommend the VirtualBox version that is included in the recommended BOINC Windows installer, since newer VirtualBox versions do not work correctly for all projects."
ID: 63005 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14732
Netherlands
Message 63006 - Posted: 11 Jul 2015, 16:25:49 UTC

Got answer back from development already.

They have released new VirtualBox wrapper applications for BOINC which do work with VBox 5.0
The project will have to update their wrapper applications.
ID: 63006 · Report as offensive
Rom Walton
Project developer
Avatar

Send message
Joined: 26 Aug 05
Posts: 164
Message 63007 - Posted: 11 Jul 2015, 16:29:00 UTC

I build Vboxwrapper 26169 yesterday, which includes the needed changes to support VirtualBox 5.0.

You can find them here: http://boinc.berkeley.edu/trac/wiki/VboxApps
----- Rom
BOINC Development Team, U.C. Berkeley
My Blog
ID: 63007 · Report as offensive
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 63008 - Posted: 11 Jul 2015, 16:38:24 UTC

really great guys for the ultra-fast reply.
I know that better to work with the virtualbox included but since i need virtualbox also for other VM with XORG server...
as I say virtualbox 5.0 is really a huge improvement for the network drivers installations which don't screw up anymore and also for Xorg virtualization, at least for those two things.

So as users we don't have to do anything? only project as atlas etc have to change their files?
ID: 63008 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14732
Netherlands
Message 63009 - Posted: 11 Jul 2015, 16:43:34 UTC - in response to Message 63008.  

So as users we don't have to do anything? only project as atlas etc have to change their files?

You best notify the affected project(s) that there are problems with the present wrapper applications and that there are better ones available. Not everyone reads the email lists.

But yes, essentially you do not have to download these files, the project will have to incorporate them.
ID: 63009 · Report as offensive
boistordu

Send message
Joined: 8 Jan 12
Posts: 46
Belgium
Message 63010 - Posted: 11 Jul 2015, 19:54:56 UTC - in response to Message 63009.  

thank you very much for your help :)
ID: 63010 · Report as offensive
Crystal Pellet

Send message
Joined: 23 Apr 12
Posts: 40
Netherlands
Message 63014 - Posted: 12 Jul 2015, 13:59:55 UTC - in response to Message 63007.  
Last modified: 12 Jul 2015, 14:17:37 UTC

I build Vboxwrapper 26169 yesterday, which includes the needed changes to support VirtualBox 5.0.

You can find them here: http://boinc.berkeley.edu/trac/wiki/VboxApps

Thanks Rom!

I did a test with combo Win7 64bit, vboxwrapper 26169, VirtualBox 5.0, BOINC 7.4.18 and project VirtualLHC@home.

Result: http://lhcathome2.cern.ch/vLHCathome/result.php?resultid=5043240

Vbox_job.xml:

<vbox_job>
 <os_name>Linux26_64</os_name>
 <memory_size_mb>1024</memory_size_mb>
 <enable_network/>
 <enable_floppyio/>
 <enable_remotedesktop/>
 <enable_cern_dataformat/>
 <job_duration>86400</job_duration>
 <minimum_checkpoint_interval>60</minimum_checkpoint_interval>
 <pf_guest_port>80</pf_guest_port>
 <pf_host_port>7859</pf_host_port>
 <disable_automatic_checkpoints/>
 <enable_vm_savestate_usage/>
</vbox_job> 

I made a manual snapshot in between (task suspended, LAIM off).
Job ran fine and everything cleaned up after the finish.
I've stderr.txt, VBox.log's and VBoxStartup.log available, if interested.
ID: 63014 · Report as offensive
Crystal Pellet

Send message
Joined: 23 Apr 12
Posts: 40
Netherlands
Message 63019 - Posted: 12 Jul 2015, 18:54:08 UTC - in response to Message 63014.  

I did a test with combo Win7 64bit, vboxwrapper 26169, VirtualBox 5.0, BOINC 7.4.18 and project VirtualLHC@home.


Repeated same test with BOINC version 7.6.3.

Result: http://lhcathome2.cern.ch/vLHCathome/result.php?resultid=5044094
ID: 63019 · Report as offensive
Crystal Pellet

Send message
Joined: 23 Apr 12
Posts: 40
Netherlands
Message 63026 - Posted: 13 Jul 2015, 8:37:01 UTC
Last modified: 13 Jul 2015, 8:53:09 UTC

I discovered one issue in my former mentioned setup:

Configuring the VM with 2 cores by adding <avg_ncpus>2.0</avg_ncpus> in the app_config.xml (what was working fine in VBox 4.3.28 with VBoxwrapper 26167) results in:

- VM created with 2 cores
- VM booting
- During boot phase stops somewhere, although VBoxHeadless.exe keeps on running using a full core.
- Not doing real work.

Maybe this message has something to do with it:

00:01:19.883176 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Unknown exception
00:01:19.883176 F:\tinderbox\win-rel\out\win.amd64\release\obj\VBoxAPIWrap\MediumWrap.cpp[2245] (long __cdecl MediumWrap::GetEncryptionSettings(unsigned short **,unsigned short **))}, preserve=false aResultDetail=0


My own Linux-VM with 4 cores on my Windows host is running fine with VirtualBox 5.0, like the projects VM with 1 core is doing OK too.
ID: 63026 · Report as offensive
Rom Walton
Project developer
Avatar

Send message
Joined: 26 Aug 05
Posts: 164
Message 63029 - Posted: 13 Jul 2015, 17:29:44 UTC - in response to Message 63026.  

I discovered one issue in my former mentioned setup:

Configuring the VM with 2 cores by adding 2.0 in the app_config.xml (what was working fine in VBox 4.3.28 with VBoxwrapper 26167) results in:

- VM created with 2 cores
- VM booting
- During boot phase stops somewhere, although VBoxHeadless.exe keeps on running using a full core.
- Not doing real work.

Maybe this message has something to do with it:

00:01:19.883176 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={4afe423b-43e0-e9d0-82e8-ceb307940dda} aComponent={MediumWrap} aText={Unknown exception
00:01:19.883176 F:\tinderbox\win-rel\out\win.amd64\release\obj\VBoxAPIWrap\MediumWrap.cpp[2245] (long __cdecl MediumWrap::GetEncryptionSettings(unsigned short **,unsigned short **))}, preserve=false aResultDetail=0


My own Linux-VM with 4 cores on my Windows host is running fine with VirtualBox 5.0, like the projects VM with 1 core is doing OK too.


Does that always happen when a new job is received? Or only after restoring from a checkpoint?
----- Rom
BOINC Development Team, U.C. Berkeley
My Blog
ID: 63029 · Report as offensive
Crystal Pellet

Send message
Joined: 23 Apr 12
Posts: 40
Netherlands
Message 63034 - Posted: 14 Jul 2015, 7:27:34 UTC - in response to Message 63029.  

I discovered one issue in my former mentioned setup:
..
..
..

Does that always happen when a new job is received? Or only after restoring from a checkpoint?

With every new BOINC-task received and app_config configured as described, the 2-core VM is created and booting, but unusable.
Checkpoints (I suppose in this case you mean snapshots) aren't made.

Selected 2 of those problem tasks returned by ending gracefully:
http://lhcathome2.cern.ch/vLHCathome/result.php?resultid=5044490
http://lhcathome2.cern.ch/vLHCathome/result.php?resultid=5045098
ID: 63034 · Report as offensive

Message boards : Questions and problems : virtualbox 5.0 not recognized by boinc

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.