List of project for Mac with AMD GPU

Message boards : Projects : List of project for Mac with AMD GPU
Message board moderation

To post messages, you must log in.

AuthorMessage
Nikolay

Send message
Joined: 9 Jan 12
Posts: 8
Russia
Message 41999 - Posted: 10 Jan 2012, 16:57:08 UTC
Last modified: 10 Jan 2012, 16:57:40 UTC

Somebody, could you make the list of projects for Mac with AMD GPU, please? I am really confused.
ID: 41999 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14938
Netherlands
Message 42000 - Posted: 10 Jan 2012, 17:38:00 UTC - in response to Message 41999.  
Last modified: 10 Jan 2012, 17:38:07 UTC

There's one in this FAQ for CAL + CUDA and in this FAQ for OpenCL.

(I just added to them, can use plenty more).
(What was that rumor of WCG having a GPU app?)
ID: 42000 · Report as offensive
Claggy

Send message
Joined: 23 Apr 07
Posts: 1112
United Kingdom
Message 42001 - Posted: 10 Jan 2012, 17:43:15 UTC - in response to Message 42000.  
Last modified: 10 Jan 2012, 17:46:22 UTC

Collatz has added a MAC OS X OpenCL Application in the last few days:

MAC OS X OpenCL Application Added

Claggy
ID: 42001 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14938
Netherlands
Message 42002 - Posted: 10 Jan 2012, 18:09:45 UTC - in response to Message 42001.  

Yes, Collatz was already in the list, in both FAQs.
ID: 42002 · Report as offensive
Profile Gundolf Jahn

Send message
Joined: 20 Dec 07
Posts: 1069
Germany
Message 42003 - Posted: 10 Jan 2012, 20:27:21 UTC - in response to Message 41999.  

Here's a list for 64bit AMDs.

Gruß,
Gundolf
ID: 42003 · Report as offensive
Nikolay

Send message
Joined: 9 Jan 12
Posts: 8
Russia
Message 42052 - Posted: 13 Jan 2012, 18:35:12 UTC - in response to Message 42003.  

Here's a list for 64bit AMDs.

Gruß,
Gundolf


I meant AMD GPU, not AMD64 system.
ID: 42052 · Report as offensive
Profile Gundolf Jahn

Send message
Joined: 20 Dec 07
Posts: 1069
Germany
Message 42053 - Posted: 13 Jan 2012, 19:06:12 UTC - in response to Message 42052.  

I meant AMD GPU, not AMD64 system.

Ah yes, didn't wear my glasses ;-)

Gruß,
Gundolf
ID: 42053 · Report as offensive
Nikolay

Send message
Joined: 9 Jan 12
Posts: 8
Russia
Message 42057 - Posted: 13 Jan 2012, 20:34:58 UTC
Last modified: 13 Jan 2012, 20:44:19 UTC

Albert@Home (Einstein test project) **
Seti@Home * (through 3rd party Lunatics apps)
Seti Beta *
Milkyway@Home **
Collatz Conjecture **
POEM

* Windows only, Linux and Macintosh require 3rd party applications or are not available.
** Macintosh GPU apps available.


So, there are only the following projects are available for GPU computing on a Mac:

Albert@Home (Einstein test project)
Milkyway@Home
Collatz Conjecture


1) Albert@Home is not working because of the bug :
http://albert.phys.uwm.edu/forum_thread.php?id=8854#111583

A fix is already available and should be part of the next release (i.e. 7.0.8).

Cheers,
Oliver (project administrator and developer)


2) Milkyway@Home does not work because my GPU (AMD HD 6750M) is single precision.

3) Collatz Conjecture is working!
However, it has a bug with "Resume": if you will suspend the running project and then resume,
it will restart from the beginning 0.000% if it was not far enough (less than 1-2%), or
will go to 100% and upload a false result (if computed more than 1-2%) !

Conclusion:
1) Albert@Home can't be used until the release of BOINC v7.08.
2) Milkyway@Home can't be used until it would be programmed to make use of single-precision GPUs.
As you know, most GPUs have only single precision, and the same thing with most (if not all) Macs.
3) Currently, the only way of using Mac AMD GPU for distributed computing is
to run Collatz Conjecture without resuming a project.
ID: 42057 · Report as offensive
Claggy

Send message
Joined: 23 Apr 07
Posts: 1112
United Kingdom
Message 42058 - Posted: 13 Jan 2012, 20:58:26 UTC - in response to Message 42057.  

PrimeGrid also has a Mac OS 10.5+ ATI app:

PrimeGrid Applications

Claggy
ID: 42058 · Report as offensive
Nikolay

Send message
Joined: 9 Jan 12
Posts: 8
Russia
Message 42059 - Posted: 13 Jan 2012, 21:05:31 UTC - in response to Message 42058.  

PrimeGrid also has a Mac OS 10.5+ ATI app:

PrimeGrid Applications

Claggy


PrimeGrid does not want to give me a GPU work unit, despite my computer meet all the requirements
(Mac OS 10.7, 64-bit Intel CPU, ATI/AMD GPU with OpenCL support)
ID: 42059 · Report as offensive
Claggy

Send message
Joined: 23 Apr 07
Posts: 1112
United Kingdom
Message 42061 - Posted: 13 Jan 2012, 21:38:25 UTC - in response to Message 42059.  
Last modified: 13 Jan 2012, 21:39:57 UTC

PrimeGrid also has a Mac OS 10.5+ ATI app:

PrimeGrid Applications

Claggy


PrimeGrid does not want to give me a GPU work unit, despite my computer meet all the requirements
(Mac OS 10.7, 64-bit Intel CPU, ATI/AMD GPU with OpenCL support)

First try setting your PrimeGrid Preferences to only ask for ATI GPU work, and make sure that Proth Prime Search (Sieve) is selected in the AMD (ATI) column.

Claggy
ID: 42061 · Report as offensive
Nikolay

Send message
Joined: 9 Jan 12
Posts: 8
Russia
Message 42069 - Posted: 14 Jan 2012, 12:37:05 UTC - in response to Message 42061.  
Last modified: 14 Jan 2012, 12:39:13 UTC

Proth Prime Search (Sieve)
The Winter Solstice Challenge project

Supported platforms:
Windows: 32bit, 64bit (+CUDA23, AMD OpenCL*)
Linux: 32bit, 64bit (+CUDA23, AMD OpenCL*)
Mac: 32bit, 64bit (+CUDA32, AMD OpenCL* - 64 bit only)

* Requires AMD Accelerated Parallel Processing (APP) drivers:
http://support.amd.com/us/gpudownload/Pages/index.aspx
If APP driver not available for your card, then the ATI Stream SDK is needed:
http://developer.amd.com/gpu/ATIStreamSDK/Pages/default.aspx


Neither APP driver, nor ATI Stream SDK are available for Mac - only for Windows and Linux!
Because I don't have them, PrimeGrid does not want to give me a task =(
ID: 42069 · Report as offensive
Claggy

Send message
Joined: 23 Apr 07
Posts: 1112
United Kingdom
Message 42070 - Posted: 14 Jan 2012, 13:40:29 UTC - in response to Message 42069.  
Last modified: 14 Jan 2012, 13:55:36 UTC

Proth Prime Search (Sieve)
The Winter Solstice Challenge project

Supported platforms:
Windows: 32bit, 64bit (+CUDA23, AMD OpenCL*)
Linux: 32bit, 64bit (+CUDA23, AMD OpenCL*)
Mac: 32bit, 64bit (+CUDA32, AMD OpenCL* - 64 bit only)

* Requires AMD Accelerated Parallel Processing (APP) drivers:
http://support.amd.com/us/gpudownload/Pages/index.aspx
If APP driver not available for your card, then the ATI Stream SDK is needed:
http://developer.amd.com/gpu/ATIStreamSDK/Pages/default.aspx


Neither APP driver, nor ATI Stream SDK are available for Mac - only for Windows and Linux!
Because I don't have them, PrimeGrid does not want to give me a task =(

The APP and ATI Steam SDK are only to enable ATI OpenCL support on Windows and Linux, Apple has already enabled OpenCL support on your GPU,
PrimeGrid's Server can't tell if hosts running Boinc 6.12.x and earlier have the APP drivers or SDK installed as they don't have code to look for OpenCL support, it should issue work anyway wether or not they are installed,
Look my i7-2600K/GTX460/HD5770 gets ATI OpenCL tasks with only Boinc 6.10.58,

If after you're edited you're preferences you still don't get work, then ask at PrimeGrid for a suitable app_info, that should bypass any server requirements, or get the project to tweak their server so it does issue work.

Claggy
ID: 42070 · Report as offensive
Nikolay

Send message
Joined: 9 Jan 12
Posts: 8
Russia
Message 42130 - Posted: 18 Jan 2012, 13:47:59 UTC

Albert@Home is finally working!

(BOINC version is 7.0.11)
(get the latest version here: http://boinc.berkeley.edu/dl/)
ID: 42130 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14938
Netherlands
Message 42131 - Posted: 18 Jan 2012, 14:11:28 UTC - in response to Message 42130.  
Last modified: 18 Jan 2012, 14:22:40 UTC

Now, no need to spam the forums with that link and also a warning that the 7.0.11 version is not a recommended one, but a development version. There will be other versions coming, before the 7 range will become recommended.

We normally wait with announcing the version until a couple of days have passed. This so the BOINC developer can test his own ideas and/or have people privately test the new version.
ID: 42131 · Report as offensive
Profile Blurf

Send message
Joined: 18 Jul 11
Posts: 217
United States
Message 42140 - Posted: 18 Jan 2012, 19:56:57 UTC

Maybe someone (DA?) should talk to the POEM folks for requiring people use a non-standard version of Boinc if they want to crunch their new GPU WU's.
ID: 42140 · Report as offensive

Message boards : Projects : List of project for Mac with AMD GPU

Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.