HTTP error 0 with World Community Grid and BOINC 6.12.34

Message boards : Questions and problems : HTTP error 0 with World Community Grid and BOINC 6.12.34
Message board moderation

To post messages, you must log in.

1 · 2 · Next

AuthorMessage
darkpella

Send message
Joined: 24 Mar 06
Posts: 20
Italy
Message 40218 - Posted: 17 Sep 2011, 8:30:50 UTC

Hi,

as reported in this message on WCG forums , my host, with BOINC 6.12.34 installed, can't connect to WCG, every communication attempt resulting in a "HTTP error 0" message.

I tried uninstalling BOINC 6.12.34 and reverting to BOINC 6.10.60 and everything with WCG went back OK.

Then I uninstalled BOINC 6.10.60 and reinstalled 6.12.34 and the issue reappeared.

I also tried with BOINC 6.13.1 (beta) but this didn't fix the issue.

Currently, I reverted once again to 6.10.60, but it looks like the issue is related to BOINC 6.12.34, WCG and (possibly) the way I communicate to the Internet, though I tried with my standard Internet proxy and TOR, none of which gives me problems with other projects.
Also, I don't get any such issue with other BOINC-projects while running BOINC 6.12.34.

I posted this message on WCG forums as well

Bye

darkpella
ID: 40218 · Report as offensive
sylvain

Send message
Joined: 19 Sep 11
Posts: 1
French Polynesia
Message 40257 - Posted: 19 Sep 2011, 23:56:17 UTC - in response to Message 40218.  

Hello,
i have the same problem !

ID: 40257 · Report as offensive
oxley

Send message
Joined: 8 Feb 09
Posts: 6
Czech Republic
Message 40276 - Posted: 21 Sep 2011, 10:15:30 UTC - in response to Message 40257.  

Any news to fix this issue ? I have bunch of tasks done only waiting to be sent... If i downgrade to 6.10.60 then i cannot see any tasks in my system at all. So it doesn't work. And 6.13.1 doesn't fix this issue.
ID: 40276 · Report as offensive
Profile Jord
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 29 Aug 05
Posts: 13466
Netherlands
Message 40451 - Posted: 29 Sep 2011, 17:41:53 UTC

Can anyone who ran into this problem with 6.12.34 test if 6.12.38 is still doing it? Available for Linux, Windows and Mac at this download list.
Please do not private message me for tech support, these will be ignored!

Do as I say, don't do as I do.
ID: 40451 · Report as offensive
darkpella

Send message
Joined: 24 Mar 06
Posts: 20
Italy
Message 40645 - Posted: 12 Oct 2011, 6:44:04 UTC - in response to Message 40284.  

If i downgrade to 6.10.60 then i cannot see any tasks in my system at all. So it doesn't work. And 6.13.1 doesn't fix this issue.


That proves 6.13. works as it should. It's changed your client_state.xml file exactly as it says it will in INCOMPATIBILITY WARNING FOR UPCOMING 6.13 BUILDS thread.

As for the "HTTP error 0 with World Community Grid and BOINC 6.12.34" problem, the solution is posted here on the WCG forums.


Don't know whether reverting to 6.12.33 can be taken as a solution overall, anything starting form 6.12.34 won't simply work with WCG and proxies.

darkpella
ID: 40645 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 43538 - Posted: 16 Apr 2012, 9:21:44 UTC - in response to Message 40645.  

ive just upgraded to 7.0.25, after having to stay on 6.12.33 to get comms, this version seems to have the same problem any fixes?
ID: 43538 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 3658
United Kingdom
Message 43541 - Posted: 16 Apr 2012, 9:56:16 UTC - in response to Message 43538.  

ive just upgraded to 7.0.25, after having to stay on 6.12.33 to get comms, this version seems to have the same problem any fixes?

An apparently successful workround is posted at

https://secure.worldcommunitygrid.org/forums/wcg/printpost_post,372940
ID: 43541 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 43561 - Posted: 17 Apr 2012, 12:26:18 UTC - in response to Message 43541.  

just tried it and it doesnt work:

17/04/2012 13:26:39 | | Project communication failed: attempting access to reference site

17/04/2012 13:26:39 | World Community Grid | Scheduler request failed: Failure when receiving data from the peer

17/04/2012 13:26:59 | | BOINC can't access Internet - check network connection or proxy configuration.

ID: 43561 · Report as offensive
Profile Jord
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 29 Aug 05
Posts: 13466
Netherlands
Message 43563 - Posted: 17 Apr 2012, 12:33:55 UTC - in response to Message 43561.  
Last modified: 17 Apr 2012, 14:26:20 UTC

A couple of problems with the post at WCG:

1. It doesn't say for instance that you need to exit BOINC (BOINC Manager->Advanced view->File->Exit, check "Quit running tasks when exiting the Manager" (or similar words)->OK).
2. It also doesn't say that the file you're downloading is a ZIP archive file, a compressed file which needs to be decompressed before the file inside the archive is available for use. BOINC won't unzip it for you.

So, did you just drop the *.zip file in your BOINC programs directory and hoped for the best, or did you use WinZip, WinRAR, 7-zip or Windows its own archive decompresser, to get a file called libcurl.dll out of the archive and did you put that one in the BOINC programs directory, overwriting the original one?

The default directory where BOINC will install its executables to is:
Windows 32bit: C:\PROGRAM FILES\BOINC\
Windows 64bit: C:\PROGRAM FILES (x86)\BOINC\
Linux: wherever you are unpacking it/BOINC/
Macintosh: /Applications/BOINC/

After you're done, restart BOINC (Windows: Start->(All) Programs->BOINC->BOINC Manager).
Please do not private message me for tech support, these will be ignored!

Do as I say, don't do as I do.
ID: 43563 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 43622 - Posted: 20 Apr 2012, 11:56:23 UTC - in response to Message 43563.  

hello.

i exited boinc closing tasks i then unzipped the new dll and replaced it. i then restarted the machine just for good measure.
ID: 43622 · Report as offensive
Profile Jord
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 29 Aug 05
Posts: 13466
Netherlands
Message 43625 - Posted: 20 Apr 2012, 12:32:20 UTC - in response to Message 43622.  

Update to 7.0.26, links available from the last post in the change log thread.
Please do not private message me for tech support, these will be ignored!

Do as I say, don't do as I do.
ID: 43625 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 44048 - Posted: 8 May 2012, 13:45:51 UTC

tried 7.0.26 and got the same problem. were using microsoft TMG and websense. if i knew which ip/web address boinc was trying to access the world community servers with, i could check our filter.
ID: 44048 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 44214 - Posted: 21 May 2012, 11:15:19 UTC - in response to Message 44048.  
Last modified: 21 May 2012, 11:17:26 UTC

any ideas? or should i go back to the old client 6.12.33?

p.s. ive 7.0.27 and same problem. is it a change in the way boinc authenticates with proxies?
ID: 44214 · Report as offensive
Profile Jord
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 29 Aug 05
Posts: 13466
Netherlands
Message 44215 - Posted: 21 May 2012, 12:31:45 UTC - in response to Message 44214.  

There is no change between BOINC 6.12 and 7.0 on how to communicate with proxies. However, 7.0.27 does use the newer libCurl.

In any case, we have too little information to be able to help you. You could try to run with the and tags in cc_config.xml
Or just try to force authentication through the same cc-config.xml file, with the basic | digest | gss-negotiate | ntlm tag.

Example given:
<cc_config>
<log_flags>
<http_debug>1</http_debug>
<http_xfer_debug>1</http_xfer_debug>
</log_flags>
<options>
<force_auth>ntlm</force_auth>
</options>
</cc_config>

Please do not private message me for tech support, these will be ignored!

Do as I say, don't do as I do.
ID: 44215 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 44217 - Posted: 21 May 2012, 13:39:58 UTC - in response to Message 44215.  

where does the output go?
ID: 44217 · Report as offensive
Profile Jord
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 29 Aug 05
Posts: 13466
Netherlands
Message 44218 - Posted: 21 May 2012, 13:44:46 UTC - in response to Message 44217.  

In the Event Log (CTRL+SHIFT+E), and stdoutdae.txt in the data directory.
Please do not private message me for tech support, these will be ignored!

Do as I say, don't do as I do.
ID: 44218 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 44219 - Posted: 21 May 2012, 13:48:42 UTC - in response to Message 44218.  
Last modified: 21 May 2012, 13:50:02 UTC

ill send this as a pm.
ID: 44219 · Report as offensive
Profile Jord
Volunteer moderator
Project administrator
Avatar

Send message
Joined: 29 Aug 05
Posts: 13466
Netherlands
Message 44220 - Posted: 21 May 2012, 14:06:41 UTC - in response to Message 44219.  

The example cc_config.xml I gave was really an example. You will have to change the authentication forcing if it uses something different than NTLM.
As now you end at:
21-May-2012 14:38:51 [World Community Grid] [http] [ID#1] Received header from server: HTTP/1.1 407 Proxy Authentication Required ( Access is denied. )


If not sure, don't use authentication forcing:
<cc_config>
<log_flags>
<http_debug>1</http_debug>
<http_xfer_debug>1</http_xfer_debug>
</log_flags>
<options>
</options>
</cc_config>


As stated in the log, WCG lives at 172.16.222.51
WCG uses a HTTPS address which requires that TCP port 443 is accessible.


Please do not private message me for tech support, these will be ignored!

Do as I say, don't do as I do.
ID: 44220 · Report as offensive
Adam

Send message
Joined: 16 Sep 06
Posts: 13
United Kingdom
Message 44221 - Posted: 21 May 2012, 14:29:11 UTC - in response to Message 44220.  

our system does use NTLM.
ID: 44221 · Report as offensive
1 · 2 · Next

Message boards : Questions and problems : HTTP error 0 with World Community Grid and BOINC 6.12.34

Copyright © 2020 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.