"error:1402 could not open key...

Message boards : Questions and problems : "error:1402 could not open key...
Message board moderation

To post messages, you must log in.

AuthorMessage
stuart patterson

Send message
Joined: 22 Oct 08
Posts: 1
United Kingdom
Message 20925 - Posted: 22 Oct 2008, 18:21:22 UTC

...HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Run. Verify that you have sufficient access to that key, or contact your support personnel"

i get this message half way through installing boinc.

does this mean i have an older version installed or what? because i dont think i do. :S
ID: 20925 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 15068
Netherlands
Message 20927 - Posted: 22 Oct 2008, 19:15:05 UTC - in response to Message 20925.  
Last modified: 22 Oct 2008, 19:15:43 UTC

It may mean you have an older version installed, but it's not necessarily that (do check in Add/Remove programs if you have something called BOINC installed. If you do, uninstall it). Looking around the web it's a permission problem.

So, open the registry with regedit. (Start->Run, type regedit, click OK)
Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows/CurrentVersion/Run and right click on it, select permissions.
In the window that now opens, make sure your account name is in there and that it has full rights.
Go to the Advanced button and uncheck the "Inherit from parent." option. Click OK.
In the top box called 'Group or User names' it needs to list both Administrators and System and they both need to be given 'full control'. Add or change the groups as needed. Don't change any other groups that may be listed.

When that's done, close regedit.
Try to install again.
ID: 20927 · Report as offensive

Message boards : Questions and problems : "error:1402 could not open key...

Copyright © 2022 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.