Screen saver graphics not running

Message boards : BOINC client : Screen saver graphics not running
Message board moderation

To post messages, you must log in.

AuthorMessage
UpstateLabs
Avatar

Send message
Joined: 17 Dec 07
Posts: 20
United States
Message 14390 - Posted: 17 Dec 2007, 17:40:16 UTC

Since I upgraded to Boinc 5.10.28 the graphics of my projects do not display. All I get is a %progress message in place of the regular graphics. Can anyone tell me if there is something I'm doing wrong, or if this is a problem that has a fix, or what? The graphics work fine if I view them through the BOINC manager.

Thanks much!
ID: 14390 · Report as offensive
AKuzmenkoUA

Send message
Joined: 25 Dec 07
Posts: 2
Ukraine
Message 14517 - Posted: 25 Dec 2007, 12:54:26 UTC

I have exactly the same problem. Anyone can help?
ID: 14517 · Report as offensive
AKuzmenkoUA

Send message
Joined: 25 Dec 07
Posts: 2
Ukraine
Message 14518 - Posted: 25 Dec 2007, 13:13:06 UTC

Turning off the password helped. But why? How it can be overcome?
ID: 14518 · Report as offensive
UpstateLabs
Avatar

Send message
Joined: 17 Dec 07
Posts: 20
United States
Message 14522 - Posted: 26 Dec 2007, 3:21:22 UTC - in response to Message 14518.  

Turning off the password helped. But why? How it can be overcome?


Yes this works for me too, but I can't keep it this way, I need the password protection kept on. Is there another setting that can be adjusted, or perhaps a fix is in the works? It's alot less fun without the graphics.
ID: 14522 · Report as offensive
Aurora Borealis
Avatar

Send message
Joined: 8 Jan 06
Posts: 448
Canada
Message 14523 - Posted: 26 Dec 2007, 7:33:39 UTC - in response to Message 14522.  

Turning off the password helped. But why? How it can be overcome?


Yes this works for me too, but I can't keep it this way, I need the password protection kept on. Is there another setting that can be adjusted, or perhaps a fix is in the works? It's alot less fun without the graphics.

There may be a fix in Boinc V6 which will be able to handle graphics in a different way and allow the projects to have the screensaver as a separate process from the science application.
ID: 14523 · Report as offensive
Kage_

Send message
Joined: 27 Dec 07
Posts: 4
United States
Message 14549 - Posted: 27 Dec 2007, 19:14:29 UTC
Last modified: 27 Dec 2007, 19:14:41 UTC

I upgraded from 5.10.20 to .30 and lost the graphics. I'm on a domain machine with the password forced so no option to turn it off. .30 works great at home. Why the change. If I had the .20 installer I would go back just to have the graphics again.
ID: 14549 · Report as offensive
UpstateLabs
Avatar

Send message
Joined: 17 Dec 07
Posts: 20
United States
Message 14550 - Posted: 27 Dec 2007, 19:33:13 UTC - in response to Message 14549.  

I upgraded from 5.10.20 to .30 and lost the graphics. I'm on a domain machine with the password forced so no option to turn it off. .30 works great at home. Why the change. If I had the .20 installer I would go back just to have the graphics again.


Yeah, I'm in a similar situation, and I'm kicking myself for deleting my copy of the old installer. I'd go back. I'm not sure what improvements were made, but for myself, I haven't noticed anything good enough to compensate for what has been lost.

And in reference to a previous post, I wonder why a whole step up version is needed to bring back graphics. It didn't take a whole step up to lose them. I went from 5.10.13 to 5.10.28. Clearly in .29 and .30 the situation hasn't been rectified. Since this is an issue affecting LOTS of users, couldn't a fix come sooner, rather than later?

ID: 14550 · Report as offensive
Les Bayliss
Help desk expert

Send message
Joined: 25 Nov 05
Posts: 1504
Australia
Message 14551 - Posted: 27 Dec 2007, 21:07:40 UTC - in response to Message 14550.  
Last modified: 27 Dec 2007, 21:08:28 UTC

And in reference to a previous post, I wonder why a whole step up version is needed to bring back graphics. It didn't take a whole step up to lose them. I went from 5.10.13 to 5.10.28. Clearly in .29 and .30 the situation hasn't been rectified. Since this is an issue affecting LOTS of users, couldn't a fix come sooner, rather than later?


The 'step up' version is needed because of the way Windows changed when they went from Xp to Vista. While they're at it, it was decided to separate the graphics to avoid the sort of problems some people are/were getting with various earlier versions, some going back to 4.*

The few people doing the programming are not going to spend what time they have fiddling with the 5.* version when they can be spending that time on 6.*
ID: 14551 · Report as offensive
UpstateLabs
Avatar

Send message
Joined: 17 Dec 07
Posts: 20
United States
Message 14555 - Posted: 28 Dec 2007, 12:04:11 UTC - in response to Message 14551.  
Last modified: 28 Dec 2007, 12:04:41 UTC


The 'step up' version is needed because of the way Windows changed when they went from Xp to Vista. While they're at it, it was decided to separate the graphics to avoid the sort of problems some people are/were getting with various earlier versions, some going back to 4.*

The few people doing the programming are not going to spend what time they have fiddling with the 5.* version when they can be spending that time on 6.*


No wonder people complain about vista... it even screws up computers running a different OS!! :)

Seriously, though, any idea how long we'll have to wait for a fix?
ID: 14555 · Report as offensive
MikeMarsUK

Send message
Joined: 16 Apr 06
Posts: 386
United Kingdom
Message 14556 - Posted: 28 Dec 2007, 12:16:54 UTC


Version 6. No idea when that's due to be out, it's not even at the 'alpha' stage at the moment.

ID: 14556 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14682
Netherlands
Message 14557 - Posted: 28 Dec 2007, 12:27:08 UTC - in response to Message 14556.  
Last modified: 28 Dec 2007, 12:27:59 UTC

We can test 6.1.5 if we want, but it doesn't do graphics at all. So none of the above should even try to run 6 at this time.

I am back at running 5.10.30 and I have graphics and a screen saver (if I want to). So it can also be something on your system. Or just run without the password protect option on the screen saver. That's bound to give problems (always has).
ID: 14557 · Report as offensive
UpstateLabs
Avatar

Send message
Joined: 17 Dec 07
Posts: 20
United States
Message 14562 - Posted: 29 Dec 2007, 15:31:14 UTC - in response to Message 14557.  

I am back at running 5.10.30 and I have graphics and a screen saver (if I want to). So it can also be something on your system. Or just run without the password protect option on the screen saver. That's bound to give problems (always has).


Well I don't have the option of running w/o password protection. I'm sure I'm not the only user in my situation.

And as far as my systems are concerned, they worked with BOINC project graphics just fine before I updated to 5.10.28. Now, I suppose that I might need to upgrade something else. After reading some of the other threads on this topic, I did update my DirectX but that helped not one bit. As far as graphics drivers, should that really matter? I mean, as I said, it worked before, and I didn't change anything else.

I'm not trying to be a complainer, but I'm not a complete novice, and I don't think my systems have anything to do with this problem.
ID: 14562 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14682
Netherlands
Message 14566 - Posted: 29 Dec 2007, 17:21:47 UTC - in response to Message 14562.  
Last modified: 3 Jan 2008, 16:12:27 UTC

I'm not trying to be a complainer, but I'm not a complete novice, and I don't think my systems have anything to do with this problem.

Please, complain all you want. :-)
That's what the forums are for.

I'll ask Rom if something changed in the graphics part of BOINC, and otherwise if something changed in regards to the protected screen saver mode. Question from Rom: Does it at least show the BOINC screen saver, with the bouncing logo going around the screen?

If it does, then that's the best the developers can do for now. Windows had some changes in this department, some security updates that fixed a Windows problem but broke the protected screen saver option.

If you use an older version of BOINC where it still works, then this is a bug. It shouldn't work on any version of BOINC, but the weirdness of that bug makes it work on some computers, while others only show a black screen.

BOINC 6 will fix all that with version 6 applications.
ID: 14566 · Report as offensive
UpstateLabs
Avatar

Send message
Joined: 17 Dec 07
Posts: 20
United States
Message 14591 - Posted: 31 Dec 2007, 13:00:11 UTC - in response to Message 14566.  

Question from Rom: Does it at least show the BOINC screen saver, with the bouncing logo going around the screen? <Yes>

If you do, then that's the best the developers can do for now. Windows had some changes in this department, some security updates that fixed a Windows problem but broke the protected screen saver option.

If you use an older version of BOINC where it still works, then this is a bug. It shouldn't work on any version of BOINC, but the weirdness of that bug makes it work on some computers, while others only show a black screen.

BOINC 6 will fix all that with version 6 applications.



Thanks for the explanation; it's a little bizarre, but I'll accept that.

I'll be eagerly awaiting BOINC 6!!

ID: 14591 · Report as offensive
Anool

Send message
Joined: 1 Jan 08
Posts: 1
India
Message 14595 - Posted: 1 Jan 2008, 10:27:36 UTC

I had the same problem. I downgraded to Ver 5.10.27, just so that I have password enabled on resume, and it works fine now. Older versions of BOINC available at this link : http://boinc.berkeley.edu/dl/

I'm now waiting for Version 6.

Anool
ID: 14595 · Report as offensive

Message boards : BOINC client : Screen saver graphics not running

Copyright © 2021 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.