Client not working after update

Message boards : BOINC client : Client not working after update
Message board moderation

To post messages, you must log in.

AuthorMessage
derchris

Send message
Joined: 4 Apr 07
Posts: 3
Message 9350 - Posted: 4 Apr 2007, 21:11:23 UTC

Hi,

I updated my Linux client from 5.8.11 to 5.8.17.
But now it is not running anymore.
I get the following error:

./boinc: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by ./boinc)
./boinc: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4' not found (required by ./boinc)
./boinc: /usr/lib/libstdc++.so.6: version `CXXABI_1.3' not found (required by ./boinc)

Was there a change in the program, because .11 was working ok.
ID: 9350 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 13685
Netherlands
Message 9351 - Posted: 4 Apr 2007, 21:27:51 UTC

The version details say specifically:

Boincmgr requires GTK++2.0 and glibc 2.4 (libc) or higher which are included in recent Linux distributions. Its been tested on:

* Fedora Core 5 (with updates)
* SUSE 10.1
* Ubuntu 6.10

Glibc 2.5 for download.
Please do not private message me for tech support, these will be ignored!
ID: 9351 · Report as offensive
Nicolas

Send message
Joined: 19 Jan 07
Posts: 1174
Argentina
Message 9352 - Posted: 4 Apr 2007, 22:35:26 UTC

Yes there was a change. A more recent version of the gcc compiler is used, getting better optimizations and in turn more accurate benchmarks. By default it uses glibc 2.4. I think it's possible, but not so easy, for the developers to use a new compiler with an older glibc. I was unable to install 5.8.17 on Ubuntu Dapper, which is Ubuntu's "Long Term Support" version; I guess a lot of people run that version. So I suggested going at least one version back, that is, using glibc 2.3 on BOINC.

Meanwhile, you could try out BOINC 5.8.16 (packages for all versions can be found on http://boinc.berkeley.edu/dl/). I think it would be far easier than trying to get a newer glibc working on your system...
ID: 9352 · Report as offensive
derchris

Send message
Joined: 4 Apr 07
Posts: 3
Message 9380 - Posted: 5 Apr 2007, 18:14:31 UTC - in response to Message 9352.  

Yes there was a change. A more recent version of the gcc compiler is used, getting better optimizations and in turn more accurate benchmarks. By default it uses glibc 2.4. I think it's possible, but not so easy, for the developers to use a new compiler with an older glibc. I was unable to install 5.8.17 on Ubuntu Dapper, which is Ubuntu's "Long Term Support" version; I guess a lot of people run that version. So I suggested going at least one version back, that is, using glibc 2.3 on BOINC.

Meanwhile, you could try out BOINC 5.8.16 (packages for all versions can be found on http://boinc.berkeley.edu/dl/). I think it would be far easier than trying to get a newer glibc working on your system...


Yeah, I think so.
I downloaded glibc 2.5, and during configure it told me that I should'n installed into /usr/local.
So I read the FAQ and choose /usr/local/glibc2.
It is compiled, however the current version of boinc still won't start.
But two of the error messages are now gone.
The only one left is:

./boinc: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by ./boinc)

I have the libc.so.6 in /usr/local/lib/glibc2/lib
How can I tell boinc to use it, the version in /lib/tls is the old 2.3 one, and I don't want to overwrite it.

If there is no other way, I will try to use the version you mentioned.
ID: 9380 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 13685
Netherlands
Message 9381 - Posted: 5 Apr 2007, 18:27:45 UTC - in response to Message 9380.  

I have the libc.so.6 in /usr/local/lib/glibc2/lib
How can I tell boinc to use it, the version in /lib/tls is the old 2.3 one, and I don't want to overwrite it.

Why not? All new versions have got backward compatibility. Unlike old versions having forward compatibility. ;-)

If there is no other way, I will try to use the version you mentioned.

We're testing 5.9.3 now on all OSes. When 5.10.x comes out after this, you'll be stuck on an older version. Some projects may want to make 5.10.x their minimum version.

I know it's a pain to need to install new drivers on Linux, but sometimes it's just necessary. And the BOINC developers try to use newer versions of drivers and such as little as possible. It was just that the compiler they use needed it.

Basically you should be able to find the newer version of glibc on your distribution's repository. You should be able to upgrade it using your normal installation or upgrade procedures for your Linux distribution.
Please do not private message me for tech support, these will be ignored!
ID: 9381 · Report as offensive
derchris

Send message
Joined: 4 Apr 07
Posts: 3
Message 9382 - Posted: 5 Apr 2007, 18:54:45 UTC - in response to Message 9381.  

Basically you should be able to find the newer version of glibc on your distribution's repository. You should be able to upgrade it using your normal installation or upgrade procedures for your Linux distribution.


Well, I'm using SuSE Linux 9.3, that might be the problem.
Even 2.4 is not available as an update option.
And upgrading to OpenSuse is a little bit trickey, when you have no access to a remote console.

5.8.16 is working, and I leave it with that.
ID: 9382 · Report as offensive
Metod, S56RKO

Send message
Joined: 9 Sep 05
Posts: 128
Slovenia
Message 9394 - Posted: 6 Apr 2007, 10:46:16 UTC - in response to Message 9380.  

The only one left is:

./boinc: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by ./boinc)

I have the libc.so.6 in /usr/local/lib/glibc2/lib
How can I tell boinc to use it, the version in /lib/tls is the old 2.3 one, and I don't want to overwrite it.


You may try to start boinc as

LD_PRELOAD=/usr/local/glibc2/lib/libc.so.6 ./boinc

If this doesn't work, you may try to run it as

LD_DEBUG=all LD_PRELOAD=/usr/local/glibc2/lib/libc.so.6 ./boinc

As you compiled new glibc on your host, this might work. In my case it fails:

LD_PRELOAD=/tmp/libc-2.3.2.so ls
/usr/bin/ls: /lib/ld-linux.so.2: version `GLIBC_PRIVATE' not found (required by /tmp/libc-2.3.2.so)

The problem is actually stated in the error message above ... System has ld-2.2.5.so (which is the target of /lib/ld-linux.so.2) while glibc was compiled on host with ld-2.3.2.so ...


Metod ...
ID: 9394 · Report as offensive
MarkusWeiler

Send message
Joined: 10 Apr 07
Posts: 1
Message 9484 - Posted: 10 Apr 2007, 8:56:12 UTC - in response to Message 9394.  
Last modified: 10 Apr 2007, 8:57:13 UTC

Hi,

same problem occured after updating the 5.8.15 client to 5.8.17 on my SME Server (Version 7.1.3, all updates). Installation of the offered glibc updates didn't help, changing back to 5.8.15 did...
Does anyone else have problems on SME Server (Rosetta client often dead after one day, killing one of the Rosetta tasks helps for a couple of days...)?

Greetings, Markus!


The only one left is:

./boinc: /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by ./boinc)

I have the libc.so.6 in /usr/local/lib/glibc2/lib
How can I tell boinc to use it, the version in /lib/tls is the old 2.3 one, and I don't want to overwrite it.


You may try to start boinc as

LD_PRELOAD=/usr/local/glibc2/lib/libc.so.6 ./boinc

If this doesn't work, you may try to run it as

LD_DEBUG=all LD_PRELOAD=/usr/local/glibc2/lib/libc.so.6 ./boinc

As you compiled new glibc on your host, this might work. In my case it fails:

LD_PRELOAD=/tmp/libc-2.3.2.so ls
/usr/bin/ls: /lib/ld-linux.so.2: version `GLIBC_PRIVATE' not found (required by /tmp/libc-2.3.2.so)

The problem is actually stated in the error message above ... System has ld-2.2.5.so (which is the target of /lib/ld-linux.so.2) while glibc was compiled on host with ld-2.3.2.so ...


ID: 9484 · Report as offensive
Profile Sancio
Avatar

Send message
Joined: 11 Apr 07
Posts: 2
Italy
Message 9526 - Posted: 11 Apr 2007, 20:43:38 UTC - in response to Message 9352.  

Hi,
I have the same problem on a Slackware 10.1(glibc 2.3.4), boinc 5.8.17:
ldd BOINC/boinc
BOINC/boinc: /lib/libc.so.6: version `GLIBC_2.4' not found (required by BOINC/boinc)
linux-gate.so.1 => (0xffffe000)
libdl.so.2 => /lib/libdl.so.2 (0xb7fe0000)
libc.so.6 => /lib/libc.so.6 (0xb7ec2000)
libstdc++.so.6 => not found
libm.so.6 => /lib/libm.so.6 (0xb7e9f000)
libpthread.so.0 => /lib/libpthread.so.0 (0xb7e4d000)
/lib/ld-linux.so.2 (0xb7feb000)

What is it better?
Return to boinc 5.8.15, try 5.8.16 or manual compile 5.8.17?

Yes there was a change. A more recent version of the gcc compiler is used, getting better optimizations and in turn more accurate benchmarks. By default it uses glibc 2.4. I think it's possible, but not so easy, for the developers to use a new compiler with an older glibc. I was unable to install 5.8.17 on Ubuntu Dapper, which is Ubuntu's "Long Term Support" version; I guess a lot of people run that version. So I suggested going at least one version back, that is, using glibc 2.3 on BOINC.


I hope it's possible:
Slackware 10.1 glibc 2.3.4
Slackware 10.2 glibc 2.3.5
Slackware 11 glibc 2.3.6

I know that I can compile and install glibc in another directory or maybe even replace it, but I don't want another software to keep updated at hands...

Thanks.
ID: 9526 · Report as offensive
Nicolas

Send message
Joined: 19 Jan 07
Posts: 1174
Argentina
Message 9529 - Posted: 11 Apr 2007, 21:24:05 UTC

Stay with 5.8.16. 5.8.17 was especially to test if benchmarks got better by using a newer compiler (and glibc). We can consider the test a failure on your machine :)
ID: 9529 · Report as offensive

Message boards : BOINC client : Client not working after update

Copyright © 2020 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.