Resource Share Problem

Message boards : Questions and problems : Resource Share Problem
Message board moderation

To post messages, you must log in.

AuthorMessage
Bryn Mawr
Help desk expert

Send message
Joined: 31 Dec 18
Posts: 56
United Kingdom
Message 99438 - Posted: 24 Jun 2020, 21:52:32 UTC
Last modified: 24 Jun 2020, 21:59:45 UTC

As Rosetta and Climate Prediction are both out of work, yesterday I added TN-Grid to my main PC as a backup project to WCG.

It worked quite happily (took over all 12 cores in an effort to get the work done up to match its resource share) and I processed 58 WUs with no errors.

Then, sometime between 19:00 and 20:00 this evening with no intervention on my part, the resource share showing in BoincMgr changed from 100 to 0, all of the WUs changed to waiting and WCG took over.

After some discussions of the TN-Grid forum I'm coming to the conclusion that the problem lies within Boinc. All of the parameters within both TN-Grid and BAM have a valid resource share, the resource share shown in the /var/lib/boinc-client/account_****_XML file is 100 but the value in the client_state file is 0.

So, first question is "is this a problem that's been seen before" and the second question is "can anyone explain the route by which the resource share gets into the client_state file" - am I looking in the right place?

To add some context, I'm running Boinc 7.16.6 (or 7.17.0, depends where you look) under Ubuntu 18.04 on computer :-

https://gene.disi.unitn.it/test/show_host_detail.php?hostid=60043
ID: 99438 · Report as offensive     Reply Quote
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99439 - Posted: 24 Jun 2020, 22:57:08 UTC - in response to Message 99438.  

Make sure you're looking at the correct location or venue, that you didn't set one up for that computer that differs.
Please do not private message me for tech support, these will be ignored!
ID: 99439 · Report as offensive     Reply Quote
Bryn Mawr
Help desk expert

Send message
Joined: 31 Dec 18
Posts: 56
United Kingdom
Message 99440 - Posted: 24 Jun 2020, 23:33:59 UTC - in response to Message 99439.  

Make sure you're looking at the correct location or venue, that you didn't set one up for that computer that differs.


Depending where I look the location is either default or, somewhat randomly, school. Since I discovered this I’ve set up a profile for school and done an update on the project.

I also found that bam holds a resource share at both the project level and by host within project. The latter was unset so I’ve set it and done both an update project and a resynchronise with bam.

What worries me is that the boinc project config file (my assumption) /val/lib/boinc-client/account-***.xml holds 100 which matches the projects setting but that the working set (again my assumption) in client-state is zero which would put the disconnect within boinc.
ID: 99440 · Report as offensive     Reply Quote
Bryn Mawr
Help desk expert

Send message
Joined: 31 Dec 18
Posts: 56
United Kingdom
Message 99443 - Posted: 25 Jun 2020, 9:27:09 UTC

OK, I’m still confused but the problem has resolved itself overnight with the resource share bein downloaded from TN-Grid default profile.

Why the delay I don’t know, it now updates immediately if I change it in TN-Grid and do update which it wasn’t yesterday.
ID: 99443 · Report as offensive     Reply Quote
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99445 - Posted: 25 Jun 2020, 9:36:45 UTC - in response to Message 99443.  

Me sleeping always helps with other people's tech problems. :)
ID: 99445 · Report as offensive     Reply Quote
Bryn Mawr
Help desk expert

Send message
Joined: 31 Dec 18
Posts: 56
United Kingdom
Message 99446 - Posted: 25 Jun 2020, 10:47:40 UTC - in response to Message 99445.  
Last modified: 25 Jun 2020, 10:48:17 UTC

Me sleeping always helps with other people's tech problems. :)


Sleeping on a problem always helps lol

Thank you :-)
ID: 99446 · Report as offensive     Reply Quote
Bryn Mawr
Help desk expert

Send message
Joined: 31 Dec 18
Posts: 56
United Kingdom
Message 99449 - Posted: 25 Jun 2020, 15:46:05 UTC - in response to Message 99443.  

OK, I’m still confused but the problem has resolved itself overnight with the resource share being downloaded from TN-Grid default profile.

Why the delay I don’t know, it now updates immediately if I change it in TN-Grid and do update which it wasn’t yesterday.


More confusion, the resource share has changed again, this time taking the value from the BAM host within project level. It would appear that sync with account manager does not update this value but the 6 hourly refresh does???
ID: 99449 · Report as offensive     Reply Quote

Message boards : Questions and problems : Resource Share Problem

Copyright © 2020 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.