Incompetent BOINC Programmers

Message boards : Questions and problems : Incompetent BOINC Programmers
Message board moderation

To post messages, you must log in.

AuthorMessage
rcthardcore9512

Send message
Joined: 30 Apr 20
Posts: 5
Message 99066 - Posted: 3 Jun 2020, 17:13:18 UTC

collatz: Notice from BOINC
Your settings do not allow fetching tasks for CPU. To fix this, you can change Project Preferences on the project's web site.
6/3/2020 12:06:07 PM

The above message is STILL appearing whenever I start BOINC. This annoys me to no end. You said it was going to be deactivated in the NEXT update. YOU LIE!!!!!!!
ID: 99066 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4094
United Kingdom
Message 99067 - Posted: 3 Jun 2020, 17:49:19 UTC - in response to Message 99066.  

OK, we should have said "it will be fixed in the next planned update". That's still the plan: https://github.com/BOINC/boinc/pull/3749

But in the meantime, the incompetent BOINC administrators got caught out by an expired security certificate, and made an unplanned update which didn't include the planned updates. So the 'next' update became the 'next but [one?] [two?] [who knows?] update'.
ID: 99067 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99068 - Posted: 3 Jun 2020, 18:28:28 UTC - in response to Message 99066.  

I asked about those fixes being included and was ignored. So yes. Fun.
Please do not private message me for tech support, these will be ignored!
ID: 99068 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4094
United Kingdom
Message 99069 - Posted: 3 Jun 2020, 18:41:46 UTC

The latest BOINC version, as known to BOINC at the time of writing, is v7.16.7

So why is my Linux machine being offered v7.16.15 by Gianfranco's PPA?
ID: 99069 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99070 - Posted: 3 Jun 2020, 18:50:49 UTC - in response to Message 99069.  

Nightly tarball?
ID: 99070 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4094
United Kingdom
Message 99071 - Posted: 3 Jun 2020, 19:02:02 UTC - in response to Message 99070.  

Nightly tarball?
No, a fully fledged system update.

ID: 99071 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99072 - Posted: 3 Jun 2020, 19:12:49 UTC - in response to Message 99071.  

I don't know. You should ask him why he jumped from 7.16.6 to 7.16.15: https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/boinc/+builds?build_state=built
ID: 99072 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4094
United Kingdom
Message 99073 - Posted: 3 Jun 2020, 19:26:58 UTC - in response to Message 99072.  

I could, I suppose, but I think I'd just be getting even further out of my depth. I'll sleep on it.
ID: 99073 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99075 - Posted: 3 Jun 2020, 19:42:52 UTC - in response to Message 99073.  

It's possible he ran some test versions, internally or with the other developers. But other than that I really can't think of anything.
ID: 99075 · Report as offensive
ProDigit

Send message
Joined: 8 Nov 19
Posts: 546
United States
Message 99076 - Posted: 4 Jun 2020, 2:05:00 UTC
Last modified: 4 Jun 2020, 2:05:36 UTC

Because in order to install Boinc from him, you must add his PPAs into the repositories.
In other words, you're loading the latest 'beta' versions, that could have some instability (like 'Your settings do not allow fetching tasks for CPU...'

If you installed Ubuntu 20.04 or a variant, without PPA, the latest version will be 7.16.6, until someone decides that it's time to provide the repositories with an updated version.
ID: 99076 · Report as offensive
rcthardcore9512

Send message
Joined: 30 Apr 20
Posts: 5
Message 99079 - Posted: 4 Jun 2020, 2:47:14 UTC

Still lied. You can't get around that.
ID: 99079 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99081 - Posted: 4 Jun 2020, 6:35:41 UTC - in response to Message 99079.  

Well, the programmers and developers don't frequent these forums so if you want to rub against the good volunteers that do frequent these forums and call us all liars because no one checked the validity of some certificate for crucial communications with a lot of projects then be my guest. Humans make mistakes.

We cannot predict what the BOINC Release Manager is going to add to a next BOINC unless one of us becomes that person next. The present RM does what he wants and listens to no-one.

So for future reference, some future BOINC will have the fixes added and most probably have new annoyances added. Which then take absolutely forever to get fixed again.

I don't even know why this version needed a new version number, seeing how they're in the process of releasing an Android client with the new certificates file with the same version number as the present stable version. That could've been done for the Windows version as well. (and still nothing about the 32bit client, right?)
Please do not private message me for tech support, these will be ignored!
ID: 99081 · Report as offensive
Richard Haselgrove
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 4094
United Kingdom
Message 99084 - Posted: 4 Jun 2020, 9:14:00 UTC - in response to Message 99071.  
Last modified: 4 Jun 2020, 9:53:07 UTC

Nightly tarball?
No, a fully fledged system update.

https://i.imgur.com/9F0bTnZ.png
Well, I took my courage in both hands, donned PPE, and installed it.

2020-06-04 09:33:07 upgrade boinc-client-nvidia-cuda:amd64 7.16.6+dfsg+202005240954~ubuntu18.04.1 7.16.15+dfsg+202006021756~ubuntu18.04.1
2020-06-04 09:33:32 status installed boinc-client-nvidia-cuda:amd64 7.16.15+dfsg+202006021756~ubuntu18.04.1

-- Logs begin at Mon 2020-02-03 12:48:12 GMT, end at Thu 2020-06-04 09:54:09 BST. --
Jun 04 09:34:29 Rosa systemd[1]: Started Berkeley Open Infrastructure Network Computing Client.
Jun 04 09:34:29 Rosa boinc[628]: 04-Jun-2020 09:34:29 [---] Starting BOINC client version 7.17.0 for x86_64-pc-linux-gnu
Jun 04 09:34:29 Rosa boinc[628]: 04-Jun-2020 09:34:29 [---] log flags: file_xfer, sched_ops, task, cpu_sched, sched_op_debug, unparsed_xml
Jun 04 09:34:29 Rosa boinc[628]: 04-Jun-2020 09:34:29 [---] Libraries: libcurl/7.58.0 OpenSSL/1.1.1 zlib/1.2.11 libidn2/2.0.4 libpsl/0.19.1 (+libidn2/2.0.4) nghttp2/1.30.0 librtmp/2.3
Jun 04 09:34:29 Rosa boinc[628]: 04-Jun-2020 09:34:29 [---] Data directory: /var/lib/boinc-client
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [---] OpenCL: NVIDIA GPU 0: GeForce GTX 1660 SUPER (driver version 440.82, device version OpenCL 1.2 CUDA, 5943MB, 5943MB available, 5153 GFLOPS peak)
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [---] OpenCL: NVIDIA GPU 1: GeForce GTX 1660 SUPER (driver version 440.82, device version OpenCL 1.2 CUDA, 5945MB, 5945MB available, 5153 GFLOPS peak)
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [SETI@home] Found app_info.xml; using anonymous platform
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [---] App version needs CUDA but GPU doesn't support it
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [---] App version needs CUDA but GPU doesn't support it
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [---] App version needs CUDA but GPU doesn't support it
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [GPUGRID] Application uses missing NVIDIA GPU
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [GPUGRID] Missing coprocessor for task 1neeA01_379_4-TONI_MDADex2sn-8-50-RND2183_0
Jun 04 09:34:31 Rosa boinc[628]: 04-Jun-2020 09:34:31 [GPUGRID] Missing coprocessor for task 1svuA02_413_4-TONI_MDADex2ss-8-50-RND6622_0
So it's v7.17.0 (master), but without the pre-release tag.

When I install a package called "boinc-client-nvidia-cuda", I expect it to wait for the CUDA driver to load before launching...

Off to find a bug reporting site.
ID: 99084 · Report as offensive
Bryn Mawr
Help desk expert

Send message
Joined: 31 Dec 18
Posts: 56
United Kingdom
Message 99085 - Posted: 4 Jun 2020, 11:12:09 UTC - in response to Message 99079.  

Still lied. You can't get around that.


You’ve obviously never worked in a computer development environment and you know not of what you speak.

There are two distinct types of implementation, what you might call an update. There are scheduled implementations and emergency fixes. You NEVER rush in a scheduled implementation to make an emergency fix, that is a sure fire recipe for disaster and bugs in the future. If you have a problem that blocks the users you develop and test a fix for that problem against the live system and implement it in isolation. You then go back and regression test your scheduled implementation against the updated live system and, hopefully, make the updates to the original schedule.

Given that no-one can predict when an emergency fix will be necessary the information that you were given was true to the best knowledge that the responders could possibly have had, it was therefore no lie.

For you to come in here insulting the people who are doing their very best to help and who are doing so in their own time without reward is totally out of order. I suggest that you apologise to them for your ignorance and rudeness and then crawl back where you came from.
ID: 99085 · Report as offensive
Profile Jord
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 14157
Netherlands
Message 99088 - Posted: 4 Jun 2020, 12:08:13 UTC - in response to Message 99084.  

Always fun to see how people still can't use versions.php
But then I shouldn't laugh as I've been there as well. :)
ID: 99088 · Report as offensive

Message boards : Questions and problems : Incompetent BOINC Programmers

Copyright © 2020 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.