No GPU Units, Did I Turn Them Off?

Message boards : GPUs : No GPU Units, Did I Turn Them Off?
Message board moderation

To post messages, you must log in.

AuthorMessage
l008com

Send message
Joined: 22 Mar 09
Posts: 27
United States
Message 83918 - Posted: 17 Dec 2017, 13:14:22 UTC

I am unable to get any GPU units and I cannot figure out why.

Some background: I'm running a Mac Pro but booted natively on windows 7. It has a very low power nVidia 7300GT card, and then a very powerful AMD card. I forget the exact model, but it is a high end, 4 year old model.

I run many projects at once. I used to get GPU units. Collatz and Seti would send them, plus at least one other project I run. I'm not sure which one but I'm thinking Milkyway?

Here's a full list of all projects I'm running:
    Collatz
    Einstein
    Seti
    Asteroids
    Climateprediction(disabled)
    Milyway
    NFS
    pogs
    LHC
    Cosmology
    Rosetta



As I said, I used to get GPU units. I only run this machine in the winter, for extra heat :) It's very possible that I disabled GPU units somehow, because that was using too much power, and creating too much heat? It was so long ago, I just don't recall. But I'm not sure how. I've been running just CPU for a few months but now I need to be able to do more work. I've gone into the settings on all three accounts and made sure AMD GPU use was enabled. Is there some other way to disable GPU?
I know it's always possible some projects won't have work, but collatz is just a math problem, it should always have work! And it used to burn through GPU units 10x faster than any other project. But now I can't get anything at all.

ID: 83918 · Report as offensive     Reply Quote
l008com

Send message
Joined: 22 Mar 09
Posts: 27
United States
Message 83919 - Posted: 17 Dec 2017, 14:46:21 UTC

Update:

The event log was showing NO gpus! That makes no sense.
I downloaded the latest AMD driver. Then I ran it. I ran that horrible, ridiculous, embarrassing excuse for an installer.
I don't know if I upgraded or downgraded the drivers, I honestly couldn't tell. It was not clear at all.

BUT whatever I did, BOINC immediately started getting GPU units again! So problem solved!

One more related question. Is there an 'easy' way to turn of the GPU for all projects, at once? Rather than disabling it project by project?
ID: 83919 · Report as offensive     Reply Quote
Juha
Volunteer developer
Volunteer tester
Help desk expert

Send message
Joined: 20 Nov 12
Posts: 740
Finland
Message 83927 - Posted: 17 Dec 2017, 20:40:00 UTC - in response to Message 83919.  

You can select Suspend GPU in View -> Advanced View -> Activity. This stops computing on the GPU but you will still receive GPU tasks according to your cache settings.

Another way is to set <exclude_gpu>, <ignore_X_dev>, <no_gpus> and/or <no_opencl> in cc_config.xml or start BOINC client with --no_gpus command line option. See Client configuration.
ID: 83927 · Report as offensive     Reply Quote

Message boards : GPUs : No GPU Units, Did I Turn Them Off?

Copyright © 2018 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.