Only one GPU detected. Linux, Ubuntu, Nvidia

Message boards : GPUs : Only one GPU detected. Linux, Ubuntu, Nvidia
Message board moderation

To post messages, you must log in.

AuthorMessage
Rolf

Send message
Joined: 15 Dec 17
Posts: 3
Australia
Message 83910 - Posted: 17 Dec 2017, 6:49:00 UTC

I have looked through the forums and searched the internet but I can't understand this one.

I'm running an Ubuntu Server with 2 Nvidia card installed. The system sees them both but Boinc only sees the first one.

You can see the config and system messages below, these show both cards are initialized by the system.

rolf@atomgpu:~$ cat /etc/lsb-release 
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.3 LTS"


rolf@atomgpu:~$ lspci | grep NVIDIA
01:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)
02:00.0 VGA compatible controller: NVIDIA Corporation GM107 [GeForce GTX 750 Ti] (rev a1)
02:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)


rolf@atomgpu:~$ dmesg | grep nvidia
[    4.927464] nvidia: module license 'NVIDIA' taints kernel.
[    5.054779] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    5.164331] nvidia-nvlink: Nvlink Core is being initialized, major device number 246
[    5.255554] nvidia 0000:02:00.0: enabling device (0000 -> 0003)
[    5.356837] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  384.90  Tue Sep 19 17:05:19 PDT 2017
[    5.445568] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
[    5.460398] [drm] [nvidia-drm] [GPU ID 0x00000200] Loading driver
[   13.713674] nvidia-uvm: Loaded the UVM driver in 8 mode, major device number 245


Sun 17 Dec 2017 06:00:44 AWST |  | Starting BOINC client version 7.6.31 for x86_64-pc-linux-gnu
Sun 17 Dec 2017 06:00:44 AWST |  | log flags: file_xfer, sched_ops, task, coproc_debug
Sun 17 Dec 2017 06:00:44 AWST |  | Libraries: libcurl/7.47.0 OpenSSL/1.0.2g zlib/1.2.8 libidn/1.32 librtmp/2.3
Sun 17 Dec 2017 06:00:44 AWST |  | Data directory: /var/lib/boinc-client
Sun 17 Dec 2017 06:00:44 AWST |  | [coproc] launching child process at /usr/bin/boinc
Sun 17 Dec 2017 06:00:44 AWST |  | [coproc] relative to directory /
Sun 17 Dec 2017 06:00:44 AWST |  | [coproc] with data directory /var/lib/boinc-client
Sun 17 Dec 2017 06:00:45 AWST |  | CUDA: NVIDIA GPU 0: GeForce GTX 750 Ti (driver version 384.90, CUDA version 9.0, compute capability 2.1, 964MB, 932MB available, 691 GFLOPS peak)
Sun 17 Dec 2017 06:00:45 AWST |  | OpenCL: NVIDIA GPU 0: GeForce GTX 750 Ti (driver version 384.90, device version OpenCL 1.1 CUDA, 964MB, 932MB available, 691 GFLOPS peak)
Sun 17 Dec 2017 06:00:45 AWST |  | [coproc] NVIDIA library reports 1 GPU


rolf@atomgpu:~$ cat /etc/boinc-client/cc_config.xml 
<!--
This is a minimal configuration file cc_config.xml of the BOINC core client.
For a complete list of all available options and logging flags and their
meaning see: https://boinc.berkeley.edu/wiki/client_configuration
-->
<cc_config>
 <options>
       <use_all_gpus>1</use_all_gpus>
    </options>
  <log_flags>
<coproc_debug>1</coproc_debug>
    <task>1</task>
    <file_xfer>1</file_xfer>
    <sched_ops>1</sched_ops>
  </log_flags>
</cc_config>
ID: 83910 · Report as offensive     Reply Quote
Juha
Volunteer developer
Volunteer tester
Help desk expert

Send message
Joined: 20 Nov 12
Posts: 740
Finland
Message 83928 - Posted: 17 Dec 2017, 20:51:43 UTC - in response to Message 83910.  

Do you have monitor connected to both GPUs? That used to be a problem with older Windows drivers, maybe its still needed with Linux drivers.
ID: 83928 · Report as offensive     Reply Quote
robsmith
Help desk expert

Send message
Joined: 25 May 09
Posts: 329
United Kingdom
Message 83935 - Posted: 18 Dec 2017, 12:43:57 UTC

Linux does not need to have any monitors attached to a gpu. All three of my Linux crunchers are headless an happily detect all their GPUs. The only thing to do is make sure you have "use all gpu" set if you have issues getting them all detected.
ID: 83935 · Report as offensive     Reply Quote
Profile Ageless
Volunteer moderator
Project administrator
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 12526
Netherlands
Message 83937 - Posted: 18 Dec 2017, 13:49:51 UTC - in response to Message 83935.  

The only thing to do is make sure you have "use all gpu" set if you have issues getting them all detected.
The "Use all gpus" option is not used to get your GPUs detected, not even when you have problems with detection of the GPUs.
Instead it's used to use all GPUs of the same brand but different models that BOINC has already detected, but isn't all using out of the box.

If you have problems getting any of your GPUs detected, think drivers first.
Jord
Please do not private message me for tech support. Use the forums for that. Tech PMs will be ignored.

quote: "Isn't the best defense always a good attack?"
ID: 83937 · Report as offensive     Reply Quote
Rolf

Send message
Joined: 15 Dec 17
Posts: 3
Australia
Message 83979 - Posted: 21 Dec 2017, 1:45:44 UTC - in response to Message 83937.  

You said:

Instead it's used to use all GPUs of the same brand but different models that BOINC has already detected, but isn't all using out of the box.

Both GPU's are the exact same model. Do I have to do something special to get Boinc to use 2 identical GPUs?
ID: 83979 · Report as offensive     Reply Quote
Rolf

Send message
Joined: 15 Dec 17
Posts: 3
Australia
Message 83980 - Posted: 21 Dec 2017, 3:42:25 UTC

******* Resolved ********

After a week of trying everything to try and get both cards working I went back to basics and tested everything individually.

It turns out that even though one GPU identifies itself as a GTX 750TI it just won't talk OPENCL no matter what I do.

I replaced it with an identical unit and that works fine.

I am going to assume that the card I was having issues with was either defective or a fake.

Everything is working as it should now.
ID: 83980 · Report as offensive     Reply Quote

Message boards : GPUs : Only one GPU detected. Linux, Ubuntu, Nvidia

Copyright © 2018 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.