Application doesnt use missing NVIDIA GPU msg after installing Boinc 7.8.3

Message boards : GPUs : Application doesnt use missing NVIDIA GPU msg after installing Boinc 7.8.3
Message board moderation

To post messages, you must log in.

AuthorMessage
diveguy_84

Send message
Joined: 8 Nov 17
Posts: 2
United States
Message 82809 - Posted: 8 Nov 2017, 19:57:06 UTC
Last modified: 8 Nov 2017, 20:37:29 UTC

Today I upgraded Boinc to 7.8.3 from the current World Community Grid version. After that I got various Application uses missing NVIDIA GPU entries in my log for of my current projects and also noted that my VirtualBox had been downgraded.
So I upgraded to the current version of that as well to restore it to it's past state.

I have recently installed the Windows 10 Fall Creators Update without problems. Sun Nov 5.
After the problem showed up I installed the latest driver from NVIDEA it did not fix the problem.

Here is the output in my event log:
11/8/2017 10:41:48 AM Starting BOINC client version 7.8.3 for windows_x86_64
11/8/2017 10:41:48 AM log flags: file_xfer, sched_ops, task
11/8/2017 10:41:48 AM Libraries: libcurl/7.47.1 OpenSSL/1.0.2g zlib/1.2.8
11/8/2017 10:41:48 AM Data directory: C:\ProgramData\BOINC
11/8/2017 10:41:48 AM Running under account Rick
11/8/2017 10:41:48 AM CUDA: NVIDIA GPU 0: GeForce GTX 780 (driver version 388.13, CUDA version 9.1, compute capability 3.5, 3072MB, 2528MB available, 4576 GFLOPS peak)
11/8/2017 10:41:48 AM App version needs OpenCL but GPU doesn't support it
11/8/2017 10:41:48 AM Collatz Conjecture Application uses missing NVIDIA GPU
11/8/2017 10:41:49 AM App version needs OpenCL but GPU doesn't support it
11/8/2017 10:41:49 AM Einstein@Home Application uses missing NVIDIA GPU
11/8/2017 10:41:49 AM Einstein@Home Missing coprocessor for task LATeah0043L_1196.0_0_0.0_24896690_1
11/8/2017 10:41:49 AM Milkyway@Home Application uses missing NVIDIA GPU
11/8/2017 10:41:49 AM App version needs OpenCL but GPU doesn't support it
11/8/2017 10:41:49 AM App version needs OpenCL but GPU doesn't support it
11/8/2017 10:41:49 AM SETI@home Application uses missing NVIDIA GPU
11/8/2017 10:41:49 AM Processor: 12 GenuineIntel Intel(R) Core(TM) i7-5930K CPU @ 3.50GHz [Family 6 Model 63 Stepping 2]
11/8/2017 10:41:49 AM Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss htt tm pni ssse3 fma cx16 sse4_1 sse4_2 movebe popcnt aes f16c rdrandsyscall nx lm avx avx2 vmx tm2 dca pbe fsgsbase bmi1 smep bmi2
11/8/2017 10:41:49 AM OS: Microsoft Windows 10: Professional x64 Edition, (10.00.16299.00)
11/8/2017 10:41:49 AM Memory: 31.81 GB physical, 63.81 GB virtual
11/8/2017 10:41:49 AM Disk: 465.22 GB total, 309.46 GB free
11/8/2017 10:41:49 AM Local time is UTC -5 hours
11/8/2017 10:41:49 AM VirtualBox version: 5.2.0
11/8/2017 10:41:49 AM Config: event log limit 200000 lines
11/8/2017 10:41:49 AM Config: use all coprocessors
11/8/2017 10:41:49 AM World Community Grid General prefs: from World Community Grid (last modified 05-Nov-2017 06:12:46)
11/8/2017 10:41:49 AM World Community Grid Host location: none
11/8/2017 10:41:49 AM World Community Grid General prefs: using your defaults
11/8/2017 10:41:49 AM Reading preferences override file
11/8/2017 10:41:49 AM Preferences:
11/8/2017 10:41:49 AM max memory usage when active: 16286.87 MB
11/8/2017 10:41:49 AM max memory usage when idle: 29316.36 MB
11/8/2017 10:41:49 AM max disk usage: 319.87 GB
11/8/2017 10:41:49 AM (to change preferences, visit a project web site or select Preferences in the Manager)
11/8/2017 10:41:49 AM Using account manager BOINCstatsBAM!

I suspect that this is a NVIDEA/WINDOWS 10 Fall Creators issue but have no way to resolve this.
ID: 82809 · Report as offensive     Reply Quote
Profile Ageless
Volunteer moderator
Project administrator
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 12308
Netherlands
Message 82810 - Posted: 8 Nov 2017, 20:45:02 UTC - in response to Message 82809.  
Last modified: 8 Nov 2017, 20:47:38 UTC

After the problem showed up I installed the latest driver from NVIDEA it did not fix the problem.
From where?

11/8/2017 10:41:48 AM CUDA: NVIDIA GPU 0: GeForce GTX 780 (driver version 388.13, CUDA version 9.1, compute capability 3.5, 3072MB, 2528MB available, 4576 GFLOPS peak)
11/8/2017 10:41:48 AM App version needs OpenCL but GPU doesn't support it
It looks as if Windows installed the driver, because you only have the CUDA component installed, not the OpenCL component. Both are in the drivers. But only when you install the drivers from the Nvidia website, not if you allow Windows 10 to update the driver. Microsoft tends to leave components out of the driver, if they feel it makes them unstable or them being a direct competitor to their own components (OpenGL -> DirectX, OpenCL -> DirectCompute)

Download from the Nvidia website and use the Clean Install option in the installer to install the Nvidia drivers clean. Also make sure Windows Update cannot update your drivers.
Jord
Please do not private message me for tech support. Use the forums for that. Tech PMs will be ignored.

I'm only partially available, until further notice.
ID: 82810 · Report as offensive     Reply Quote
diveguy_84

Send message
Joined: 8 Nov 17
Posts: 2
United States
Message 82814 - Posted: 9 Nov 2017, 2:52:20 UTC - in response to Message 82810.  
Last modified: 9 Nov 2017, 2:56:55 UTC

Using your info as a guide I was able to update the driver.

I went to the NVIDIA site and downloaded the correct driver. It was the same driver I downloaded this morning.

I ran this installer and chose custom install and then clean install. The installer showed that before it did it's work that the OpenCl drivers as well as others were missing. Others had been updated. None where back leveled.
The installer hung up and I was forced to restart the machine. This also happened duning this morning's install

This did not fix the problems.
I re-ran the same installer. I chose custom install without the clean install option.
This showed that all but the Bios and the last driver lasted had been cleared out. The installer finished and asked for a restart.
This fixed the problem.

Here are the log entries:
11/8/2017 8:31:06 PM CUDA: NVIDIA GPU 0: GeForce GTX 780 (driver version 388.13, CUDA version 9.1, compute capability 3.5, 3072MB, 2528MB available, 4576 GFLOPS peak)
11/8/2017 8:31:06 PM OpenCL: NVIDIA GPU 0: GeForce GTX 780 (driver version 388.13, device version OpenCL 1.2 CUDA, 3072MB, 2528MB available, 4576 GFLOPS peak)

At this point I suspect that the LG driver I installed for my 34" curved monitor also had had caused some issues. It was not very usefull so I removed it.

The only 2 outstanding issue at time are:
1) The project's resource shares for each project have been lost. I will attempt to fix this by setting BoincStatsBam projects options. I have done this once before but the update seems to have been lost.
2) I couldn't join the World Community Grid from the projects list page. So I installed the projects Bionic which is down leveled from the current version that I installed this morning.
What are the implications of this. I noticed that the help tab for the World Community Grid Bionc points to their own links. Are there any down sides

I have been very detailed in this is an attempt to make this as useful as possible for any future readers.

I welcome any future input. And express my sincere gratitude.
Thank you so much

Rick

After the problem showed up I installed the latest driver from NVIDIA it did not fix the problem.
From where?

11/8/2017 10:41:48 AM CUDA: NVIDIA GPU 0: GeForce GTX 780 (driver version 388.13, CUDA version 9.1, compute capability 3.5, 3072MB, 2528MB available, 4576 GFLOPS peak)
11/8/2017 10:41:48 AM App version needs OpenCL but GPU doesn't support it
It looks as if Windows installed the driver, because you only have the CUDA component installed, not the OpenCL component. Both are in the drivers. But only when you install the drivers from the Nvidia website, not if you allow Windows 10 to update the driver. Microsoft tends to leave components out of the driver, if they feel it makes them unstable or them being a direct competitor to their own components (OpenGL -> DirectX, OpenCL -> DirectCompute)

Download from the Nvidia website and use the Clean Install option in the installer to install the Nvidia drivers clean. Also make sure Windows Update cannot update your drivers.
ID: 82814 · Report as offensive     Reply Quote

Message boards : GPUs : Application doesnt use missing NVIDIA GPU msg after installing Boinc 7.8.3

Copyright © 2018 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.