Ubuntu - Updater wants to remove BOINC Manager?!

Message boards : Questions and problems : Ubuntu - Updater wants to remove BOINC Manager?!
Message board moderation

To post messages, you must log in.

AuthorMessage
Zeiss Ikon

Send message
Joined: 2 Jul 17
Posts: 7
United States
Message 80867 - Posted: 6 Sep 2017, 20:51:42 UTC
Last modified: 6 Sep 2017, 20:54:46 UTC

I'm running BOINC on three machines now, one of them my desktop machine, which has been running MilkyWay (CPU) for several years, and Einstein (GPU) for a little more than two years.

Yesterday, I happened to look before committing on a system update, and noted that the BOINC client was to be updated (along with some libraries it depends on, of course) -- and the BOINC Manager was to be removed?!

I don't see BOINC Manager being replaced with something else, it's just being removed entirely. For the moment, I've blocked all the BOINC updates -- but is this expected/intended, and if so, why don't I see a message or announcement in the manager itself?

Woops, guess I should tell potential help that I'm running BOINC for 64-bit Linux, installed from the Berkeley repository, with this machine running Kubuntu 14.04.5 LTS.
ID: 80867 · Report as offensive     Reply Quote
ChristianB
Volunteer moderator
Volunteer developer
Volunteer tester

Send message
Joined: 4 Jul 12
Posts: 305
Germany
Message 80890 - Posted: 7 Sep 2017, 12:27:20 UTC

There is no Berkeley repository. You seem to have BOINC installed via the Ubuntu repositories and there nothing has changed. All BOINC components are available in all current Ubuntu distributions. There should be no reason to remove boinc-manager. I durectly use aptitude and that usually tells me why it removes a package when upgrading.
ID: 80890 · Report as offensive     Reply Quote
Zeiss Ikon

Send message
Joined: 2 Jul 17
Posts: 7
United States
Message 80917 - Posted: 7 Sep 2017, 22:28:32 UTC - in response to Message 80890.  
Last modified: 7 Sep 2017, 22:40:53 UTC

I use Synaptic, mostly because I'm used to it. I assure you, I'm being told that boinc-manager 7.6.33+dfsg-0 is to be removed. Not upgraded, removed. Attempts to instead mark this package for upgrade, or to force version to 7.8.2 (seemingly available for trusty) result in the same effect: removal of libwxgtk-webview3.0-0, which appears to be a BOINC Manager depend. Marking the meta-package boinc for installation also marks libwxgtk-webview3.0-0 for removal, and thus marks various boinc-client packages to install or upgrade, but does not mark boinc-manager to install.

I do see a newer version of libwxgtk-webview3.0-0, labeled as libwxgtk-webview3.0-0v5, but marking that version also results in either removing or breaking boinc-manager 7.6.33. For the time being, I'm going to try locking boinc-manager and libwxgtk-webview3.0-0, so as to be able to install other needed updates without making it impossible to manage my BOINC clients.

Edit: Adding to this, despite locking versions as noted above, after completing updates that updated my boinc-client packages, boinc-manager now will not start from the same launcher I've used for three years, since installing on a then-new Kubuntu 14.04. Attempting to launch in terminal gives no output at all, just a pause of a few seconds and a return to the prompt.
ID: 80917 · Report as offensive     Reply Quote
ChristianB
Volunteer moderator
Volunteer developer
Volunteer tester

Send message
Joined: 4 Jul 12
Posts: 305
Germany
Message 80934 - Posted: 8 Sep 2017, 10:33:18 UTC

It seems you are trying to install boinc-manager from Ubuntu 17.04 repositories while you are still running mainly on 14.04 packages. There was an ABI change which resulted in renamed packages between 14.04 and 16.04 that's why you need libwxgtk-webview3.0-0v5 instead of libwxgtk-webview3.0-0 for the newer version of the manager. Synaptic probably doesn't know where to get this package from or it needs to be told specifically that it needs to get this from the 16.04 repository not the default 14.04 one.
ID: 80934 · Report as offensive     Reply Quote
Juha
Volunteer developer
Volunteer tester
Help desk expert

Send message
Joined: 20 Nov 12
Posts: 665
Finland
Message 80961 - Posted: 8 Sep 2017, 18:43:30 UTC - in response to Message 80917.  

Do you have BOINC installed from LocutusOfBorg's BOINC PPA?

I have wxWidgets installed from there. I tried what apt-get says if I try to install various boinc packages but I don't see it getting anything wrong.
ID: 80961 · Report as offensive     Reply Quote
Yavanius
Avatar

Send message
Joined: 19 May 15
Posts: 48
Antarctica
Message 81513 - Posted: 21 Sep 2017, 0:25:02 UTC - in response to Message 80961.  

Do you have BOINC installed from LocutusOfBorg's BOINC PPA?

I have wxWidgets installed from there. I tried what apt-get says if I try to install various boinc packages but I don't see it getting anything wrong.



https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/boinc

The unofficial official BOINC repo. ;) He maintains BOINC for Linux so it's a reasonably trusty source. :)
ID: 81513 · Report as offensive     Reply Quote
Zeiss Ikon

Send message
Joined: 2 Jul 17
Posts: 7
United States
Message 81531 - Posted: 21 Sep 2017, 22:17:17 UTC - in response to Message 81513.  

Yes, I have the costamagnagian repo enabled. I haven't had a working BOINC manager since attempting to lock the version failed (though the clients are still pounding through work units). It works fine on my "new" refurbed laptop, running Ubuntu MATE 16.04. The other machine (my older laptop) still running 14.04 doesn't have a mouse plugged in at the moment (and the touchpad disabled in BIOS to prevent it moving my cursor when I'm typing), so I can't readily check if it's still got a working BOINC Manager -- I don't update it as regularly as my desktop machine, but I might also have missed this on that machine.

Given it wasn't working anyway, I unlocked boinc-manager and libwxgtk-webview3.0-0, and removed both packages. I still can't install libwxgtk-webview3.0-0v5; Synaptic says it's got broken dependencies, and invoking edit>fix broken packages gives me a message that " you have held broken packages". Apparently, it depends on something that's not in a repo I have enabled. Any suggestions what repo I need to add?
ID: 81531 · Report as offensive     Reply Quote
Zeiss Ikon

Send message
Joined: 2 Jul 17
Posts: 7
United States
Message 81928 - Posted: 10 Oct 2017, 21:14:23 UTC - in response to Message 81531.  

Okay, I found the problem. There's a package named "golly" -- Game of Life, and a really good one. It depends on libwxgtk-3.0-0, which prevented that file from being replaced by the 3.0-0v5 version, and up the dependency chain. Now, I have a working BOINC Manager again, but I no longer have Golly. Guess someone needs to nag the maintainers of the "golly" package to update its gtk dependency.
ID: 81928 · Report as offensive     Reply Quote

Message boards : Questions and problems : Ubuntu - Updater wants to remove BOINC Manager?!

Copyright © 2017 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.