Can not configure GPU's

Message boards : GPUs : Can not configure GPU's
Message board moderation

To post messages, you must log in.

AuthorMessage
DasMauser

Send message
Joined: 16 Mar 17
Posts: 3
Sweden
Message 76484 - Posted: 16 Mar 2017, 8:39:42 UTC

Hello i have 2 GPU's, both are nvidia card (one 970 and one 550 Ti)
I have W10 and have created the cc_config.xml file and tired to run only my second graphics card.

i have tried using
<cc_config>
<options>
<exclude_gpu>
<url>project_URL</url>
[<device_num>0</device_num>]
</exclude_gpu>
</options>
</cc_config>

i have also tried adding <use_all_gpus>1</use_all_gpus> in order to activate the second gpu but to no avail.
I have tried restarting the client and i can not get it to work. Help plz.


Details on the cards:
16/03/2017 09:26:22 | | CUDA: NVIDIA GPU 0: GeForce GTX 970 (driver version 378.78, CUDA version 8.0, compute capability 5.2, 4096MB, 3391MB available, 4087 GFLOPS peak)
16/03/2017 09:26:22 | | CUDA: NVIDIA GPU 1 (not used): GeForce GTX 550 Ti (driver version 378.78, CUDA version 8.0, compute capability 2.1, 1024MB, 817MB available, 691 GFLOPS peak)
16/03/2017 09:26:22 | | OpenCL: NVIDIA GPU 0: GeForce GTX 970 (driver version 378.78, device version OpenCL 1.2 CUDA, 4096MB, 3391MB available, 4087 GFLOPS peak)
16/03/2017 09:26:22 | | OpenCL: NVIDIA GPU 1 (ignored by config): GeForce GTX 550 Ti (driver version 378.78, device version OpenCL 1.1 CUDA, 1024MB, 817MB available, 691 GFLOPS peak)
ID: 76484 · Report as offensive
Richard Haselgrove
Volunteer moderator
Volunteer tester
Help desk expert

Send message
Joined: 5 Oct 06
Posts: 2765
United Kingdom
Message 76485 - Posted: 16 Mar 2017, 8:54:24 UTC - in response to Message 76484.  

No square brackets [ ]

They are used in documentation to indicate that the item is optional, but can't be used in the actual file.
ID: 76485 · Report as offensive
DasMauser

Send message
Joined: 16 Mar 17
Posts: 3
Sweden
Message 76521 - Posted: 18 Mar 2017, 19:23:00 UTC - in response to Message 76485.  

ah ok, thanks a lot. My code-fu need more practice.
ID: 76521 · Report as offensive
DasMauser

Send message
Joined: 16 Mar 17
Posts: 3
Sweden
Message 76522 - Posted: 18 Mar 2017, 20:28:07 UTC - in response to Message 76485.  
Last modified: 18 Mar 2017, 20:29:46 UTC

Im sorry i still can not get it to work
I have made sure to have the file cc_config.xml and in the ANSI encoding (read on another forum that was important). In that file i have written
<cc_config>
<options>
<exclude_gpu>
<url>http://einstein.phys.uwm.edu/</url>
<device_num>0</device_num>
</exclude_gpu>
</options>
</cc_config>
the file is located in C:\ProgramData\BOINC that is the Data directory. I'm not sure why the <url> is there but i tried both with and without that part.

Still the event log shows that GPU 0 is active and 1 is not used:

18/03/2017 21:19:15 | | Starting BOINC client version 7.6.33 for windows_x86_64
18/03/2017 21:19:15 | | log flags: file_xfer, sched_ops, task
18/03/2017 21:19:15 | | Libraries: libcurl/7.47.1 OpenSSL/1.0.2g zlib/1.2.8
18/03/2017 21:19:15 | | Data directory: C:\ProgramData\BOINC
18/03/2017 21:19:15 | | Running under account XXXXXXXXX
18/03/2017 21:19:16 | | CUDA: NVIDIA GPU 0: GeForce GTX 970 (driver version 378.78, CUDA version 8.0, compute capability 5.2, 4096MB, 3391MB available, 4087 GFLOPS peak)
18/03/2017 21:19:16 | | CUDA: NVIDIA GPU 1 (not used): GeForce GTX 550 Ti (driver version 378.78, CUDA version 8.0, compute capability 2.1, 1024MB, 817MB available, 691 GFLOPS peak)
18/03/2017 21:19:16 | | OpenCL: NVIDIA GPU 0: GeForce GTX 970 (driver version 378.78, device version OpenCL 1.2 CUDA, 4096MB, 3391MB available, 4087 GFLOPS peak)
18/03/2017 21:19:16 | | OpenCL: NVIDIA GPU 1 (ignored by config): GeForce GTX 550 Ti (driver version 378.78, device version OpenCL 1.1 CUDA, 1024MB, 817MB available, 691 GFLOPS peak)

Are there any special things i have to turn in the Log Flags (ctrl+shift+f) to make it activate config file or something? i can not find anything else under the wiki
ID: 76522 · Report as offensive
Profile Ageless
Volunteer moderator
Project administrator
Volunteer tester
Help desk expert
Avatar

Send message
Joined: 29 Aug 05
Posts: 12589
Netherlands
Message 76523 - Posted: 18 Mar 2017, 21:05:33 UTC - in response to Message 76522.  

Two things.

1. Make sure the file is called cc_config.xml and that when you made it it didn't get an extra .txt extension, as then it doesn't work. If need be, show file extensions in Windows Explorer options.
2. Add use_all_gpus as well, as without that BOINC might still ignore the second GPU. All GPU decisions are made at BOINC startup, but as far as I know, the use_all_gpus bit of code is done before excluding any GPU.

So:
<cc_config>
<options>
<use_all_gpus>1</use_all_gpus>
<exclude_gpu>
<url>http://einstein.phys.uwm.edu/</url>
<device_num>0</device_num>
</exclude_gpu>
</options>
</cc_config>

Jord
Please do not private message me for tech support. Use the forums for that. Tech PMs will be ignored.

quote: "Isn't the best defense always a good attack?"
ID: 76523 · Report as offensive

Message boards : GPUs : Can not configure GPU's

Copyright © 2018 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.