AMD deprecating fglrx driver on ubuntu 16.04

Message boards : GPUs : AMD deprecating fglrx driver on ubuntu 16.04
Message board moderation

To post messages, you must log in.

AuthorMessage
Ron

Send message
Joined: 19 Jul 16
Posts: 1
United States
Message 70938 - Posted: 19 Jul 2016, 0:43:16 UTC

Is the open source driver that comes with the ubuntu distros(specifically ubuntu mate 16.04) able to crunch anything gpu related? Any word on when amd will come out with amdgpu or whatever they are calling the replacment? Will this be a drop in replacement for fglrx for 16.04 when in comes out? I searched around but I can't find anything about how far away this driver is for 16.04. Should I just go ahead and drop down to 14.04 till the end of the year?
ID: 70938 · Report as offensive
Juha
Volunteer developer
Volunteer tester
Help desk expert

Send message
Joined: 20 Nov 12
Posts: 801
Finland
Message 70941 - Posted: 19 Jul 2016, 13:10:35 UTC - in response to Message 70938.  

I suppose it depends on what GPU you have.

AgentB is successfully running RX 480 with amdgpu driver over at Einstein. It seems that driver doesn't support older cards yet. RX 480 Results

And other people are running Mesa OpenCL with older cards. Mesa OpenCL then doesn't support newer cards yet. See All Einstein@Home jobs fail immediately on starting and the linked threads.
ID: 70941 · Report as offensive
Profile Agentb
Avatar

Send message
Joined: 30 May 15
Posts: 265
United Kingdom
Message 70960 - Posted: 20 Jul 2016, 20:01:59 UTC - in response to Message 70941.  

Yes the new AMDGPU supports GCN 1.2 and later, and is much easier to setup than the fgrlx. The driver is a lot more stable than i expected.

See also

Ubuntu 16.04 LTS Is Deprecating AMD's fglrx (Catalyst) (released this month)
ID: 70960 · Report as offensive

Message boards : GPUs : AMD deprecating fglrx driver on ubuntu 16.04

Copyright © 2020 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.