wiki:SoftwarePrereqsUnix

Version 7 (modified by davea, 11 years ago) (diff)

--

Software prerequisites (Unix/Linux?)

The various parts of BOINC have dependencies on other software; most or all of these may already be present on your system. You'll need to download and install the ones you don't have. The list depends on the system you're on, and the parts of BOINC that you need. If you're creating a BOINC project, you don't need to build the Core client or BOINC Manager.

Server Core client BOINC Manager Applications (non-graphical) Applications(graphical)
GNU tools (find them here): make 3.79+, m4 1.4+, libtool 1.4+, pkg-config 0.15+, autoconf 2.58+, automake 1.8+, GCC 3.0.4+ X X X X X
Python 2.2+ with MySQLdb module 0.9.2+ (see installation instructions) and xml module X
MySQL 4.0 or higher (with mysql-devel, and mysql-client) X
Apache with mod_ssl and PHP5+ X
PHP5 with php5-cli package X
OpenSSL version 0.9.8+ X X
libcurl version 7.15.5+ X
WxWidgets 2.8.3 (Configure with the --with-gtk --disable-shared options; BOINC needs a static library. If you have an older Wxwidgets installed, uninstall it (make uninstall), then install 2.6. Make sure you have the 'development' version installed. X
Graphics libraries: GL, GLU, GLUT (or freeglut). You'll need a static (.a) version of GLUT or freeglgut (some Linux distributions come with only a dynamic version). Use the 'development' version of GLUT or freeglut. X
jpeglib, X11 libraries and include files X X