2nd GPU of 4870x2 stays in 2d clocks

log in

Advanced search

Message boards : GPUs : 2nd GPU of 4870x2 stays in 2d clocks

Author Message
Timi
Send message
Joined: 1 Nov 09
Posts: 12
Message 37723 - Posted: 9 May 2011, 17:18:28 UTC
Last modified: 9 May 2011, 17:20:09 UTC

I'm using BOINC 6.12.26, Lunatics ap_5.06_win_x86_SSE2_OpenCL_ATI_r456 and Lunatics MB_6.10_win_SSE3_ATI_r177 (both on seti@home).
My 4870x2 is using Catalyst 11.4 and it seems that during the process of a workunit on the 2nd GPU (AP or MB), the clocks stay at 2d mode (500MHz), when the 1st GPU is at 750MHz as it should be.
Both GPUs were found during BOINC Manager startup with same\correct capabilities.
Possibly it is a Catalyst fault, but is there any option to force 3D clocks on the 2nd GPU through app_info.xml or cc_config.xml ?

FYI, running FurMark both GPU goes into 3D clocks.

Profile Ageless
Volunteer moderator
Project administrator
Avatar
Send message
Joined: 29 Aug 05
Posts: 8891
Message 37725 - Posted: 9 May 2011, 17:33:53 UTC - in response to Message 37723.

Forwarded to development. In the mean time, no there is no way to force the GPU to do anything with regard to calculations and clocks.
____________
Jord

Claggy
Send message
Joined: 23 Apr 07
Posts: 890
Message 37730 - Posted: 9 May 2011, 21:08:00 UTC - in response to Message 37723.
Last modified: 9 May 2011, 21:50:49 UTC

Better to ask in Number Crunching on the Seti Boards, or at Lunatics if you have an account there.

Do know that the r456 AP app isn't the latest ATI AP app, r516 is the latest Released app, and r521 is in Beta testing, (r505 and later is quite a bit quicker)

Have you tried other Catalyst drivers yet? is it the same with Catalyst 11.2, 11.3 or 11.5?

Claggy

Claggy
Send message
Joined: 23 Apr 07
Posts: 890
Message 37732 - Posted: 9 May 2011, 23:22:27 UTC - in response to Message 37723.

From the r449/r456 Release Notes:

Known issues::

1) App will not work (no progress on secondary chip at all or will produce invalid results) on second core of dual-core GPUs like 5970 and will produce invalid results(or no progress at all) with CrossFire enabled on non-primary GPUs in system.
It's ATI SDK2.2 related bug, ask ATI for fix.

timiman also reported problems on his 4870x2 (in same thread):

Good news, managed to download another task for the 2nd GPU.
Bad news, 3D clocks do not kick in, so 2nd GPU is running on 507MHz and not in 750MHz (possibly an error of 10.9 Catalysts as this appears on some games also).

No one has reported on the Seti Forums or at Lunatics whether the r177 MB app or later AP apps work correctly or not on this GPU,

Claggy

Timi
Send message
Joined: 1 Nov 09
Posts: 12
Message 37744 - Posted: 10 May 2011, 15:57:33 UTC
Last modified: 10 May 2011, 15:57:58 UTC

I have updated:
a. Catalyst from 11.4 to 11.5a Hotfix
b. AP from r456 to r516
and also reinstalled AMD SDK 2.4 just to be sure I have the latest version.

The 2D clocks remain on the 2nd GPU, processing MB r177 now, as I run out of AP workunits.

Is there any place you can provide me, so I can post inform AMD of that, if it is their "bug"?

Thanks.

Claggy
Send message
Joined: 23 Apr 07
Posts: 890
Message 37747 - Posted: 10 May 2011, 20:30:26 UTC - in response to Message 37744.

Is there any place you can provide me, so I can post inform AMD of that, if it is their "bug"?

At AMD's Driver download page there is a driver feedback link:

AMD Radeon™ Video Card Drivers

or at the AMD Developer's OpenCL forum:

AMD Developer» Software Development Topics » OpenCL™

Claggy

Vepide
Send message
Joined: 8 Jul 11
Posts: 5
Message 38832 - Posted: 8 Jul 2011, 5:06:11 UTC - in response to Message 37723.

Actually you can try Forcing Maximum Performance on both GPU's from your tray icon, right click your tray icon and select the "Force Maximum Performance Clocks" under the 3D settings sub-menu.

Though i dont know of any way or "option to force 3D clocks on the 2nd GPU through app_info.xml or cc_config.xml ?"

I have a 4870 X2 also, can run my core to 800 Mhz and that's been stable for three years now, except only one older driver version accepted the full memory overclock without any issues, and current drivers don't seem to allow any memory overclocking for some reason.

Claggy
Send message
Joined: 23 Apr 07
Posts: 890
Message 38834 - Posted: 8 Jul 2011, 9:02:43 UTC - in response to Message 37744.

AMD's OpenCL system requirements lists the supported devices:

5900 Series (5970) and 4870 X2 are supported, but Supported in single-GPU mode only.

System Requirements & Driver Compatibility

Claggy

Timi
Send message
Joined: 1 Nov 09
Posts: 12
Message 39376 - Posted: 30 Jul 2011, 18:43:45 UTC

With Catalysts 11.7 and 11.8 preview, it is even worst!
Both GPUs stay at 507MHz running SETI!!!
Back to 11.5rc5

I hope that AMD APP v2.5 will bring full support on the 4870x2 ...

Timi
Send message
Joined: 1 Nov 09
Posts: 12
Message 39644 - Posted: 13 Aug 2011, 6:06:22 UTC

Well, just tried APP 2.5 together with Official Cats 11.7, and again both clocks stays at 2D mode...

Message boards : GPUs : 2nd GPU of 4870x2 stays in 2d clocks


BOINC home page · Log in · Create account

Copyright © 2014 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.