BOINC 7.6.33 Debian Jessie Build/Run issue

Message boards : BOINC client : BOINC 7.6.33 Debian Jessie Build/Run issue
Message board moderation

To post messages, you must log in.

AuthorMessage
Ken Linder

Send message
Joined: 27 Jul 11
Posts: 18
United States
Message 73452 - Posted: 19 Oct 2016, 20:52:31 UTC
Last modified: 19 Oct 2016, 20:57:11 UTC

Trying to get my AMD GPU recognized and running. A few helpful folks in the GPU section suggest I go here https://packages.debian.org/source/stable-backports/boinc and build a more up to date version. 7.4.23 was the most recent in the repositories.

So, I pull down the file boinc_7.6.33+dfsg.orig.tar.gz, unpack it, and do the following after resolving all the broken dependencies...
./_autosetup
./configure --disable-server --enable-client --enable-manager CXXFLAGS="-O3 "
make
su
make install


When I run this:
/etc/init.d/boinc-client start


I see the following error:
ERROR: /var/lib/boinc is not owned by boinc.  [FAILED]


I did this:
chown boinc:boinc boinc


The directory looks like this:
drwxr-xr-x 2 root     root     4096 Apr  3  2016 aspell
drwxr-xr-x 2 boinc    boinc    4096 Oct 19 14:45 boinc
drwxr-xr-x 5 boinc    boinc    4096 Oct 19 08:06 boinc-client
drwxr-xr-x 3 colord   colord   4096 Apr  3  2016 colord


Still receive the same error when attempting to start the client.

FWIW, BOINC ver 7.4.23 worked fine, except it had issues with my new AMD/ATI GPU.

Thoughts anyone??

Thanks!
-Ken
ID: 73452 · Report as offensive
Profile Agentb
Help desk expert
Avatar

Send message
Joined: 30 May 15
Posts: 265
United Kingdom
Message 73454 - Posted: 19 Oct 2016, 21:17:28 UTC - in response to Message 73452.  

Trying to get my AMD GPU recognized and running. A few helpful folks in the GPU section suggest I go here https://packages.debian.org/source/stable-backports/boinc and build a more up to date version. 7.4.23 was the most recent in the repositories.


You need to add (deb) jessie-backports to your list of repos in Synaptic (assumes you run that for packaging) AND crucially set distribution preferences to select jessie-backports

Then allow it to upgrade.

Manually installing is not recommended.
ID: 73454 · Report as offensive
Ken Linder

Send message
Joined: 27 Jul 11
Posts: 18
United States
Message 73455 - Posted: 19 Oct 2016, 21:45:34 UTC - in response to Message 73454.  

Manually installing is not recommended.

AHH! I was just trying to make it difficult for myself. :-)

OK, I added the backport repository to sources.list and installed 7.6.33

Unfortunately, same problem as before, for the most part. It doesn't recognise my GPU. Will continue with more details in that thread.


Thanks!
ID: 73455 · Report as offensive

Message boards : BOINC client : BOINC 7.6.33 Debian Jessie Build/Run issue

Copyright © 2017 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.